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Chapter 1: DIADesigner-AX Overview

DIADesigner-AX is the IEC 61131-3 programming tool for Delta’s new generation
motion controller — AX series and adopts many applied instructions, especially
Motion library.

The multilingual environment and the user-friendly interface provide a convenient

and efficient development environment.

DIADesigner-AX Version 1.8.0
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1.1 DIADesigner-AX Function

DIADesigner-AX provides:

* All editors of the IEC 61131-3 (FBD, LD, ST, SFC) and different variants of the
standard editors.

* Powerful and proven library concept for the reuse of application.
* Project configuration through wizards.
* Input assistance for the input and configuration of data.

* User-friendly programming with mouse and keyboard in all IEC 61131-3
editors.

* Extensive debugging and online features for the fast optimization of the
application code and to speed up testing and commissioning.

* Numerous security features for the protection of the source code and for
safeguarding the operation of the controller.

* Programmable devices from different manufacturers.
* Extendible and adaptable user interfacewithout leaving the framework.

* Transparent internal structures of the development tool and the available
components.

* Many seamlessly integrated tools for different kinds of automation tasks.

* Two built-in configurations:
Hardware Configuration: It is used to configure hardware for a system, and
manage parameters.
Network Configuration: It is used to configure networks for a PLC system,
and manage data exchanges.
DIADesigner-AX provides various solutions for motion control including
PLCopen MC function block, G-code editor, E-CAM editor, positioning

DIADesigner-AX Version 1.8.0

planning chart tool and many more.
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* Support PLCopen POUs for single and multi-axis movements.

* Support PLCopen POUs for add-on functions like diagnostics, stop, CAM

controller.

* Additional POUs for different tasks like monitoring dynamic data or following

error, operating CAMs and CAM controllers.

* Integrated graphical CAM editor with extensive configuration options

¢ Virtual and logical axes are supported.

* Integrated drivers for numerous, CANopen and EtherCAT drives.

¢ Configuration of the Drives / Servo based on standard field devices.

1.2 Supported Devices

DIADesigner-AX v1.8.0 supports the following devices. For more information about

the devices, see the device documentation.

Type Product Series
Motion PLC:
* AX-304ELAOPA1T, AX-304ELAOPA1P,
AX-308EAOMA1T, AX-308EAOMA1P, AX-316EAOMA1T,
AX-332EPOMB1T, AX-332EPOMB1P,
AX-364ELAOMA1T
Controller

AX-516EBOMB1P, AX-516EBOMB1T, AX-532EBOM-
B1P, AX-532EBOMB1T, AX-564EBOMB1P, AX-564E-
BOMB1T, AX-564ELBOMB1T, AX-564ELBOMB1P

AX-8xxXEPO Linux series, AX-8xxEPO Windows series

DIADesigner-AX Version 1.8.0
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Type Product Series

* AX-864E30CE2T, AX-864E30ME2T, AX-8H1E30CD2T,
AX-8H1E30CD2P, AX-864EP1ME1TP

* AX-CO6EBOMD1T, AX-CO6EBOMD1P, AX-C12E-
BOMD1T, AX-C12EBOMD1P, AX-C12EBOCD1T, AX-
C12EBOCD1P, AX-C24EBOMD1T, AX-C24EBOMD1P

Logic PLC: AX-300NAOPA1, AX-324NAOPA1P

C2000 plus series, MS300 series, MH300 series, CH2000
se-ries, MX300-E series

AC Motor Drive

ASDA-A2-E series, ASDA-B3-E series, ASDA-A3-E series,
AC Servo Drive ASDA-A3-EP series, ASDA-W3-E series, ASDA-E3-E series,
ASDA-E3C series, ASDA-H3-E series

EtherCAT: R1-C series, R1-EC series, R2-EC series, R3-C
series, RTU-ECAT series, AX-500CECO00 series, ASRTU-EC
Remote 1/0O series

EtherNet/IP: AS200 series, AS300 series, AHCPU series
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Chapter 2: Installation

This chapter introduces how to use DIAlnstaller to install, uninstall, and update
DIADesigner-AX.
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2.1 System Requirements

The following table lists the system requirements to run DIADesigner-AX.

Item System Requirements

Operating System | Windows 10/11 (64-bit)

Intel Celeron 540 1.8 GHz (min.)

CPU _ .
Intel Core i5 M520 2.4 GHz (min.)

Memory 4 GB or above

Hard Disk Drive 10 GB or above

Monitor Resolution: 1920 x 1080 Pixels recommended

Keyboard/Mouse | General keyboard mouse or Windows-compatible device

PC interface EtherNet, USB, Serial port (depends on product interface)

Software Need to install Microsoft .Net Framework 4.8

2.2 Install DIADesigner-AX

DIAInstaller is used to easily download, install, uninstall, and update all DIAStudio
software. You can download DIAlnstaller from diastudio.deltaww.com. For more
information about DIAInstaller, see DIAInstaller User Manual.

Prerequisites

* DIlAlnstaller is installed.

To install DIADesigner-AX

1. Open DIAlnstaller.

2. Click| 2 atthe upper-right corner to sign in.

3. Go to All Apps and find DIADesigner-AX.

4. |n Available Versions, select a version.
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5. Click : and then select Install.

6. Select components to install. You can select the full components or customize
the components to install.

7. In the DIADesigner-AX dialog, follow the on-screen instructions to complete
the installation.

Note:

° You can click Updates to check if there are any new versions or
patches.

° You can configure the settings of DIAInstaller by clicking i

o Starting from version 1.7.0, you can install two different versions of
DIADesigner-AX on the same computer.

2.3 Uninstall DIADesigner-AX

Follow the steps to uninstall DIADesigner-AX in DIAInstaller.
To uninstall DIADesigner-AX
1. In DIAInstaller, go to Installed, and select Uninstall.

2. Select the components to uninstall. You can select the full components or
customize the components to uninstall and then click Uninstall.

3. Inthe DIADesigner-AX dialog, follow the on-screen instructions to complete
the uninstallation.

2.4 Update DIADesigner-AX

Follow the steps to update DIADesigner-AX.

To update DIADesigner-AX
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1. In DIAlInstaller, go to Updates.

2. Find DIADesigner-AX.
3. In Available Versions, select a version.

4. Do one of the following:

o Select Update and then follow the on-screen instructions to complete the
update.

o (Click : and select Download to download the installation file to the local

path, and then select Show in folder to find the EXE file to install.
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Chapter 3: Getting Started with DIADesigner-AX

DIADesinger-AX adhares to the IEC-61131 standard progromming. In this quick start
example, you will program a simple refrigerator controller.
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3.1 Example Description

The completed project RefrigeratorControl.project_archive can be found in the
DIADesigner-AX installation directory in the Projects sub-directory. In addition to the
sample project, you will create one here step-by-step.

* As with a conventional refrigerator, the user specify the temperature via rotary
control.

* The refrigerator determines the actual temperature using a sensor. When it is
too high, the refrigerator starts the compressor with an adjustable delay.

* When the desired temperature is reached, the compressor will start to cool
down minus one degree of hysteresis. The hysteresis here prevents the actual
temperature from fluctuating too much within the range of the set temperature,
causing the compressor to be turned on and off continuously.

* When the door is open, a lamp lights up inside the refrigerator. When the door
is open too long, a beeping acoustic signal sounds.

* [f the compressor does not reach the set temperature despite the activity of
the motor over a long period of time, then the buzzer emits a steady acoustic
signal.

The cooling function is controlled by the main program in the application, while
another POU controls the signal management. There are required function blocks in
the standard library. The example has no physical temperature sensor or actuator,
so you must write a program to simulate heating/cooling. In this way, the operation of
the refrigerator controller can be monitored in the online mode.

3.1.1 Create a Project
After the project is created, it is stored in a .project file in the folder you specified.

To create a project
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1. Do one of the following:

° On Start Page, click New Project.

° On the quick access bar, click =,

o Select File > New Project.

2. In the New Project dialog, select Standard Project as a template, specify a
name and a storage location for the project, and then click OK.

3. Inthe Standard Project dialog, select the controller, DDF version, and
programming language, and then click OK.

3.1.2 Add a Device

DIADesigner-AX supports controllers, servo drives, and AC drives. After the project
is created, you can add devices to the project or the device levels.

To add a device

1. On the Devices pane, right-click the project name or a device, and then select
Add Device.

2. Inthe Add Device dialog, select the device, enter Name, and then click Add
Device.

Only the latest version of the device is listed by default. If you want to select the
earlier versions of the device, select the Display all version (for experts only)
checkbox.

3.1.3 Set up Communication

You can use Communication Settings to configure and establish communications
with the controller.

Prerequisites

* Set up the local gateway.

To establish communications with the controller
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1. On the Devices pane, double-click the controller.

2. Go to Communication Settings.
3. Click Scan Network.

4. Inthe Select Device dialog, select your controller.

[e]

The IP-Address and MAC-Address are N/A if you specify the username
and password in the controller.

° If you select an AX-8xxEPO Linux series controller, the IP-Address and
MAC-Address will show if the controller firmware version is 1.0.4.4 or later.

° [f you select an AX-8xxEPO Windows series controller, the IP-Address and
MAC-Address will show if the controller firmware version is 1.0.4.12 or
later.

° There are two EtherNet ports on both AX-8xxEPO Linux and AX-8xxEPO
Windows series controllers. The first IP-Address and MAC-Address are for
GLAN1 and the second IP-Address and MAC-Address are for GLANZ2.

Communication Settings Scan Network | Gateway v  Device ~
Applications
Backup and Restore
Files —_— . o .
Gateway
Log
[Gatenay-1 v|  [peeceiT23320006 (actve) V]
PLC Settings IP-Address: Device Name:
localhost 88PCE1T23320006
PLC Shell .
Port: Device Address:
1217 00F5
Licensed Software Metrics
System Settings —19;168.1.1 GLAN1
1 q 4 a n
S [TOZTE85025] GLAN2
Right Setti > H
S :18: 133274:d7! GLAN1
118123103 /4% GLAN2
System Parameters
FW-Version:
Task Deployment 1.0.5.10
Target ID:
Status 16F7 0411
Target Type:
Information 4102
TargetVendor:
Delta Electronics
TargetVersion:
3.5.18.30

5. Click OK. The device is active and the information shows on the

DIADesigner-AX Version 1.8.0
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Communication Settings

Applications

Backup and Restore

Files

Log

PLC Settings

PLC Shell

Licensed Software Metrics

System Settings

Right Settings

System Parameters

Task Deployment

Status

Information

Scan Network | Gateway v  Device v

(] o
Gateway .

Im v | I 00F0] (active) v |
IP-Address: Device Name:
localhost AX-308EAOMALT
Port: Device Address:
1217 00F0

IP-Address:

192.168.50.240

MAC-Address:

00:18:23:b2:93:6b

Target ID:
16F7 0314

Target Type:
4102

TargetVendor:
Delta Electronics, Inc.

TargetVersion:
1.0.7.0

6. Go to System Settings.

7. In the Network area, click Read from PLC to synchronize the IP address from

the controller.

Note:

° If you select an AX-8xxEPO Linux series controller, the Read

from PLC function will be available if the controller DDF version is

3.5.15.21 or later and the controller firmware version is 1.0.4.4 or

later.

° [If you select an AX-8xxEPO Windows series controller, the Read

from PLC function will be available if the controller DDF version is

3.5.14 .17 or later and the controller firmware version is 1.0.4.12 or

later.

3.1.4 Configure Network

Network Configuration Editor shows the industrial network topology and provides

an intuitive and visible approach to configuring the network. After the device is
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added, you can view its network topology, add devices, and configure the network
connection.

To set up a network connection
1. On the Devices pane, double-click Network Configuration.

2. On the Product List pane, double-click the device or drag it to Network
Configuration Editor.

3. Click the device port icon and drag it to the network line or other device’s port to
set up a network connection.

€ Untitled1.project” - DIADesigner-AX
File Edit View Project Build Online Debug Tools Window Help
ABRIEO©-0 0 o § BB XYM N 9% &9 ¥ Application [Controller 1: PLCLogic] » &8 & ) w W 5 5 [[2622=02 3 |0 W[

Devices. v 3 X A, Network Configuration Editor X v | | Product List Editor v 31X

=13 Untited: MEYRTRONY

@ [0 == *l
= controler_1 (AX-8xxEPO Linux SM Series) | [String for a full text search
o8 Hardware Configuration EtherCAT
=- & Network Configuraton [ ModbusTCP/EtherNetlP All Vendors n
A, EtherCAT T 1 Hodus v F
eICATTeploy & & (0] Display All Versions
= B0 pLCLogic & &
Z Y Aot ¢ 9
{3 Application Product List
() Library Manager . m L
2] Motion_PRG (PRG) N o
= (& Task Configuration o 3 « O Fieldbuses
=& EtherCAT Task (IEC-Tasks) s 4 @ EtherCAT
8] Motion_PRG Series 4 9 ASD
& MainTask (IEC Tasks) i e
= () EtherCAT_1 (AX-B0EP0 Series EtherCAT BaEn
= (7) Drive_1 (Delta ASDA-AZ:E EtherCAT( il Delta ASDA-A2
B4 DML Drive_ETC_Delta_ASDA_A [ Delta ASDA-A3
= @ suitn Guien) [ Deta ASDA-A3
() Buitin_DIO (Builtin_DIO)
(7 suittn_puise_ Encoder (uitin_Puise_ 0 Deta ASDABS
2 SoftMotion General Axis Pool Ethernet_1 Delta ASDA-B3
= controler_2 (AX-308EAOMA1T) ! Delta ASDAE3
8 Hardware Configuration } Deta ASDAE3
=&, Network Configuration
Ha
M EtherCAT Topdogy [ Detta ASDAHZ

A, EtherNetlP Topology

[ Delta ASDAW:
A, ModbusTCP Topology

B b % ASRTU
= @l pLcLogc oy
= Atlog ASDA-R2-E b AXS
=} Applcation EtherCAT
D vieary Manager (Cof) Drve i e b % RIC
= < >
E] Motion_PRG (PRG) L
[ E,; PRG (RG) Version: 14,00
Task Configuration > o Advanced Type ASDA-A2-E
= EtherCAT Task (EC Tasks) & o EtherCAT(CoE) Drive RevA,
8 votion PRG v Positioning Axis
< >
5 Devices | ) PoUs VI
{E| Messages - Total 0 error(s), 0 warning(s), 12 message(s)
Lastbuid: © 0 ® 0 Precomple o/ Project user: (nobody) Q

3.1.5 Configure Hardware

In the Hardware Configuration editor, you can add modules to the controller, scan
devices, and view the device information.

To add a module to the controller
1. On the Devices pane, double-click Hardware Configuration.

2. In the Hardware Configuration editor, click the extension placeholder.
Available modules will be listed in Product List.
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3. Expand Product List and do one of the following:

o  Double-click the module.

° Drag the module to the placeholder.

¢ Hardware Configuration [Controller_1] X

4

\Prowctustsﬁw v X

Q & EherCAT- therCAT.1 v M =—t
i (7] Display Al Versions
c
b :
Product List
) o=+ Total Module Width: 110mm b 8 Analog 0 Modules

2 (Internal) Curent Consumption: 458mA
“2\(External) Current Consumption; 0mA
pPower Current Qutput; OmA

b @) Digtal IO Modules
b {8) Nebiork Modules

b {8) PostioninglCounler Module

0 hes{Tota Module Widh: 25 5mm
‘ff"'" &2 (Internal) Current Consumption: 90mA
€2 (Extenal) Current Consumption: OmA
H b Povier Curent Output; ImA
|

3.1.6 Declare Variables

Before creating a program, you need to declare the variables for the application by
creating a Global Variable List under Application.

To declare variables

1. On the Devices pane, right-click Application, and then select Add object >
Global Variable List.

2. In the Add Global Variable List dialog, enter the name for the list and then
click Add. The default name is GVL.

3. Click @ to switch to the tabular view.

4. Click LZ lto insert a new variable.

5. In the Name box, enter rTempActual.
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6. Do one of the following to select Data type.

o Enter the initial letter “R” of the data type, and then select REAL from the
list shown below.

o Double-click the Data type box and click || and then selectinput

Assistant dialog, on the Categories tab, select Standard Types > REAL,
and then click OK.

7. In the Initialization box, enter a number value, for example, 8.0.

8. Declare the following variables in the same way.

Name Data Type Initialization Description
rTempActual REAL 1.0 Actual temperature
rTempSet REAL 8.0 Set temperature.
xDoorOpen BOOL FALSE Status of door
timAlarmThreshold | TIME TIME#30S The time the compres-

sor runs before the signal
sounds
timDoorOpen- TIME TIME#10S The time to open the door
Threshold after the signal sounds
xCompressor BOOL FALSE Control signal
xSignal BOOL FALSE Control signal
xLamp BOOL FALSE Status message
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Devices v B x| P x
=43 Uhtteds =l ¢ & X
-8 i);w::(fm:\ OﬁM Al‘l’: " Scope  Name Address  Datatype  Initialization ~ Comment Attributes
=& NELNQIECO:;;::O:H @ .. rTempActual REAL 1 Actual temperature
A EtherCAT Topdlogy @ .. rempset REAL 8 Settemperature,
A EtherNett? Topdlogy 3 @ A.. xDoorOpen BOOL FALSE Status of door
A o usTC Topdogy § ﬂ VA... timAlarmThreshold TIME TIMEZ30ms  Thetimethe compressorruns beforethe signal sounds
= ::jﬂ PLC Loge § ﬂ VA... timDoorOpenThreshold TIME TIME210ms  Thetimeto open the door after the signal sounds
=} Application ¢ @ VA. xCompressor B0OL FALSE Control signal
@on 7 @A Signal BOOL FALSE Control signal
mubraryl‘danager | @ .. xtamp BOOL FALSE Status message
[£] Maton_PRG (RG)
5] pLc_pro (R9)
= @3 Task Configuration
= EtherCAT Task (EC Tasks)
8] otion_pRG
=85 MainTask (EC-Tasks)
&) nic e
=-(fJ Buitin_1o Buitin 10)
(oo (o10)
Ei‘i Delta_LocalBus_Master (Delta LocalBus Mastq
@ EtherCAT Master_SoftMotion (AX Series Eth
ﬂ‘] Ethernet (Etheret)
4 Softotion General Ais Pool

3.1.7 Programming

Programming is creating internal logic for a programmable logic controller (PLC).
This section introduces how to use different types of languages to create programs
to realize a cooling control project.

3.1.7.1 Create a Program for Cooling Control in the CFC Editor

The compressor is activated and cooled if the actual temperature is higher than the
temperature set point plus a hysteresis. The compressor is switched off if the actual
temperature is lower than the temperature set point minus the hysteresis.

You can describe a main function of the application program in the main program
block PLC_PRG, which is created by default.

Prerequisites

* Declare the variables mentioned in Declare variables.

To create a main program for cooling control in the CFC editor
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1. Create a standard project.

2. In the Standard Project dialog, select Continuous Function Chart (CFC) for
PLC_PRG in.

3. On the Devices pane, double-click PLC_PRG.

4. On the Delta ToolBox pane, drag Input to the editor.

5. Click L]

6. Inthe Input Assistant dialog, select Application > GVL > rTempActual to
assign the variable to Input.

7. Drag another Input and assign variable rTempSet to it.
8. Drag another Input and rename it with rHysteresis.

9. Declare the variable. Select Data type as REAL and enter 1 for Initialization.

10. Drag Box to the editor and enter ADD in .
11. Connect the rTempSet and rHysteresis pins to the ADD input pins.

12. On the Delta ToolBox pane, drag Box to the editor on the right side of the
ADD function block and enter GT in .

13. Connect the rTempActual pin to the upper input pin of the GT function block.

14. Connect the ADD function block output pin to the lower input pin of the GT
function block.

15. On the Delta ToolBox pane, drag Box to the editor on the right side of the GT
function block and enter SR in to start or stop the cooling compressor.

16. Declare the variable name as SR_0 and Data type as SR.

17. Connect the output pin of GT function block to the SET1 input pin of the SR_0
function block.

18. Drag Output to the editor and assign variable xComppressor to it.

19. Connect the xCompressor pin to the SR output pin Q1.
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20. Set up a condition under which the compressor should be turned off again
(under this condition, the RESET input of the SR function block will get a
TRUE signal). Use SUB (subtraction) and LT (less than) function blocks.

@ o [g) PLC_PRG x
v ¢ X PROGRAM PLC_PRG

~

Scope Name Address  Datatype Initialization ~ Comment  Attributes
lI & VAR rHysteresis REAL 1
P VR  SRO R

SET1 al =xComp
R

=rTempSet | ADD

1
SuB

3.1.7.2 Create a Program for Signal Management in the LD Editor

Now you need to implement the signal management program for the alarm
buzzer and for power switch of the lamp. The ladder diagram (LD) language is
recommended.

Create the following three signal programs respectively in three networks in the LD
editor:

* A continuous acoustic signal sounds when the compressor runs too long
because the temperature is too high.

* An intermittent signal sounds when the refrigerator’s door is open for too long.

* The light is on as long as the refrigerator’s door is open.

To create a continuous acoustic signal program in the LD editor

DIADesigner-AX Version 1.8.0



A BELTA Chapter 3: Getting Started with DIADesigner-AX

1. On the Devices pane, right-click Application and then select Add Object >
POU.

2. Inthe Add POU dialog, enter Signal for name and select Ladder Logic
Diagram (LD) for Implementation Language.

3. Click Add.

4. On the Delta ToolBox pane, expand Function Blocks and then drag TON to
the first network (Network 1) in the editor.

5. Declare the variable name as TON_0 and Data type as TON.

6. Assign variable xCompressor to the upper input of the TON function block so
that the function block is activated as soon as the cooling compressor starts to

run.

7. On the Delta ToolBox pane, expand Ladder Elements and then drag Coil to
the editor.

8. Assign variable xSignal to the coil.

9. Assign variable timAlarmThreshold to the input pin PT of TON_O0 to define
the time from the activation of TON_0 to when the signal should sound.

10. Right-click TON and then select Remove unused FB call parameters.

To create an intermittent signal program in the LD editor

—_—

Right-click Network 1 and then select Insert Network (Below).

N

On the Delta ToolBox pane, drag TON to Network 2.

3. Declare the variable name as TON_1 and Data type as TON.
4. Assign variable xDoorOpen to the input pin IN.

5. Assign variable timDoorOpenThreshold to the input pin PT.

As in Network 1, you implement TON for time-controlled activation of the
signal. This time it is triggered by the global variable GVL.xDoorOpen and
GVL.timDoorOpenThreshold.

6. On the Delta ToolBox pane, drag Box to the output pin Q of TON_1.
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7. Add blink in the library and declare the variable name as blink_1 and Data
type as BLINK.

8. Assign variable blink_1 to the function block.

9. On the Delta ToolBox pane, drag two Contact and connect to the OUT output
pin of the BLINK function block.

10. Assign variable TON_1.Q to the contact directly after the output Q and assign
the global variable xDoorOpen to the second contact.

11. Drag Coil after the two contacts and then assign the global variable xSignal.

12. Declare the local variable timSignalTime : TIME := T#1S; and assign this
variable to the input pins TIMELOW and TIMEHIGH.

The cycle time is 1 second for TRUE and 1 second for FALSE.

13. Right-click TON and then select Remove unused FB call parameters.
The signal should sound intermittently when the door is open too long.
To create a turning lamps on program in the LD editor

1. Right-click Network 2 and then select Insert Network (Below).

2. Drag Contact to Network 3 and assign global variable xDoorOpen.

3. Drag Coil next to it and assign global variable xLamp.
The lamp should be on as long as the door is open.

DIADesigner-AX processes the networks of an LD in succession. You need to insert
a jump to Network 3 at the end of Network 1 to ensure that after running Network1,
Network 3 runs.

To add a label and jump to run Network 3 after running Network 1

1. Right-click Network 3 and then select Insert Label.

N

Replace the text with DoorlsOpen.

3. On the Delta ToolBox pane, drag Jump to the Network 1.

‘| and select DoorlsOpen from the label identifiers.
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5. Click OK.

@ o1 (o] PCPRG T Swnal X ~ [ [TooBox S
1| PROGRAM Signal = General
8 2 VAR ™ Network
TON_1: TON;

blink_1: BLINK:
tinSignallime: TDME := Téls;

7 BDVAR
100% | @R
1] TON_0
GVL.xCompressor [—M, GVL.xSignal
I
— [ N 1
GVL.timAlaraThreshold —{n
DoorIsOpen
blink_1
BLINK TON_1.Q GVL.xDoorOpen GVL.xSignal
ENABLE our [ { [ {)
tinSignalTime —TIMELOW
tinSignalTime —TIMEHIGH
DoorIsOpen:
GVL.xLamp

GVL.xDoorOpen
n

;

3.1.7.3 Call the Signal Program in the Main Program

|| = Function Blocks

{F Box with EN/ENO
< Assignment
- Jump
an Return
Y Input
T Branch
& Beate
+ Boolean Operators
+ Math Operators
+ Other Operators

& R_TRIG

| FRIG
/RS
TR
B ToN

contect
w4 Parallel negated contact
fer coil
& setcoll
o0 Reset coil
&/ ToN
® ToF
& cu
& o
& Move
+ Jump
< Retum
T Branch
&~ Branch Start/end
+ POUs

The main program PLC_PRG should call the Signal program for signal processing.

To call the Signal program in the main program

1. In PLC_PRG, on the Delta ToolBox pane, drag Box to the editor.

2. Click and in the Input Assistant dialog, select POU / Program and

Function Calls > Application > Signal.

3. Click OK.

@ v 8] PLC_PRG X[ iH Sgnal v || ToolBox v 2 x
D)0 8.% PROGRAM PLC_PRG E |- o
" Scope  Name Address  Datatype Initialization  Comment t  Attributes O [\ pointer
. Control Point
| e vm eysteresis REAL 1 Semm
2 * VAR SR_O SR = Output
£ Box
F Boxwith EN/ENO
= Jump
@ Label
o Retum
4 Composer
I Selector
= Comment
I8 D - C - Source
= = Connection Mark - Sink
o ZF Input Pin
5 Output Pin
SRO
SR
1 =xCompressor
L —— e |
Srempset oo
(o]
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3.1.7.4 Create an ST Program for a Simulation

The application in this example project is not linked to real sensors and actuators. To
monitor the operation of the refrigerator controller in online mode, you should write a
program for the simulation of rises and falls in temperature.

The program increases the temperature until the main program PLC_PRG
determines that the temperature set point has been exceeded and activates the
cooling compressor. The simulation program then lowers the temperature again until
the main program deactivates the compressor.

To create an ST program for a simulation

1. On the Devices pane, right-click Application and then select Add Object >
POU.

2. In the Add POU dialog, enter Simulation for name and select Structured Text
(ST) for implementation language.

3. Click Add.

4. Enter the following program in the ST editor.
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PROGRAM Si nul ati on
VAR
/1 The tenperature is decreased on a tinme delay when the
/I conpressor has been acti vat ed.
T1: TON,
P_Cool i ng: TI ME: =T#500M5;
/1 Signal for decreasing the tenperature
xReduceTenp: BOOL;
/1 The tenperature is increased on a tinme delay when the
/I conpressor has been acti vat ed.
T2: TON,
/I Delay time when the door is closed
P_Envi ronnment: TI M =T#2S;
//Delay time when the door is open
P_Envi r onnent Door Qpen: Tl ME: =T#1S;
/1 Signal for increasing the tenperature
XRai seTenp: BOOL;
[/ Delay time
ti mrenp: TI ME
i Counter: |NT;
END_VAR

/I No function, just for denonstration purposes
i Counter := iCounter+1;
/| After the conpressor has been activated due to rTenpActual being
//too high, the tenperature decreases.
/1 The tenperature is decreased by 0.1°C per cycle after a del ay of
/I P_Cool i ng.
I F GVL. xConpr essor THEN
T1(I N: = GVL. xConpressor, PT:= P_Cooling, Q=>xReduceTenp);
| F xReduceTenp THEN
GVL. r TenpActual := GVL.rTenpActual -0. 1;
T1(1 N: =FALSE) ;
END_I F
END I F

/11f the door is open, warning occurs faster; SEL selects
/' P_Envi r onment Door Qpen.
ti mrenp: =SEL( GVL. xDoor Qpen, P_Envi ronnent, P_Envi r onment Door Open) ;

[11f the conpressor is not working, then the cooling chanber becones
[ [ war mer .
/1 The tenperature is increnented by 0.1°C per cycle after a del ay of
[/timrenp.

T2(IN. = TRUE, PT:= tinTenp, Q=>xRai seTenp);

| F xRai seTenp THEN
GVL. r TenpActual := GVL.rTenpActual + 0.1;
T2(1 N: =FALSE) ;

END | F
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@ on  [[g) pcPrRG [T signal [g] Simulation X |

1 PROGRAM Simulation

B8 2 VAR
3 //The temperature 1s decreased on & time delay when the
4 //compressor has been activated

] M i b
-
-
-
[}
=z

P_Cooling: TIME:=T#500M4S;
//Signal for decre i
xReduceTemp: BOOL;

//The temperature 1s increased on & time delay when th
PR,
tivat

W -

M

o

//compressor ha
T2: TON;
//Delay time when the door 1is closed

P _Environment: TIME:=T#25;

//Delay time when the door 1s open

P_EnvironmentDoorOpen: TIME:=T#15;

//5ignal for increasing the temperaturs

xRaiseTemp: BOOL;

W o
L0

o

W~

//Delay time
timTemp: TIME;
iCounter: INT;
END VAR

o w

D 0D b b b b b b b e e
O ) o

//No function, just for demonstration purposes

1

2 iCounter := iCounter+l;

3 //After the compressor has beesn activated dus to rTempActual being
4 //too high, the temperature decreasess

5 //The temperature is decreased by 0.1°C per cycle after a delay of
€ //P _Cooling.

=] 7 IF GVL.xCompresscor THEN
T1(IN:= GVL.xCompressor, PI:= P_Cooling, Q=>xReduceTemp);
IF xReduceTemp THEN
GVL.rTempActual := GVL.rTempActual-0.1;
T1(IN:=FALSE);
END_IF
END_IF

m
o w

W

b

//If the door is open, warming occurs faster; SEL selects
//P EnvironmentDoorOpen.

timTemp:=SEL(GVL.xDoorOpen, P_Environment, P_EnvironmentDoorOpen);

0

[ S R S S S e e e e
W o~ @

S //If the compressor is not working, then the cooling chamber becomes
0 //wvarmer

1 //The temperature is incremented by 0.1°C per cycle after & delay of
2 //timTemp

29

24 T2(IN:= TRUE, PI:= timTemp, Q=>xRaiseTemp);
B 25 IF xRaiseTemp THEN

2¢€ GVL.rTempActual := GVL.rTempActual + 0.1;

27 T2 (IN:=FALSE);

28 END_IF

Note: Visualization is recommended for convenient operation and monitoring
of the entire control program. You can add a Visualization object to the
project. For more information, see CODESYS Visualization.
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3.1.7.5 Define the Programs to Run in the Task Configuration

The default task configuration contains the call for the main program PLC_PRG. You
also need to add the call for the Simulation program.

To add the call for the Simulation program
1. On the Devices pane, drag Simulation to MainTask.

2. Double-click MainTask to configure the task.

3.1.7.6 Debug the Application Program
Use the following steps to check syntax errors for the programs.
To debug a program

1. Press F11 to have the entire application checked for syntax errors.
The results will be shown on the Messages pane at the lower-left corner.

2. Select any message and press F4 to jump directly to the location.

3.1.8 Download and Run the Application

Before downloading the application to the controller, ensure the application has been
compiled without errors.

Prerequisites

* The controller is connected.

To download the application to the controller

1. (optional) In the System Settings tab, clear the Apply IP settings while
download checkbox if you want to keep the IP address of the target controller.

2. On the menu bar, click Online > Login.
A dialog asking whether to download the application to the controller opens.
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3. Click Yes. The current status of the controller appears in the taskbar:

O Untitled1.project” - DIADesigner-AX - o X
File Edit View Project Build Online Debug Tools Window Help Y
BNSEIE O-0 v o f BBRX|ALHALIN AN - 3" | & | Application [Controller_1:PLCLogic] » 5 @ » w N 5 5 F (=== F [ ||
Devices v & X|| /(@ Controller_1 x v

=g L{,»m’edl = Communication Settings Runtime Clock
=% () Controllr_1 [connected) (AX-308EAOMALT) | | | PLC Time: Read PLC Time
8 Hardware Configuration .
= A Network Configuration Applications Date: [Tuesday , August 20,2024  @~]||  writePLCTime
A, EtherCAT Topology | . Time: [ s:a1:56 am 2] [ syncviith Local Time |
A, EtherNetIP Topology |
A, ModbusTCP Topology Files Time Zone
=& pLC Logic ] PLC Timezone: Read Timezone
=0 -
G Application [stop] Log Timezone: | (UTC+08:00) Asia/Shanghai O| [ wiite Timezone
() Library Manager ]
[£] Motion_PRG (PRG) PLC Settings Network
8 pc_pro (rO) 1 Apply IP settings while dovnload
= (@ Task Configuration PLC Shell .
] e
=53 EtherCAT Task (IEC-Tasks) || | s
) Licensed Software Metrics
8] Motion_PRG P Address Mod
5 5 MainT: ’ ress Mode: Static
€3 MainTask (IEC-Tasks) System Settings ! )
8] pLcpre 1P address: 192 . 168 . S0 . 241
=3 { Buitin_IO (uiltIn_I0) Ri ; 5
J _ R ight Settings s 4
@ o0 o10) | Subnet mask: [2s5 . 255 . 254 . 0 ]
5 () Delta_LocalBus_Master_1 (Delta LocalBus|| | system Parameters Default gateway: 0.0 .0 .0
A\ [ EtherCAT_1 (AX Series EtherCAT Master §| |
[ Ethemet_1 (Ethernet) Task Deployment Obtain DNSserver address automatically
> Softhotion General Axis Pool 1 Usethefollowing DNSserver addresses:
Status ) )
] Preferred DNSserver: | 0 . 0 . 0 . 0
Information Altemate DNSserver: [0 . 0 . 0 . 0 |
Read from PLC
| ProjectID
Project ID status: Inactive Set Project ID
‘ Persistent Retain Settings
Mode: O Original mode @® %M mode
Start Memory Address (%M8) |0
End Memory Address (%MB) 524287
< 5> Clearall %M addresses Clear
58 Devices |[[) Pous < >
[E] Messages - Total 0 error(s), 0 warning(s), 5 message(s)|
Device user: Anonymous Lastbuid: @ 0 ® 0 precompie » x|SR Program loaded Program unchanged Project user: (nobody) Q

To run the application

* On the menu bar, click or press F5.

The current status of the controller appears in the taskbar: RUN

3.1.9 Share HMI Tags

DIADesigner-AX supports exporting the user-defined variables to the XML file. The
XML files can be imported DIAScreen. Variables in the XML file can be shared as
tags between the controller and Delta HMI devices. For more information, see HMI

Interactive.
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3.2 Create and Manage Projects

When a project is created, the structure for the project is automatically created. The
devices and program elements in the project shows in an organized tree view. You
can manage program elements and access additional device configuration editors.

3.2.1 Open a Project
Use the following steps to open an existing project.
To open a project
* On the menu bar, click File > Open Project. Or, double-click the project file.

When double-clicking to open a project in a multi-version DIADesigner-AX
environment:

* [f a version of DIADesigner-AX installed is the same as the version of
the project to be opened, the project is opened directly using that same
DIADesigner-AX version. For example, If DIADesigner-AX version 1.6.0 and
1.7.0 are installed on the computer, the version 1.6.0 project will be opened by
DIADesigner-AX version 1.6.0.

* If the versions of the installed DIADesigner-AX are all later than the version of
the project to be opened, you need to select which version of DIADesigner-AX
to open the project.

* |f the versions of the installed DIADesigner-AX are all earlier than the version of
the project to be opened, you need to install a later version DIADesigner-AX.

3.2.2 Add Device Dialog

The Add Device dialog consists of the following information.
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il Add Device

Name |AJ<_3OUNADPAI 0

Action
(®) Append device

|'_~'.:r ing for a fulltext search

= @ rues
+- [ softotion PLCs

| €

| Name Vendor Version Description

@ [ ax-300MA0PAL Delta Electronics, Inc. | 1.0.1.0  AX-300NAOPA1 logic PLC with 2 Ethernet pc|
_Ii AX-Z04ELADPA TP Delta Electronics, Inc. 1.0.1.0 AX-304ELADPA 1P motion controller with 16 |I
_Ii AX-304ELADPAIT Delta Electronics, Inc. 1.0.1.0 AX-3D4ELADPA IT motion controller with 16 |i
_-,j AX-324NADPATIP Delta Electronics, Inc. 10.1.0 AX-324NADPA IP logic PLC with 16 paints Bu:

Group by category [ ] Display all versions (forexperts only) [] Disp]a'ﬂdaled Versions

@| Vendor | <all vendors> -

>

[  MHame: AX-300NAOPA1
Vendor: Delta Electronics, Inc.
Categories:PLCs

@ Version: 1.0.1.0
Order Number:

7
Description: AX-300MAOPA L logic PLC with 2 Ethernet port (Ethernet Switch). -

Add selected device to the project (top-level)

©  (You can select another target node inthe navigator while this window is open.)

Add Device Close

Legend Description

1 Enter the device name and select to either append a device,
insert a device, plug a device, or update a device.

2 Search based on the device name and vendor.

3 Display the available device with its name, vendor, version,
and description.

4 Select to group the devices by category, to display either all
versions or only display outdated versions.

5 Display the details of the selected device.

The following table lists the differences among Append device, Insert device, Plug
device and Update device.

Setting

Description

Append device

Add the selected device below the selected object in the de-
vice tree.
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Setting Description

Insert device Add the selected device at the same level as the selected ob-
ject below it in the device tree.

Plug device Add the selected device to the selected slot. If the slot is al-
ready occupied, the new module replaces the existing mod-
ule.

Update device Replace the device selected in the device tree by the selected
device.

Note: Depending on the device, this may overwrite
the existing configuration with the default values in the
editor.

3.2.3 Standard Toolbar

The following table lists the icons and functions in the standard toolbar.

Item Description

5 Click to add a new project.

G Click to open an existing project.

Click to save the project.

& Click to print the project.

& - Click to go to the previous opened editor. It locates the posi-
tion you last stopped in the editor.
Click Ll to select and open the editor that was opened in the
history. You can view up to 10 history records.

@ Click to go to the next opened editor. It locates in the position
you last stopped in the editor.
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Item Description
) Click to undo the previous action.
Cu Click to redo the last action.
& Click to cut.
Click to copy.
i) Click to paste.
> Click to delete.
i Click to find the text in the active editor.
84 Click to replace the text in the active editor.
] Click to find the text in the current project.
Al Click to replace the text in the current project.
| Click to add a bookmark in the language editor for easy navi-
gation.
€ Click to go to the previous bookmark.
& Click to go to the next bookmark.
b | Click to delete bookmarks in the language editor.
Click to open the Properties dialog of the current editor.
e Click to add the following objects:
* Action
* Method
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Item

Description

Property

Transition

Click to edit objects.

Click to generate code.

Click to select the active application

Click to log in to the controller.

. Click to log out from the controller.
b Click to start running the program.
m Click to stop running the program.
.

Click to enter Online Config Mode for the current application

Click to write values to the variables.

(= Click to run the statement from the breakpoint to debug. To
step over means to jump the sub POU if any.
= Click to run the statement from the breakpoint to debug. To
step into means to go into and run the sub POU if any.
=

Click to jump out of the current sub POU you have stepped in-

to. To step out means to jump out of the sub POU and return
to the calling POU.

Click to set a cursor. The program runs from the current

breakpoint position and stops at the cursor position without
running the code of this line.

Click to run the statement to the position before the cursor.
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Item Description

Click to show the current breakpoint position.

2
Click to switch between different localizations.

= Click to go to CODESYS store.

A, Click to accept differences between the project compared to

the current project.

3.2.4 Update Devices

DIADesigner-AX provides a device update function. You can update devices in the
project to devices of different versions or types.

To update devices

1. Do one of the following:

° On the menu bar, select Project > Update Device.

° Right-click the device that you want to update and select Update Device.

2. In the Update Device dialog, select the device to be updated to.

3. (optional) You can select Update same devices in project to update all the
devices with the same ID and type in the project.

4. Click Update Device.

5. In the Update Device List dialog, check the update information and select the
version for the target device.

6. Click Update.

3.2.4.1 Update Device List Dialog

The following table lists the settings in the Update Device List dialog.

Item Description

Device Name The name of the device in the project tree.
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Item Description

Source The type and version of the original device.

Target . .
The type and version of the target device.
You can select the version in the dropdown list.
Some data and configurations may not be updated to the tar-
get device due to incompatibility.

(x] This device will be removed.

O The device will be successfully updated and the configuration

will be transferred to the target device.

Note: If the source device's version is no longer sup-
ported, you cannot roll back to it after updating, so in
this case, the target device is the same by default and
will not change after updating. If you want to update to
another version, change the target device.

Don't show again If you select the checkbox, the Update Device List dialog
will not show again. If any updating error occurs, you need to
check it manually.

3.2.5 Edit 10 Mapping Tab
How do | open the Edit IO mapping tab?
* On the Devices pane, right-click the controller and select Edit IO mapping.

On the Edit 10 mapping tab, all I/O maps of the currently device are displayed,
including the 1/0 maps of all additional devices in the project.
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Add Device...

Update Device...
J-' Edit Object

Edit Object With...

| Edit IO mapping

Import mappings from CSV...
| Expert mappings te CSV...
* Online Config Mode...

- @

Theted] =] TFmd Fier Show al
iij i: &) Cut lble Channel Address  Type  Description
] :m:ﬁ: Copy B contoler 1
@ cony I i s._!i tin_l10
o8 | % Delete = [@ow
Al Properties... & _‘" 1:0-7 %180 BYTE §-CH Open Colactor Ingut
+ L:8-11 %IB1 BYTE 4-CH Open Colector Input
|4 Add Object » * " Q0-3 %QB0  BYTE  4<CHOpen Colector Output
O Add Folder,.. i EthercaT_1

The following table shows the options in the Edit IO mapping editor.

Function

Description

Find

Enter the keyword to search the variables. The search result
will be marked in yellow.

Filter

Select the I/O allocation filter displayed in the mapping table:

* Show all.

* Show only inputs.

* Show only mapped variables.

* Show only mapping to existing variables.
* Show only mapping to new variables.

* Show only outputs.

* Show only unmapped variables.

You can create the 1/O variable and name them by the following method:
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* Name by Default

* Name by Prefix

Variable Channel Address Type Description
= ﬂj A¥_BxxEPD_Windows_Series
= " Builtin
= [l Builtin_DIO
= 4 In0 %eIBO BYTE 8-CH Digital Input
R un miva g  BOOL
9 £ 1 BooL
B Copy 2 BOOL
* Paste 3 BOCL
By Delete 4 BOOL
R 5 BOOL
gy Advanced b A BOOL
R E Input Assistant... 7 BOOL
+ "@ oVTE D U Diimide] P by
= ﬂj Builtln_Pulse_Enc | Create |/0 Vanable % Mame by Default
b Counter gl Mame by Prefix ..
T Reset 00X 1.0 BOOL Reset Counter value(Execution)
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Chapter 4: Programming Reference

The Programming Reference section provides information relevant to a AX series
controller.
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4.1 IEC61131-3 Programming

IEC61131-3, published by International Electrotechnical Commission (IEC)
standardizes the syntax and semantics of the programming languages used for
programmable controllers. This set of standards improved the interoperability,
reusability, and efficiency of programming. Based on the IEC61131-3 standards,
DIADesigner-AX integrated programming languages that manufacturers and users
can follow.

* DIADesigner-AX supports the following IEC61131-3 programming languages.

o Structured Text (ST)

° Ladder Diagram (LD)

o Sequential Function Chart (SFC)
° Function Block Diagram (FBD)

° Instruction List (IL)

° Continuous Function Charts (CFC)—An IEC61131-3 extension language,
derived from the Function Block Diagrams (FBD)

* The concept of Variable is adopted. You can replace a register address with a
variable. A Program is more readable and the time of assigning addresses is
saved.

* The architecture related to Program Organization Units (POUs) is adopted. A
traditional program is divided into several independently-developed program
organization units. The architecture of a program can be more modular and can
be maintained more easily by calling Functions and Function Blocks.

* Program Organization Units (POUs) are managed and organized through the
concept related to tasks. The development of programs is upgraded to the
management of projects. The large-scale development of programs can be
managed more easily.
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4.1.1 Delta ToolBox

The enhanced Delta ToolBox gives a more user-friendly programming experience,

designed to simplify navigation tailored to your preference. It provides IEC standard

operators (such as Boolean and math operators), function blocks, and POU defined

in the current program for the LD editor. Delta ToolBox also provides AX Series

Standard Instructions, AX Series Motion Control Instructions, and basic language-

specific instructions. By default, the toolbox only shows the elements supported by

the current editor.

You can do the following in Delta ToolBox.

* Customize instruction categories.

* Add instructions from Input Assistant.

* Drag the element to the editor for programming.

Note: If you close the toolbox, you can reopen it from the menu bar > View >
Delta ToolBox.

4.1.1.1 Delta ToolBox Settings

The following table lists the settings in the toolbox and their descriptions.

Setting

Descriptions

Enter keywords to filter folders and elements whose names

contain the keywords. You can click to clear all search

histories.

Click to open the New Category dialog to add a new folder to
contain customized instructions. You can categorize instruc-
tions by creating different folders. Enter descriptions for this
category in the New Category dialog, and the descriptions
will be shown at the bottom of the toolbox when you click the
folder.
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Setting Descriptions

The folder’s placement depends on the current cursor posi-
tion.

* [f you click the button when the cursor focuses on a
blank area, the folder will be added to the bottom of the
list.

* If you click the button when the cursor focuses on a cus-
tomized folder, the folder will be added as a child folder.

Note: Customized folders can only be created under
My Favorites or by clicking a blank area.

;@- Click to open the Input Assistant dialog to add a new instruc-

tion from the library to the selected customized folder.

® Click to delete the selected customized folder or the instruc-

tion in the folder.

4 Click to move up the selected instruction or folder. You can

only move the instructions in My Favorites and customized
folders or move customized folders.

4‘, Click to move down the selected instruction or folder. You can

only move the instructions in My Favorites and customized
folders or move customized folders.

E Click to export the instructions in My Favorites and cus-
tomized folders to an XML file of the current editing toolbox.
If you want to see your custom data of the last saved project,
go to C:\ProgramData\Delta Industrial Automation\DIAStu-
dio\DIADesigner-AX_XXXXXXXX\ToolBox Data.

=

Click to import an XML file containing the instructions in My

Favorites and customized folders. The imported data will re-
place the original data.
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The following table lists the context menu by right-clicking the element or blank area

in the toolbox.

Setting Descriptions
Add to Fa- Select to add the selected instruction to My Favorites.
vorites
Delete Select to delete the selected customized folder or the instruction
in the folder.

New category

Select to add a new folder. It works the same as clicking

Rename Select to rename the selected customized folder or enter descrip-

tions.

If you have saved the project, the toolbox will retain its customized data when
reopening a project or DIADesigner-AX.

4.1.2 Ladder Diagram (LD)

LD is a graphical programming language representing electrical relay logic using
horizontal lines (rungs) and vertical lines (rails) that resemble a ladder. Each rung
represents a specific control operation, with inputs on the left side and outputs on the
right. This format allows for easy visualization and understanding of the control logic.

LD is mainly composed of networks which contain elements like contacts, coils,
function blocks, and branches. These elements are inserted, dragged, copied, and
pasted to networks to build the execution logic of the program.

To set the font, operands, network title, and comment display of the LD editor, on the
menu bar, select Tools > Options > FBD, LD and IL editor.

The LD editor offers to:

* Expand or collapse a network or all networks.
* Select multiple elements.

* Copy, paste, insert, or delete multiple elements.
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* Connect the start and end points by drawing lines to create a parallel contact.

* Comment or uncomment multiple networks.

* Add an element to the right of the closed parallel contact by right-clicking or
dragging elements to the rectangle.

newvar

| [ ]

newvara

I

* Drag elements from the toolbox to the editor.

* Perform online commissioning functions such as monitoring, writing values,
forcing values, and breakpoints.

4.1.2.1 Select Elements

You can select an element or network at a time, select multiple elements in the same
network, or select multiple networks.

You can select multiple elements:

* Contiguously by pressing Shift.
Select the first element within the rectangle, hold the Shift key, and then select
the last element.

* Non-contiguously by pressing Ctrl.
Select the first element, hold the Ctrl key, and then select other elements. You
can also select the element to undo the selection.

* Through a box selection.
Click the left mouse button and drag a box, and then release the mouse button
to select all element inside the box.

Note: If the selected elements are across multiple branches, you can only
paste or drag them to a new network not a specified position.
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newvars3 newvar newvara
| [ [ [ | [
Jb-trig
newvarl
/1
newvar3 newvara
| [ - [ [
B-trig
B TRIG

CLE _;;;_ o

4.1.2.2 Drag Elements

The LD editor supports drag-and-drop editing. You can select one or more elements
for the drag-and-drop operation.

To drag elements

* On the Delta Toolbox pane, drag an element to the network in series.

* Drag elements within the current LD editor to another LD editor.

* Drag the element in the network to another element of the same type to replace
it.

The dragged elements are moved from the original place to the new place. If you
want to keep them in both places, press and hold the Ctrl key and drag directly
without releasing the mouse.

When you drag an element, the LD editor shows the available positions to drop the
element.
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. : You can drag the element here and insert it in series.

Fay
W .
i : You can insert a parallel element above or below the element.

You can only drag multiple elements before or after an element.

=

« =* | You can add a network containing the dragged elements above or

below the current network and the dragged elements are deleted from the
original position.

4.1.2.3 Draw Lines

Starting from DIADesigner-AX version 1.8.0, the LD editor supports dragging the
start point on a line to the available end point to create a parallel contact.

Prerequisites
The start and end points must be on the same line.
To connect points to create a parallel contact
1. Select a start position on the line.
The start position is shown as a red square.

2. Drag lines to the available end position.
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The available position is shown as a light blue square.

w1l

Network-1

newvar

Compare

1bEnable
diPosition

DL_CmpAX8xxEDrvLinux.DFB Compare

bBusy
bDone

newVarl

4|]|]—

—uiTable5ize
—|rtneShotTime
—byTimeExten

FifoState

bError

ErrorID

rc‘TicIr.tc select end branch position here.

Network-1

newVar

Compare

DL CmpAX8xxEDrvLinux.DFE Compare

1 1

bEnable bBus
diPogition

uiTableSize
rOneShotTime
byTimeExten

Errorl

bDone
FifoState

bError

newVarl
ni
¥ U0

D

newvVar2

10

Note:

The parallel contact created this way is closed by single vertical lines,

indicating an OR operation. If you want to perform an SCE (Short-

Circuit Evaluation) operation for the parallel structure, use Set Branch
Start/End Point.

You cannot drag lines across branches. For example, the start point is

on the left side of the branch and the end point is on the right side.

4.1.2.4 Copy, Cut, and Paste Elements

DIADesigner-AX version 1.8.0 optimizes the diagram logic by solving copying and

pasting logic issues, resulting in a more streamlined programming experience.

You can copy, cut, and paste selected elements both within the same POU and

across different POUs. The following elements can be copied: networks, contacts,

coils, function blocks, strings, and branch lines. When pasted, the elements will

automatically generate a new logic at the selected line position. However, you cannot

paste copied or cut elements onto another element to replace it.
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4.1.2.5 Add Elements

You can add elements to the editor using the toolbar, Delta ToolBox, and context

menu.

To add elements to the editor

* On the toolbar, select the element.

You can customize the toolbar commands from the menu bar > Tools >
Customize > Toolbars > FBD/LD/IL.

* On the Delta ToolBox pane, drag the element to the editor.

* Right-click the network or elements and select the option from the context

menu.

4.1.2.6 Delete Elements

The LD editor supports deleting the selected element and blank branch line.

4.1.2.7 Context Menu Settings

The following table lists the default context menu shown when right-clicking a

network or an element.

Setting

Descriptions

Collapse All Networks

Select to collapse all networks.

If you only want to collapse a single network,

-w

click on the leftmost side of the network.

Expand All Networks

Select to expand all networks. If you only want

to expand a single network, click ¥ | on the left-
most side of the network.

Insert Network

Select to add a network above the selected net-
work.

Insert Network (Below)

Select to add a network below the selected net-

work.

DIADesigner-AX Version 1.8.0



A BELTA Chapter 4: Programming Reference

Setting Descriptions

Insert Label Select to insert a jump label to the selected net-
work to indicate the jump position of a jump ele-
ment.

Toggle Network Comment State | Select to comment or uncomment the selected
networks. You can select multiple networks and
then use this command for batch commenting or
uncommenting. If the network is commented, the
code of the entire network will not run.

Insert Box Select to open the Input Assistant dialog to se-
lect the function block to be added to the select-
ed position.

Insertion position (Suitable for all boxes):

* If a network is selected, the new box is in-
serted at the end.

¢ |f an element is selected, the new box is in-
serted to its left.

This option is not available for the function block
without inputs or outputs.

Insert Empty Box Select to add an empty function block to the se-
lected position without using the Input Assistant
dialog. You can enter the function block name to
specify the function block type. This option is not
available for the function block without inputs or
outputs.

Insert Empty Box with EN/ENO | Select to add an empty function block with

an Enable Boolean input and an Enable Out
Boolean output to the selected position without
using the input assistant. This function block on-

ly runs when EN is TRUE. You can enter the
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Setting Descriptions

function block name to specify the function block
type.

This option is not available for the function block
without inputs or outputs.

Insert Box with EN/ENO Select to open the Input Assistant dialog to se-
lect the function block with EN/ENO input and
output to be added to the selected position.

This option is not available for the function block
without inputs or outputs.

Insert Execute Box Select to add an Execute function block to the
selected position. This option is not available for
the function block without inputs or outputs.

Insert Box Parallel (below) Select to add an empty function block below the
selected function block. This option is not avail-
able for the function block without inputs or out-
puts.

Insert Coil Select to output a coil. If the selected position is
a coil, return, jump, or function block output con-
nection lines, a new coil is inserted below.

Insert Set Coll Select to output a set coil. The operation is the
same as Insert Coil.

Insert Reset Coill Select to output a reset coil. The operation is the
same as Insert Coil.

Insert Contact :
Select to add a Normally Open (NO) contact in

series.

Insertion positions:
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Setting Descriptions

* |f a network is selected, the new contact will
be inserted at the end.

* If a horizontal line is selected, the new con-
tact will be inserted at the current position.

* |f an element is selected, the new contact
will be inserted on the left of the element.

Insert Negated Contact Select to add a Normally Closed (NC) contact in
series. The insertion positions are the same as
that of Insert Contact.

Insert Contact (right) Select to add an NO contact to the right of the
selected element in series. If a network is select-
ed, the new contact is inserted at the end.

Insert Contact Parallel (below) | Select to add an NO contact below the select-
ed position in parallel. The selected position can
be a contact or function block. This option is not
available for the function block without inputs or
outputs.

Insert Contact Parallel (above) |Select to add an NO contact above the select-
ed position in parallel. The selected position can
be a contact or function block. This option is not
available for the function block without inputs or
outputs.

Insert Negated Contact Parallel | Select to add a negated contact below the select-

(below) ed contact in parallel.
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Setting Descriptions

Paste Contacts
* Paste below: Select to paste a contact be-

low the selected position and create a par-
allel structure.

* Paste right(after): Select to paste a contact
to the right of the selected position.

* Paste above: Select to paste a contact
above the selected position and create a
parallel structure.

The paste position can be a contact or lines be-
tween contacts. You cannot paste a contact to
multiple elements at once.

Insert Jum
P Select to add a jump element.

The jump position is the label position in the net-
work. Jump across networks is supported.

Insert Return Select to add a return element. When the inputs
are valid, the current POU returns to the caller
POU.

Insert Branch Select to add a non-closed branch below the se-
lected line position. You cannot close a branch.
A branch only ends with a coil. If a contact is se-
lected, the branch is inserted after it. You cannot
select coils or boxes and run this command.

Insert Branch Below Select to add a non-closed branch below the se-
lected branch. The insertion position should be
the start of the branch.

Insert Branch Above Select to add a non-closed branch above the se-
lected branch. The insertion position should be
the start of the branch.

DIADesigner-AX Version 1.8.0




A BELTA Chapter 4: Programming Reference

Setting Descriptions
Go to... Select to open the Go to Network dialog to
specify the target network number or label to
jump to.
Negation Select to negate the function block input and out-

put, jump, return, contact value, or coil.

Edge Detection Select to add the edge trigger to contacts, func-
tion block input lines, coil input lines, jump ele-
ment input lines, and return element input lines.

Select a contact and run this command. L in-

_-H-.

indicates the

dicates the rising edge and
falling edge.

For adding edge detection to the line: j in-

I,
il indicates the

dicates the rising edge and
falling edge.

Rising edge detection is equivalent to the R_-
TRIG function block and falling edge detection is
equivalent to the F_TRIG function block.

The edge detection function is added only to in-
put lines of the BOOL type.

Set/Reset Select to add a Set or Reset output function for
the function block's coils and BOOL output lines.
The Set output is shown as S, and the Reset out-
put is shown as R. This command can be run
multiple times and switch among Set, Reset, and
normal output.

Set Branch Start/End Point Select to set the selected position as the start
point and then select an available end point to
create a parallel contact. The parallel structure
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Setting Descriptions

is closed by double vertical lines, indicating an
SCE (Short-Circuit Evaluation) operation is per-
formed. If you want to perform an OR opera-
tion, use Insert Contact Parallel (below) or Draw
Lines.

Set Output Connection Select to set this output pin as the main output of
the function block. A function block only has one
main output linked to the subsequent element.

Update parameters Select to update the input and output parame-
ters of the selected function block if there are
changes.

Select to delete the unused input and output pa-
Remove unused FB call para- )
) rameters. When the inputs or outputs of the func-
meters
tion block are ??? or empty, they are not shown.

4.2 Variable

Use variables to store and process information. The variable types include:

* Local variable (VAR)

* Input variable (VAR _INPUT)
* OQutput variable (VAR_OUT)
* 1/O variable (VAR_IN_OUT)

* Temporary variable (VAR_TEMP)

Global variable (VAR_GLOBAL)

You can also add flags to the variable to specify the attribute:
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* Retain variables (RETAIN)

* Persistent variable (PERSISTENT)

* Constant variable (CONSTANT)

You can set up variables in POU, Global Variable List, Network Variable List,
Persistent Variables, and the DUT editor.

The following table identifies the variable parameters and their descriptions.

Item Description
Scope Type of the variable.
Name Name of the variable.
Address The address that stores the variable.
Data Type Data type of the variable. A standard data type or a user-de-

fined data type.

Initialization The value of a variable when a controller starts running for the
first time.

Comment User-defined text for the variable.

Attribute Properties of the variable.

Dimension The number of elements of an array. For example, [1..10,1..5]

represents a two-dimensional array containing a total of 50 el-
ements.

4.2.1 Create an Array Variable

An array is a collection of data elements of the same data type. One and multi-
dimensional arrays are supported. Use the following steps to create array variables
in the LD POU editor. You can use the same steps for the other supported editors.

To create an array variable
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1. Create a project.

2. On the Devices pane, right-click Application, and then select Add Object >
POU.

3. Inthe Add POU dialog, enter the POU name and select Ladder Logic
Diagram (LD) in Implementation language, and then click Add.

4. |n the variable declaration editor, click IE to switch to Tabular View, and then

/

click to insert a variable.

5. Enter a name for the variable.

6. Double-click the Data Type box and click "] and then select Array Wizard.

7. Inthe Array dialog, enter Dimensions and Base Type. If you want to find a

base type, click ] and select Input Assistant. In the Input Assistant dialog,

search the base type under Text Search, or select one from Standard Types
or Structured Types under Categories.

4.2.2 Create a Structure Variable

You can create structures in a project as DUT (Data Unit Type). Use the following
steps to create structure variables.

To create a structure variable
1. Create a project.

2. On the Devices pane, right-click Application, and then select Add Object >
DUT.

3. Inthe Add DUT dialog, enter the name and select a type, and then click Add.
4. In the DUT editor, enter the text for the structure.

5. Create a POU.

6. In the variable declaration editor, click E to switch to Tabular View, and then

/

click to insert a variable.
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7. Enter a name for the variable.

8. Double-click the Data Type box and click ], and then select Input

Assistant.

9. Inthe Input Assistant dialog, on the Categories tab, select Structured
Types.

10. Expand the Application node, and select the DUT you created, and then click
OK.

4.2.3 Set up Comments for Array and Structure Variables

You can set up comments for array and structure variables in:

* POU editors (FBD, LD, ST, CFC, and SFC), and the Method editor
* Global Variable List

* Global Variable List (tasklocal)

* Network Variable List (Sender)

* Persistent Variables
To set array and structure variable comments
1. Create an array or structure variable.

2. Do one of the following to open the Set Comments dialog:

° Right-click the variable, and then select Set Comments.

°  Double-click the Comment box and then click =

3. Inthe Set Comments dialog, enter the comments for the variable and the sub-
elements.
If you want to enter the same comment for multiple lines, select the lines and
enter the comment in the bottom textbox, and then click Apply Comments to
Selected Lines.
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Set Comments *
Expression Data type Comment &
= myArray ARRAY [1.,100] OF BOOL aza

myArray[1] BOOL 111

myArray[2] BOOL 222

myArray[3] BOOL 333

myArray[4] BOOL 444

myArray[5] BOOL Edlit

myArray[6] BOOL Edit

myArray[7] BOOL Edlit com

myArray[8] BOOL Edlit

myArray[9] BOOL Edlit

myArray[10] BOOL Edit

myArray[11] BOOL Edit

myArray[12] BOOL Edlit

myArray[13] BOOL Edlit

myArray[14] BOOL Edlit

myArray[15] BOOL Edit

myArray[16] BOOL Edlit v

P e —— P R
|555| Apply Comment to Selected Lines
Only the first 500 comments are displayed. oK Eancel

4. Click OK. The sub-comments will be synchronized and shown in the Attributes

column.

To view the comments in the POU editor

1. Insert an element in the POU editor and assign a variable to it.

2. Do one of the following:

o Check the tooltip by hovering over the element.

° Go to Tools > Options > FBD, LD and IL editor, and select Show
symbol comment, then go back to the POU editor and view the symbol

label.

Note: After the comment is set, it will be shown with all the comments of its

parent levels. In the following example, arrayvar[1] is assigned to Contact,

and when you view the comments of arrayvar[1], it will show multivarroot

arrayvar comment:1.
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miltivary oot
| |

arrayvar comment

1
Il

f
!

root parent parent arrayvar{1]s
comme nt comment comment
i
multivarroot multivarroot
arrayvar comment:l boolvar comment
front.arrayvarfl] front.booclvar
01
{ [ { [
1 set Comments »
Expression Data type Comment
= front, mid, back DuT ruiltivarroat
= arrayvar ARRAY [1..3] OF BOOL arrayvar comment
arrayvar[1] BOOL 1
arrayvar| 2] BOOL 2
arrayvar[3] BOOL 3
boolvar BOOL boolvar comment

| | Apply Comment to Selected Lines |

Only the first S00 comments are displayed.

oK, Cancel |

4.2.4 Persistent Retain Variable

Persistent retain variables protect the variables from power failure, and their value

are retained after a download or controller restart.

The following table lists the status of variable values after performing different

actions.
Action Variable Retain Variable | Persistent Retain Variable
Online Change |Retain Retain Retain
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Action Variable Retain Variable | Persistent Retain Variable
Power Failure |Initialize Retain Retain

Reset Warm Initialize Retain Retain

Reset Cold Initialize Initialize Retain

Download Initialize Initialize Retain

Reset Origin Initialize Initialize Initialize

4.2.4.1 Create a Persistent Retain Variable in the %M mode

Use the following steps to create a persistent retain variable in the %M mode.

To create a persistent retain variable

1. On the Devices pane, double-click the controller.

2. Go to System Settings > Retain Settings and select %M mode.

3. Enter Start Memory Address. The value can start with the default value

in Start Memory Address and cannot exceed the value in End Memory

Address.

System Settings

Right Settings

System Parameters

Task Deployment

Status

Information

Alternate DNS server: o. 0 .0 .00
Read from PLC

Project ID

Project ID status: Inactive Set Project ID
Persistent Retain Settings

Mode: () Original mode @) %M mode

Start Memory Address (%MB) |0

End Memory Address (3%MB) 524287

Clearall %M addresses Clear

4. Go to Application, add a POU program or open an existing one.

5. Insert variables in the POU program. Enter Name, Data type, and

Initialization.
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. Scope MName Address Datatype Initialization Comment Attributes
| @ VAR PERSISTENTRETAIN  Variablel BOCL FALSE
: § VAR Variable2 STRING
; # VAR Variable3 INT 0

6. Select the variable and click , and then select Retain and Persistent.

# | VAR PERSISTENT RETAT]
Scope

VAR

T VAR_IN_OUT

4% VAR_INPUT

"% VAR_OUTPUT

Té  VAR_TEMP
Flags
CONSTANT

v| RETAIN

v | PERSISTENT N |

7. To call this POU:

a. Go to Devices > Task Configuration.
b. Double-click MainTask.

c. On the MainTask tab, click Add Call.
d. Select the POU, and click OK.

Note: The persistent variables in the Global Variable List also need to
be called in the task under the application.

=12 Task Configuration
= EtherCAT Task (IEC-Tasks)

@) Motion_PRG
= MainTask (nzc-mo
@) pic_PrG

=) Builtin_I0 (Buitin_I0)
@ oio o)

gk Add Call X Remove Call [
pou
&) PLc_prRG

Input Assistant

TextSearch  Categories

3 SoftMotion General Axis Pool

() Delta_LocalBus_Master_t (Delta LocalBus Ma Programs 4 Name Type Origin
() EtherCAT_1 (AX Series EtherCAT Master Soff =) Application Application
ﬂ] Ethernet_1 (Ethernet) @ Motion_...

,
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8. Click
Application node, and the persistent retain variable is added to the list.
Go back to the POU and check the Address column of the variables. The
persistent retained variable memory addresses are assigned.

to generate the code. The persistent editor is added under the

9. Connect to the controller, click to log in, and download the application to the
device.

Note: To avoid persistent retain variable loss, we do not recommend
restoring the application in %M mode.

4.2.4.2 Persistent Retain Modes

DIADesinger-AX supports the original mode and the %M mode for persistent retain
variables. You can switch the mode in System Settings > Persistent Retain
Settings. For more information, see System Settings.

Supported devices for the %M mode:

AX-3v1.0.4.1 or later

* AX-5

AX-8 (Linux) v3.5.15.45 or later

AX-8 (Windows) v3.5.14.30 or later

* AX-C

The following table lists the difference between the original and the %M modes.

Item %M Mode Original Mode

Variable source All persistent retain vari- All persistent retain variables
ables declared in the active |declared in the active applica-
application. tion and in the persistent editor.

Persistent editor ) Support copying the persistent
Shows the persistent re- , , ,
) , ) retain variables to the editor.
tain variables. The variables
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Item %M Mode Original Mode

(except for function block The copied variables also oc-
type variables) in the list do | cupy the controller's memory
not occupy extra controller |space.

memory space.

Timing to update Build the project or click Build the project, right-click the

the variable list to refresh the editor. editor, and then select Add All

Instance Paths.

Re-assign address | Retain the value. Not retain the value.

4.2.4.2.1 Migrate Variables Before Switching the Mode

If you have created persistent retain variables in the persistent editor in the
original mode, switching to the %M mode will cause these variables to be lost.
We recommend using the following steps to backup the persistent variables of the
original mode beforehand.

To migrate the persistent retain variable
1. On the menu bar, select Tools > Scripting > Execute Script File.

2. Select the following file and then click Open.
C:\Program Files\Delta Industrial Automation\DIAStudio\DIADesigner-AX x.x
\CODESYS\Tools\new_persistent_tool.py

Note: This is the default installation path. If you have installed
DIADesigner-AX in a different location, locate the file in your installation
folder.

After running the tool, a new GVL is created and the variables declared in the original
persistent editor will be migrated to the GVL.

4.2.4.3 Persistent Editor of the %M Mode

DIADesiger-AX supports an enhanced persistent editor for the %M mode.

How do | open the persistent editor of the %M mode?
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Do one of the following:

* On the Devices pane, right-click Application and then select Add Object >
Persistent Variables > Add.

* After persistent retain variables are declared, click . to build the project. The

persistent editor will be automatically created.

The following table lists the options and descriptions of the persistent editor of the
%M mode.

Item Description

K\
)

Click to load the latest persistent retain variables
to the editor. All the persistent retain variables de-
clared in different places throughout the applica-
tion are loaded, and the memory addresses are
assigned.

This button is only available in the offline mode
and when the application is active.

@' Click to clear all the %M addresses of the persis-

tent variables in the editor. The addresses in de-
clared editors are also deleted. This button is only
available in the offline mode.

The following table lists the columns and descriptions in the persistent editor.

Item Description

Expression o .
Shows the combination of POU (GVL) name, variable

name, and library namespace.

Click L*_| to expand the array or structure type variables.

By default, the array variable can show up to 1000 child el-
ements.
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Item Description

Address Shows the assigned memory address of the variable. In
the offline mode, the address is editable but only for the
root variable declared in the application.

Type Shows the data type of the variable. Double-click this col-
umn of an array variable to open the Monitoring Range
dialog to change the range of the array to be monitored.

Initialization Shows the initialization value that has been assigned to
the variable.
Current value Shows the current value of the variable. It is only shown in

the online mode.

Prepared value Shows the prepared value of the variable. It is only shown
and editable in the online mode. The values are synchro-
nized to the declared editors. After the prepared value is

written to the current value, it is cleared from this column.

Comment Shows the comment of the variable.

The following table lists the context menu shown when right-clicking a variable in the
editor.

Item Description

Browse
* Go to Definition: select to show the definition

location of the variable.

* Display Cross Reference: select to show all
occurrence locations of the variable in the
Cross Reference List view.

* Display Global Reference: select to show all

the occurrence locations of all variables with
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Item Description

the same name in the Cross Reference List
view.

* Display Call Tree: select to open the call tree
which shows the callers and calls of the vari-

able.
Save Current Values to Select to save the variable value to the recipe. This
Recipe option is only available in the online mode.

Restore Values from Recipe | Select to upload the variable value from the recipe.
This option is only available in the online mode.

Export Variables Select to export the variable to an XLS or XML file.
This option is only available in the online mode.

Import Variables Select to import the variable from an XLS or XML
file. This option is only available in the online mode.

Display Mode Select the value format when monitoring values in
the online mode.

Add to Watchlist Select to add the variable to a watch list for online
monitoring.

In the persistent editor of the %M mode, boxes with a white background is editable,
while those with gray background are not. Variables shown in gray font color are of
function block type or declared in the library.

4.2.4.4 Online Change in the %M Mode

In the %M mode, removing a variable releases the memory space it occupies in the
controller, making it available for new variables. This avoids gaps that use additional
memory.

Modifying a variable’s name and then performing online change will reset its value to
initialization. However, modifying its address, initialization value, comment, scope or
attribute will retain the variable’s value. This is a standard rule of online change for all
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The following lists the value status of specific data types of persistent retain variables

in terms of different online change triggering conditions.
* Structure

° Change the name or data type of a field: The value of the changed field is
initialized while values of other fields are retained.

o Add a field: The value of the new field is initialized while the values of
existing fields are retained.

o Delete a field: The values of the left fields are retained.
* Enumeration
° Change the name of a literal: The variable’s value is retained.

° Change the type of a literal: If the type is changed to a type of larger
occupied byte size, the value of the variable is retained. If the type is
changed to a type of smaller occupied byte size, the value of the variable
is initialized.

o Add a new literal: The variable's value is retained.

° Delete a literal: The variable’s value is retained, but the literal name is
changed. (shift to show the next literal name). If the current value is not
in the enumeration, it will be shown as an integer (the underlying ordinal
value of the literal).

* Union

° Add or delete a member: If the union size is not changed, the variable’s
value is retained. Otherwise, the value is initialized.

* Alias
°© Change the data type: The variable’s value is initialized.

* Subrange
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° Change the data type: The variable’s value is initialized.

° Change the range: If the current value is in the new range, the variable’s
value is retained. Otherwise, the variable’s value is initialized.

* Function Block

° Change the name or data type of a member: The value of the changed
member is initialized while the values of other members are retained.

o Add a member: The value of the new member is initialized while the
existing members are retained.

o Delete a member: The values of the left members are retained.

* Array

° Add an element: The value of the new element is initialized, while the
values of existing members are retained.

o Delete an element: The values of the left elements are retained.

4.2.4.5 Address Assignment Rules

Persistent retain variables are assigned to the M area in the controller’s memory. The
following rules apply to address assignment.

* The address range is between the Start Memory Address and End Memory
Address you set in System Setting > Persistent Retain Settings.

e Starting from the start memory address, variables are assigned to the available
addresses based on the space they need.

* The addresses in the persistent editor are synchronized with those in the
declared editors, and vice versa.

* [f a function block containing declared persistent variables is used in multiple
locations, the persistent variables will be assigned different addresses.
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* Each variable member is stored in an address that starts at an integer multiple
of the member's size. For example, two variables, Var1(BOOL, 2 bytes) and
Var2 (DINT, 4 bytes), if Var1’s address = %MBO, Var2’s address = %MB4, not
%MB2.

* For the AX-3 series controller, except for the AX-332 controller, the address
assigned to variables of structure and union types follows an 8-byte alignment
rule. For example, if Var1’s address = %MBO, then Var2’s address = %MBS8,
Var3’s address = %MB16.

4.2.5 Variable Export and Import

You can export and import variables from and to all objects that can declare
variables.

4.2.5.1 Export Variables

Take Global Variable List as an example. Use the following steps to export variables
from Global Variable List.

To export variables from Global Variable List
1. In the Global Variable List editor, add variables.
2. Right-click the editor, and then select Export Variables.
3. Inthe Save as dialog, select the file format to save. Support XLS and XML files.
4. Click Save.

When the controller is online, DIADesigner-AX supports exporting variable's current
value and its elements' current value. You can edit the value in the exported file.

4.2.5.2 Import Variables

Take Global Variable List as an example. Use the following steps to import
variables to Global Variable List.

To import variables to Global Variable List
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1. In the Global Variable List editor, right-click the editor and then select Import

Variables.

2. In the Import Variables dialog, browse to select the file to be imported. The
imported file format should be .xml or .xls.

3. Select the properties to be imported.

4. Select Actions Upon Conflicts options to decide what to do when the variable
name to be imported conflicts with that in Global Variable List.

5. Click Import.
The import result is displayed in the lower-left corner.

When the device is online, if you import the variables that were exported online,
DIADesigner-AX supports overwriting the current value of the existing variables.

4.3 Smart Input and Auto-completion

When programming with ST language, entering the keyword automatically shows
the related element list. You can select the element in the list and press Tab to
automatically complete the input.

Supported elements:

* Variables

* POU / Program and Function Calls
* Instance Calls

* Function Blocks

¢ Keywords

* Conversion Operators

* ST statement: IF...THEN..., FOR...TO...DO, WHILE...DO..., CASE...OF...,
and REPEAT...UNTIL...

To complete the input automatically
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1. Enter the keyword of the ST element in the ST editor. For example, SMC_V3.

Devices > 31X Motion_PRG X
=4 Keyword - 1 PROGRAM Motion FRG
=[] Device (AX-308EAOMAIT) 2 VAR
@ Hardware Configuration : END VAR

= A Network Configuration
A, EtherCAT Filter
=0 PLC Logic
=17 Application
m Library Manager
Motion_PRG (PRG)
PLC_PRG (FRG)
fF] Pou (PrG)
= @ Task Configuration
=38 EtherCAT Task

B Motion_PRG .
=-g8 MairTask 1 S}{L‘j’ﬂ
& pLC_PRG [E] [Mc_v3_Add A
= [ Builtin_10 (Builtin_I0) |£] sMc_v3_angle
[ oo (oio) ] sMc_v3_anglezn
[ elta_LocalBus_Master (Delta LocalBus Master) E] SMC_v3_CloseRel

E] sMC_v3_Cross
E] sMC_v3_DistE
E] sMC_v3_Dot
5] sMC_v3_DotSq
E] sMC_v3_IsScalarMultiple
=] smc_v3 Lint
(1/3) ANitems

m EtherCAT_Master_SoftMotion (AX Series EtherCAT Master|
"3 SoftMotion General Axis Pool

==> w

Press the Left or Right key to switch among different views. For example, All
items, Keywords, Global declarations, or Local declarations.

2. Select SMC_V3_Add from the list and press Enter.

Motion_PRG X
1/  PROGEAM Motion PRG
2 VER
:  END VAR

1|  smc v3 add
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3. Press Tab. The parameter template of SMC_V3_Add is automatically

completed.
1 PROGRAM Motion PRG
2 VAR
END VAR
1| smMc_va_aad(fDst:= , vLhs:= , vRha:= ||
4.4 Recipe

Use recipes to change or read recipes values for a specific set of variables (recipe
definition) on the controller at the same time.

You can define the basic settings for recipes, such as location and format, in Recipe
Manager and add any number of recipe definitions under Recipe Manager. Recipe
Definition includes one or more recipes of the variables.

You can save a recipe to a file or write directly from a file to the controller.

4.4.1 Create a Recipe
Use the following steps to create a recipe.
To create a recipe

1. On the Devices pane, right-click Application, and then select Add Object >
Recipe Manager.

2. Inthe Add Recipe Manager dialog, enter the name of Recipe Manager, and
then click Add.

3. On the Devices pane, right-click Recipe Manager and then select Add Object
> Recipe Definition.
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4. In the Add Recipe Definition dialog, enter the name of Recipe Definition, and
then click Add.

5. In the Recipe Definition editor, right-click the blank row and then select Insert
Variable.

6. Right-click the editor and then select Add a New Recipe.

7. Inthe New Recipe dialog, enter the name of the recipe and then click OK.
You can add multiple recipes as needed.

8. Enter the recipe value for this variable in this box.

9. Right-click the recipe value column and then select Save Recipe to save the
recipe as a file on the computer.

When the controller is online, Recipe Manager and Recipe Definition will be
automatically added to the project tree if selecting Save Current Values to Recipe
in the Persistent Variables list.

4.4.2 Recipe Manager Settings

The following table lists the Storage options and descriptions of Recipe Manager.

Settings Description

Select the storage type to save the recipe.

* Textual: Saves the recipe in a readable format.

* Binary: Saves the recipe in a non-readable binary for-

Storage type mat. This format requires less storage space.
Note: You can read binary recipes again only if you
have not changed the variable lists.
Select the file path to save the recipe on the computer or en-
File path ter a relative path of the target system on the controller to

save the recipe on the controller, for example, PlcLogic/.
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Settings

Description

If you enter a relative path, select Save recipe changes to
recipe files automatically on the General tab to take effect.

File extension

Enter the file extension of the recipe file.

Separator

Select the separator between the variable name and values in
the recipe file.

Available Columns

Selected Columns

Select the information and order that you want to save in the
recipe file.

Save as Default

Click to use the settings on the tab throughout the entire
project for all other Recipe Managers.

The following table lists the General options and descriptions of Recipe Manager.

Settings

Description

Recipe manage-
ment in the PLC

Select to save the recipes to the controller at runtime and turn
on the following Save Recipe and Load Recipe settings.

Save Recipe

Save recipe
changes to recipe
files automatically

Select to automatically update the recipe file on the controller
after online changes.

Load Recipe

Load only by exact
match of variable
list

Select to load the recipe from the file only if it contains the
same variable list as the application's recipe definition.

Load matching
variables by vari-
able name

Select to only load the recipe values of variables whose
names in the application's recipe definition are the same as
those in the recipe file.
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Settings

Description

Overwrite existing
recipes on down-

Select to overwrite values in recipe files with the same name
on the controller with the configured values from the project

load after starting the application. This option is only available
when Storage Type is Textual and Save recipe changes to
recipe files automatically is selected.
The default name of the recipe file is in the format of <recipe
name>.<recipe definition name>.<file extension>.

Write Recipe

Limit the variable
to min/max when
recipe value is out
of the range

Select to write the defined minimum or maximum value to the
variable on the controller if the recipe value is out of range.

Do not write to a
variable when the
recipe value is out
of the min/max
range

Select not to write the recipe value to the variable on the con-
troller if the value is out of the defined minimum or maximum
range.

Read Recipe

Check recipe for
changes

Select to save the recipe file automatically if the recipe val-
ue has changed by using the function block RecipeManCom-
mands to read recipes. However, it affects performance be-
cause it generates additional code for checking.

4.4.3 Recipe Settings

The following table lists the items and descriptions of the context menu after right-

clicking a variable in the Recipe Definition editor.

Settings

Description

Cut

Select to cut the selected variable row. This option is only
available offline.
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Settings Description

Copy Select to copy the variable row.

Paste Select to paste the variable row above. This option is only
available offline.

Delete Select to delete the variable row. This option is only available
offline.

Select All Select to select all variables.

Browse Select to show the variable's declaration location or open the

Call Tree pane. This option is only available online and when
you right-click the variable name column.

Refactoring

Select to rename the variable. This option is only available of-
fline and when you right-click the variable name column.

New Breakpoint

Select to open the New Breakpoint dialog to define the set-
tings for a new breakpoint. This option is only available online.

Toggle Breakpoint

Select to set a breakpoint or clear an existing breakpoint. This
option is only available online.

Run to Cursor

Select to run the program until a specified position is marked
by the cursor. This option is only available online and when
the program is halted at the current break position.

Set Next Statement

Select to determine which statement to run next. This option
is only available online and when the program is halted at the
current break position, and you have marked any line in any
POU with the cursor.

Unforce All Values
of <device.applica-
tion>

Select to unforce all values of the variables from the select-
ed application. The variables get their current values from the
controller. This option is only available online.

Display mode

Select the display mode of Current Value.

Insert Variable

Select to insert a variable before the selected position. This
option is only available in Flat list view.
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Settings Description
Add Child Select to add the declared child variable of the selected vari-
able to the recipe definition list. This option is only available in
Structured view.
Add Sibling Select to add the declared sibling variable of the selected

variable the recipe definition list. This option is only available
in Structured view.

Update Structured
Variables

Select to open the Update Structured Variables dialog to
update the whole recipe definition if the declaration of a struc-
tured variable or a POU has changed.

Update Selected
Variables

Select to open the Update Structured Variables dialog to
only update the selected variable if the declaration of a struc-
tured variable or a POU has changed. This option is only
available in Structured view.

Add a New Recipe

Select to open the New Recipe dialog to insert a recipe value
column into the recipe definition.

Remove Recipe

Select to delete the recipe. This option is only available when
you right-click the recipe column.

Load Recipe Select to load a recipe from a file. This option is only available
when you right-click the recipe column.

Save Recipe Select to save the recipe to a file. This option is only available
when you right-click the recipe column.

Read Recipe Select to read the current value of variables on the controller

and overwrite the recipe values. This option is only available
online and when you right-click the recipe column.

Read and Save
Recipe

Select to read the current value of variables on the controller
and overwrite the recipe values and save the recipe to a file.
This option is only available online and when you right-click
the recipe column.
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Settings Description

Write Recipe Select to write the recipe value to the current value of vari-
ables on the controller. This option is only available online
and when you right-click the recipe column.

Load and Write Select to load a recipe from a file and write the recipe value to
Recipe the current value of variables on the controller. This option is
only available online and when you right-click the recipe col-

umn.
Upload Recipes Select to overwrite the recipe values in the project with the
from Device values on the controller. This option is only available online.

4.5 Robotics Project

To create robotics projects swiftly, DIADesigner-AX 1.7.0 and later versions support
a robotics project template. The template generates projects containing axis

groups, axis devices, POU objects, and variables necessary for robot operations.
DIADesigner-AX allows the direct programming of robots and their control via an AX
series controller.

4.5.1 Create a Robotics Project
Use the following steps to create a robotics project.

Prerequisites

* Install the robotics package. Go to DIAStudio Download to download the
package.

For more information about the installation of a package, see Install and
Uninstall a Package.

To create a robotics project
1. On the menu bar, select File > New Project.
2. In the New Project dialog, select the Robotics project template.

3. Enter the project name and project location, and then click OK.
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4. Inthe Robotics Project dialog, enter the name and select the robot type for

each robot. Click T to add robots. The maximum robots you can add is 6.

Note: The name must start with an English character or underscores
and only contain English characters, numbers, and underscores.

5. Click OK.

For more information about the configuration and usage of the robotics solution,
see the documents in the docs folder in the path where you installed the robotics
package. The default path is C:\Users\username\Robotics\docs.
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Chapter 5: Hardware Configuration

In the Hardware Configuration editor, you can view the hardware information, add
modules, set module parameters, detect and diagnose the hardware online.

How do | open the Hardware Configuration editor?

* On the Devices pane, double-click Hardware Configuration.

The Hardware Configuration toolbar is shown on the top of the editor.

Bf 2% | EtherCAT - EtherCAT_Master 5. | 100 |5 == +

T ]

The following table lists the settings in the toolbar and their descriptions.

Setting Description
Click to show the module information.
»a Click to scan the online device.
EtherCAT v Select the remote 1/0 network.
100 |& Select or enter the value to zoom in or zoom out.
i — Drag to zoom in or zoom out.
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5.1 Add an Extension Module

You can add an extension module to the right side of the controller in the Hardware
Configuration editor. There are four types of modules you can select to add.

* Analog I/O Modules
* Digital I/O Modules
* Network Modules (AX-3 only, support adding up to four)
* Motion Control Modules
* Positioning/Counter Modules
Supported controllers:
* AX-3 series

* AX-5 series

To add an extension module
1. On the Devices pane, double-click Hardware Configuration.

2. In the Hardware Configuration editor, click the extension placeholder on the
right side of the controller, and then available modules will be listed in Product
List.

e| 2 100 [§] = —t———1t

1 -]

[ Display All Versions

Product List
I {ﬁ} Analog VO Maodules
@ Digital IO Modules

[
I @ Network Modules
[

{ﬁ} Pasitioning/Counter Modules

3. Expand Product List and add the module. Do one of the following:
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4.

o Double-click the module.

° Drag the module to the placeholder.

When you click the module in the list, you can view the module information at
the bottom of the Product List pane.

Product List Editor

- 1 M

|

=

[ Display All Versions

Product List
- {ﬁ} Analog IO Modules
ASD2ADH-A
§% ASD2LC-A
§% ASD4AD-A
£5 ASD4DA-A
§% ASD4RTD-A
§% ASDATC-A
§% ASDERTD-A
§% ASDEXA-A
§% ASDBAD-B
§% ASDBAD-C
§% ASDETC-A
I {8 Digital 'O Modules

pwl

I @ Metwork Modules

Version: 1.0.0.9

Trigger imputich

I @ Positioning/Counter Modules

2 channels high-speed conversion of analog input :
-107+10V, 0710V, -57+5V, 075V, 0/4™20ma,
=207 20méA; Conversion time = 20usf2channels; 1

(optional) You can right-click the module, and then cut, copy, paste, or delete

the module if needed.
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5.2 Add a Function Card

If you add a Network Module ASO0SCM-A to the controller, you can also add
function cards to expand the function of the module. The ASO0SCM-A module
provides two slots to add the following function cards.

* AS-F232
* AS-F422
* AS-F485

* AS-FCOPM (slot two only)
Use the following steps to add a function card.
Prerequisites

* Add the ASO0SCM-A module to the controller.

To add a function card
* Do one of the following:

° In the Hardware Configuration editor, click the slot on the ASO0SCM-A
module, and then add the function card from Product List.

° On the Devices pane, under ASO00SCM-A, right-click the <Empty>
node and then select Plug Device. In the Plug Device dialog, select the
function card, and then click Plug Device.

5.2.1 Configure Function Card as Modbus Master COM Port
The function card can be configured as a Modbus master COM port.

To configure the function card as a Modbus master COM port
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1. Add one of the following function cards:

o AS-F232
o AS-F422

° AS-F485
2. Double-click the function card and go to Configuration
3. Select the Data Exchange checkbox
4. Click Add Channel. You can add a total of 32 channels.
5. In the Modbus Channel dialog, configure and enable the channel.

6. On the AS-XXX I/0 Mapping pane, configure the I/O mappings to map the
input and output. For more information, see Edit I/O Mapping.

5.2.1.1 Function Card Settings (Modbus Master)

The following table shows the function card settings when it is set as a Modbus COM

port master.

Configuration

Configuration

AS-F232 1/0 Mapping Baud Rate: 9600
Status Parity: Even
Information Data Bits: Y
Stop Bits: 1
Transmission Mode: ASCII
Delay Time to Reply (ms): 0 H
Data Exchange:

Received Data Timeout Alarm: [ ]

Detect Slaves Automatically: @[ ]

Mode: Program Control

Retry Count: 0 H
Update Cycle (ms): 50 }—:—I
Connection Timeout (ms): 100 EI
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Settings Description
Baud Rate Select the baud rate (in bits/second).
Parity Select the parity bit usage in the communication packets.
Data Bits Select the number of bits of data per character.
Stop Bits Select the number of stop bits per character.

Transmission
Mode

Select the mode of transmission:
* RTU: Transmitted in binary.

* ASCII: Transmitted in ASCII code (currently not support-
ed by all drivers).

* SCMRS: Transmitted using the communication proto-
col defined by each slave. You can perform this by the
DFB_SCMRS instruction (only support the function card
version 1.0.0.3 or later).

Delay Time to Re-
ply (ms):

Select or enter the delay time to respond after receiving a
communication command. The value range is 0—-100000.

Data Exchange

Select to turn on or turn off data exchange between master
and slave. Turn it on when configuring the function card as
the Modbus master COM port.

Received Data
Timeout Alarm

Select to turn on or turn off receiving alarm when timeout.

Detect Slaves Au-

Select to turn on or turn off automatic detection whether the

tomatically slave exists before data exchange.
Note: Before selecting this option, ensure the slave
device is powered on before the master device.
Mode Select the execution mode of data exchange.
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Settings Description

* Program Control: The data exchange is controlled by
the program.

* PLC Run: When the controller is in RUN mode, the data
exchange starts automatically. Once the controller’s sta-
tus changes to Stop, the communication disconnects.

* Always Enable: The data exchange starts once the
controller is started.

Retry Count Select or enter the number of times of COM Port re-communi-
cation. The value is 0-10.

Update Cycle (ms) | Select or enter the amount of time for an update. The value is
0-6000.

Connection Time- | Select or enter the amount of time for no connection re-

out sponse. The value is 0—6000.

After you click Add Channel, the Modbus Channel dialog shows. The following
table shows the settings and descriptions.

Modbus Channel
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]

Enable

Remote Device Settings

Channel Mame Item 1
Slave Address [1..240] 1
Device Type Standard Modbus Devices |w
Read
Access Type Read Coils L
F Device Address Ow0
Length 1

Write

Access Type Write Single Coi b

* Device Address 0x0

Settings Description
Enable Select to turn on or turn off the data exchange channel.
Channel Name Enter the name of the channel.
Slave Address Enter the slave address. The valid range is 1-240.
Device Type Select the device type.
Access Type Select the Read and Write access type. If Read/Write Multi-

ple Registers is selected for either Read or Write, it will also
synchronize with the other.

Device Address Select the device address and enter the value in hexadecimal
format.
Length Enter the word length that reads or writes from or to the regis-

ter. The value varies with different Access Type and Device
Address.

AS-XXX 1/0 Mapping
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Configuration Find Filter Show all - dk Add FB for |0 Channel... Go to Instance
AS-F232 /0 Mapping Variable Mapping  Channel Address Type Unit  Description
L ] Card DataExchangeState(jtem 1~32) {l:none/fai, Lisuccess) %ID2 DWORD
Status Ho Card UDLinkState(0:none/fprocessing, 1:finshed) 2LIWE WORD
+- " Card DataExchangeModeControl(0:none, 1:once, 2:always) SRQW 2 WORD
Information +. g Card DataExchangeTrigger (item 1~32) (0:no trigger, 1:trigger) %%QD2 DWORD
+- " Card UDLinkGroupIDTrigger SRQWE WORD
L ] FunctionCardInput(Slave) YIW7 ARRAY [0..99] OF WORD
+-Tg FunctionCardOutput{Slave) %QW7 ARRAY [0..99] OF WORD

Create and map variables. For more information, see Edit I/O Mapping.

Status

Configuration ASF232

AS-F232 I/O Mapping Last diagnostic message

|n,|‘a

Status Diagnosis Message:

Information

Shows the function card’s current status.

Information

Configuration General

Name: AS-F232
Vendor: Delta Electronics, Inc,
Categories: Function Cards
Type: 40000
Status 1ID: 16F7 8101

Version: 1.0.0.2

Order number: AS-F232

AS-F232 /0 Mapping

Information

Description: Serial COM, RS-232 interface, slave/host mode,

Shows the function card’s general information.

5.2.2 Configure Function Card as Modbus Slave COM Port

Use the following steps to configure the function card as a Modbus slave COM port.

To configure the function card as a Modbus slave COM port

1. Add one of the following function cards:
° AS-F232
o AS-F422

° AS-F485
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2. Double-click the function card and go to Configuration.

3. Clear the Data Exchange checkbox.

4. On the AS-XXX I/0 Mapping pane, configure the settings and I/O mappings of
the function card. When configured as a Modbus slave, the function card can
provide 100 input and 100 output Word addresses. For more information, see
Edit I/O Mapping.

5.2.2.1 Function Card Settings (Modbus Slave)

The following table shows the function card settings when it is set as a Modbus slave

COM port.
Configuration
Configuration
AS-F232 I/O Mapping Baud Rate: 9600
Status Parity: Even
Information Data Gits: 7
Stop Bits: 1
Transmission Mode: ASCII v
Delay Time to Reply (ms): |0 [+]
Data Exchange: ]
COM ID: 1 4]
Settings Description
Baud Rate Select the baud rate (in bits/second).
Parity Select the parity bit usage in the communication packets.
Data Bits Select the number of bits of data per character.
Stop Bits Select the number of stop bits per character.

Transmission
Mode

Select the mode of transmission:
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Settings Description

* RTU: Transmitted in binary.

* ASCII: Transmitted in ASCII code (currently not support-
ed by all drivers).

* SCMRS: Transmitted using the communication proto-
col defined by each slave. You can perform this by the
DFB_SCMRS instruction (only support the function card
version 1.0.0.3 or later).

Delay Time to Re- | Select or enter the delay time to respond after receiving a
ply (ms): communication command. The value range is 0—100000.

Data Exchange Select to turn on or turn off the data exchange between mas-
ter and slave. Turn it off when you configure the function card
as the Modbus slave COM port.

COM ID Select or enter the COM ID number. The value range is 1—
247.

AS-XXX 1/0 Mapping

Configuration Find Fitter Showall + &b Add FRfor |0 Channel.. ™= Go to Instance
sSFRR 0 ing Variable Mapping ~ Channel Address  Type Unit  Description
vl Card DataExchangeStateitem 132) (Dmonefal, Lsuccess) %02 DWORD
Status £ Card UDLinkState(D:naneprocessing, 1:finshed) %WWe  WORD
+5 Card DataxchangeModeControl(Q:none, Lonce, 2aways) — %QW2  WORD
Information +% Card DataExchangeTriggertem1~32) (0no trigoer, Lirigger) — %Q02  DWORD
£ Card UDLinkGroupIDTrigger %QWe  WORD
bl FunctionCardInput(Siave) WIW7  ARRAY[0..99] CFWCRD
) FunctionCardOutput(Slave) %QWT  ARRAY[0..99] OF WCRD

Create and map variables. For more information, see Edit IO Mapping Tab.

Status
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Configuration

AS-F232 : Inja
A5-F232 /O Mapping Last diagnostic message
Status Diagnosis Message:

Information

Shows the function card’s current status.

Information

Configuration General

Name: AS-F232
Vendor: Delta Electronics, Inc.
Categories: Function Cards
Type: 40000
Status D: 16F7 8101
Version: 1.0.0.2
Order number: ASF232
Information Description: Serial COM, R5-232 interface, slave/host mode.

AS-F232 IJO Mapping

Shows the function card’s general information.

5.2.3 Configure Function Card as a CANopen Slave

Use the following steps to configure the function card as a CANopen slave.

To configure the function card as a CANopen slave
1. Add the function card AS-FCOPM in slot two under the ASO0SCM-A module.
2. Double-click the function card and then go to Configuration.
3. Enter Station ID from 1 to 127.

4. On the AS-FCOPM IO Mapping pane, configure the 1/0O mappings to map the
input and output. For more information, see Edit I/O mapping.

5.2.3.1 Function Card Settings (CANopen Slave)

The following table shows the function card settings when it is set as a CANopen
slave.

Configuration
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Configuration

AS-FCOPM IfO Mapping Protocal: CAMopen DS301 v

Status Station ID 1 &

Informatian

Settings Description
Protocol Select the CANopen DS301 protocol.
Station ID Set up the address of the station. The value range is 1-127.

AS-FCOPM I/O Mapping

Configuration find Filter Show all v g Add B for |0 Channel.. ™ Goto Instance |
SO0 Mappitg Variable Mapping ~ Channel Address  Type Unit  Description
% Card DateExchangeState(tem 1632) (Oinonefal, Lisuccess) ~ %IDS4  DWORD
Status 2% Card UDLinkState(0:none processing, L:finshed) %W WORD
2% Card DatexchangeModeControl(Q:nong, Lionce, 2ialways)  %QW108  WORD
Information 3% Card DatexchangeTrigger(tem1~32) (Oino trigger, Lirigger)  %QDSS  DWORD
+-% Card UDLinkGroup!DTrigger %12 WORD
2% FunctionCardinput(Slave) %IW1LL  ARRAY [0..99) OF WORD
5 FunctonCardOutputSave) %QNL3  ARRAY [0.99) OF WORD

Create and map variables. For more information, see Edit I/O mapping.

Status

Configuration — : ‘n ;

ASFOPN 10 Mapping Lastdiagnosticmessage Kinovledge
Status Diagnosis Message:

Information

The function card’s current status.

Information
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Configuration Generd

Name: AS-FCORM
Vendor: D=lta Bectronics, [nc
Cateqories: Function Carcs
Type: 0000
Gt 10: 16F76106
Version: 1.0.0.3
Order number: ASFCOPM
Information Description: CANopen part, suppart DS301,

ASFCOPM 1/0 Mapping

The function card’s general information.

5.3 Add an I0-Link Device

Adding a Network Module AS04SIL-A to the controller can also add an |O-Link
device to expand the module's function. The Standard I/0O (SIO) can be added
directly, while to add the 10-Link device, you must first install the 10 Device Profile.

To add an 10-Link device
1. Select Tools > Device Repository.
2. Inthe Device Repository dialog, click Install.
3. Select an |0 Device Profile to install.

4. On the Devices pane, under AS04SIL-A, right-click the <Empty> node and
then select Plug Device.

5. In the Plug Device dialog, select Fieldbuses > 10-Link Device. Select the |10O-
Link device you installed and then click Plug Device.

5.4 Add an EtherCAT Coupler

Coupler provides an option to connect the controller with the Remote I/0O modules.
The Remote 1/0 modules can be arranged side-by-side in a scalable way on the right
side of couplers. DIADesigner-AX supports adding the following couplers.

* ASRTU-EC16AP1PA, ASRTU-EC16AP1TA

* AX-500CECO00-0A
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* R1-EC5500

* R1-COOCEOQ0-0A
* R3-COOCEO00-0A

* RTU-ECAT

Note: The logic controllers do not support adding couplers and Remote |/O
modules.
To add an EtherCAT coupler
1. On the Devices pane, right-click EtherCAT_X and select Add Device.

2. Inthe Add Device dialog, select Fieldbuses > EtherCAT > Slave > Delta
Electronics, Inc. > System Couplers.

3. Select one of the couplers and then click Add Device.

5.5 Add a Remote I/0 Moudule

After the coupler is added, it will show on the Hardware Configuration editor. You
can add the Remote 1/0O module to the couplers.

To add a Remote 1/0 module

1. On the Hardware Configuration editor, click the expansion area on the right
side of the coupler.

2. In Product List, select a Remote 1/0O module, and do one of the following:

o Double-click the module.

° Drag the module to the expansion area.

3. (optional) You can right-click the module, and then cut, copy, paste, or delete
the module if needed.

Or
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1. Scan network and select a gateway.

2. On the Devices pane, right-click EtherCAT_X and then select Scan for
Devices.

3. Inthe Scan Devices dialog, select the device and click Copy to project.

POU_1 A, Network Configuration Editor m DIO CQ Hardware Configuration [AX_308EAOMALT] X |~ || Product List Editor > o X

Bl 2% | EtherCAT - EtherCAT_Master S... |V 100 &) ==t

[] Display All Versions

+
i

Product List
[ @} Analog /O Modules

I {@ Digital 'O Modules

ToolBox * 0 X

Note:

*  AX-500CECO00-0A coupler also supports adding Power Supply
Modules.

* Up to 64 remote I/O modules can be added to the AX-308 or AX-316
series controller.
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* Up to 16 remote /0O modules can be added to the AX-304 series
controller.

* Up to 96 remote I/O modules can be added to the AX-364 series

controller.

5.6 Module Current Consumption Calculation

On the Hardware Configuration editor, click 51 to show the module information.

* 1 X <8 Hardware Configuration [Device] X
T‘ ) &% |EtherCAT - EtherCAT Master S... |¥

Show module information

l—+{Total Module Width: 205mm

£ (Internal) Current Consumption; 488mA
#J%(External) Current Consumpfion: 0mA
[P Power Current Output: 2000mA

b+ Total Module Width: 50.5mm

&2 (Internal) Current Consumption: OmA
£ (Extemnal) Current Consumption: 550mA
R Power Current Quiput: 2000mA

The following table lists the information and description of a module.

Item Description

Total Module Width | The total width of the modules mounted to a controller or a
coupler.

(Internal) Current | The total internal current consumption.
Consumption

(External) Current | The total external current consumption.
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Item Description

Power Current Out- | The maximum current power output of the device (only show
put values for couplers).

After adding modules, their internal and external current consumption will

be calculated and updated in the information. Once the total internal current
consumption of the modules mounted to the right of the coupler or the power supply
device output exceeds the maximum current output, a warning message shows and

an icon B shows under the module that has exceed the maximum current output.

s_Pso2

AS

D
O8AK
02HC
02HC
02HC
02HC
02HC
02HC..

S02HC

02HC
02HC
02HC
02HC

evice
ASDEAM

[

08
AM

The current consumption of installed modules has exceeded the supply of power module

fe—+{Total Module Width: 158 5mm

&3 (Internal) Current Consumption: 2160mA
= & (External) Current Consumption: 550mA

mn Power Current Qutput: 2000mA

[

7

1

[

[0 [T

4 @

7 7 [T

A
A
A
A
A
A
A
A
A
A
A
A

5.7 Add a Power Supply Module

The power supply modules supply power to the controller. It can only mount to the
controller and do not have any configuration data.

To add a power module
1. On the Devices pane, double-click Hardware Configuration.

2. On the Hardware Configuration editor, click the expansion placeholder, and
the power supply modules will be listed in Product List.

3. Expand the module list and add the power supply module. Do one of the
following:
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o Double-click the module.

° Drag and drop the module to the placeholder.

When you click the module, you can view the module information at the bottom
of the Product List pane.

4. (optional) You can right-click the module, cut, copy, paste or delete the module
if needed.

.ﬁnu-u. A

101
:r:@

& Cut Ctrl+X
D Copy Ctrd=C

E‘: Delete Del

5.8 Add a Motion Control Module

Use the following steps to add a motion control module.
To add a motion control module
Do one of the following:

1. Add an AX-5 series controller.

2. On the Devices pane, under EtherCAT_X, right-click AX5_Local_lO_Bus and
then select Add Device.

3. Inthe Add Device dialog, select Fieldbuses > EtherCAT > Slave > Delta
Electronics, Inc. > Motion Control Modules > one of the motion modules,
and then click Add Device.

Or
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1. Add a controller.

2. On the Devices pane, right-click EtherCAT_X, and then select Add Device.

3. Inthe Add Device dialog, select Fieldbuses > EtherCAT > Slave > Delta
Electronics, Inc > System Couplers > AX-500CEC00-0A (Ethercat coupler),
and then click Add Device.

4. Under AX-500CECO00-0A, add one of the motion modules.

5.8.1 AX-502HC Hardware 10 Configuration Page

DIADesigner-AX provides an interface to configure the hardware 1/O of the
AX-502HC motion module.

The following table shows the hardware 1/O settings and descriptions.

General » Configurations
| I Status
Channel 0 /| o

CoE Parameters

Process Data e Filter e Polarity

Hardware 10 Configuration LO/IB0  D.dus ¥ w {4
L R 0 |004s v 10 . i

Log - :
— lomo @no|l______ 2 [004s v R . 1t

EtherCAT /O Mapping 1(180) (181)1 Q0 . 'M'
EtherCAT IEC Objects 2(120)  (121)2 Q l #

Q4
Status AR L300y (11)3 l s

4(12) (13)4 CHI LATCH!

Information Channel 1
5(Q0) (QU5 anne

6(Q2) (Q3)6 | Filter Polarity
7(Q4)  (@)7 — 141/ 181 | Disable * 1Z1 i W
I Disable ¥ 1 . It

3 Disable v 6 . it

o Wi

L

s Bt

E [t

Settings Description

[#

o Pin Selection Click
terminal number.

to open the Pin Selection dialog and select the I/O
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Settings

Description

Note: If two pins select the same I/O terminal num-
ber, the system automatically changes the first one to
None.

9 Filter

Select the filter time. The default value is Disable.

9 Polarity

Click to set the contact polarity to A contact.

Click . to set the contact polarity to B contact.

5.8.2 AX-502PU Hardware 10 Configuration Page

DIADesigner-AX provides an interface to configure the hardware 1/O of the
AX-502PU motion module.

The following table shows the hardware 1/O settings and descriptions.
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General + Configurations em—
|_|_ Status
CoE Parameters Axis 0 p,
Process Data Polarity e
f N |
Hardware IO Configuration D . %‘
L R 14 .
= Avis0 LSP 0 (10) (11)0 Avisl LSP =ﬁ
—— — (]
EtherCAT I/O Mapping adsoLsw | 4 ©) @)1 Axisl LSV . . -VH
EtherCAT IEC Objects Axis{) HomeSwitch | 5 (14) (s)2 LA HomeSwitch QA0 / QB0 . %‘
Status _As0Z | 3q6)  (7)3 | AWIZ Q0 9 44
Axis0 ImmediatelyStop 4(18) (19) 4 Avis! ImmediatelyStop
Information
Avis0 AB Avisl AB
0045 | 5(Qa0) (QA1)s | A4S Adis 1 p
Avis( AB 6(QB0) (QB1)6 Avisl AB Polarity
As0aR | 700)  (on)7 | A%1aR 1 . Vﬂ
s Wl
15 . J/}-‘
A |
19 9 41
QA1 Q81 . J,{H
o W
Settings Description
0 Pin Selection | Click ___| to open the Pin Selection dialog and select the 1/0
terminal number.
9 Polarity Click . to set the input contact polarity to A contact.
Click . to set the input contact polarity to B contact.

5.9 Add a Load Cell Module

A load cell module supports connecting the load cells directly to the controller without

requiring an external signal converter. DIADesigner-AX supports adding the following

load cell modules.
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* ASO2LC-A

* AX-501LC10-0A

To add a load cell module
e ASO02LC-A

°© Add an ASRTU coupler and then add the AS02LC-A module.

° Add the AS02LC-A module directly to the AX-3 series controller with

firmware version 1.0.3.0 or later.
* AX-500CECO00-0A

o Add an AX-500CECO00-0A coupler and then add the AX-501LC10-0A
module.

° Add the AX-501LC10-0A module directly to the AX-5 series controller.

5.9.1 Open the Calibration Tab

The load cell module must be calibrated to ensure the weight is read accurately.
DIADesigner-AX supports calibrating the load cell module.

To open the calibration tab

1. Configure Communication Settings to connect to the controller attached to
the load cell module.

2. Ensure the devices is added properly in the project.

3. On the toolbar, click IE_I

4. On the Devices pane, double-click the load cell module.

5.9.2 Calibrate the Load Cell Module

Use the following steps to calibrate the load cell module.

To calibrate the load cell module
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1. Select a channel.

2. Enter Total Calibration Points and Weight of each calibration point to set

calibration criteria.

The range of calibration points is 2—20.

3. Click Start.

4. Click each calibration point, put the weight that matches the weight value

entered earlier on the load cell, and then click Calibrate. Repeat this step for

each calibration point you set.

The module will return the raw data of each calibration point.

5. Click Stop. The weight calibration is completed.

While calibrating, you can view the channel’s status in Channel X Status and

the module’s status in Module Status.

5.9.3 Calibration Settings

The following table lists the calibration settings of the load cell module.

Settings Description
Upload Upload the parameters from the controller to the software.
Download Download parameters to the controller.
Import Import the weight parameters from a CAL file.
Note: Also import the module’s parameters for AX-3
series.
Export Export the weight parameters to a CAL file.
Note: Also export the module’s parameters for AX-3
series.

The following table lists the settings of the channel.
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Settings Description
Start Click to turn on calibration.
Calibrate Click to get the raw data from the module of each calibration
point.
Stop Click to stop calibration.
Clear Error Click to clear errors if any.

Check Channel X Status for software errors and Module
Status for hardware errors.

Download Click to download the configuration of the current channel to
the online device.

The following table lists the options for handling tare weight.

Setting Description

Tare Click to remove the tare weight of the item placed on the
channel (continuous peeling is possible).

Clear Tare Click to restore the tare weight recorded in the channel.

Zero Click to reset the display value of the channel to 0.

5.10 Controller Configuration and Settings

This section introduces the system, network, and other settings of AX series
controllers.

For more information on the hardware and operations of the CPU or modules, see
Catalogs, Hardware Manual, and Operation Manual.

Before setting parameters, check the facts that affects the CPU module and the
whole system to prevent damage to the system. The parameters set only takes effect
after they are downloaded to the CPU device module.

5.10.1 System Settings

How do | open the System Settings tab?
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* On the Devices pane, double-click the device and then go to System Settings.

Use the following tables to view and configure the settings.

Runtime Clock

Setting

Description

Read PLC Time

Click to read the time and time zone from the controller. PLC
Time and PLC Timezone are updated accordingly.

Date

Set the date.

Time

Set the time.

Write PLC Time

Click to write the date and time based on the selected time-
zone to the controller. PLC Time and PLC Timezone are up-
dated accordingly.

Sync with Local
Time

Click to sync all the time, date, and timezone settings with the
computer time.

Note: This function is not available for AX-8 Windows series controllers.

Time Zone

Setting

Description

Read Timezone

Click to read timezone information from the controller.

Write Timezone

Click to write the timezone to the controller. PLC Timezone is
updated accordingly.

Note: This function is not available for AX-8 Windows series controllers.

Network

Setting

Description

Enable Gateway
and DNS Setting

Select to turn on the default gateway and DNS server set-
tings. Only available for AX-332, AX-5, and AX-C series con-
trollers.
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Setting

Description

IP Address Mode

Select the IP address mode of Static or DHCP.

IP address

Set the IP address, subnet mask, and default gateway in the
Static mode.

Obtain DNS server
address automati-
cally

Select to obtain the DNS server address automatically. This
function is only available when selecting DHCP as the IP ad-
dress mode for AX-332, AX-5, and AX-C series controllers.

Use the following
DNS server ad-
dresses:

Select to enter Preferred DNS server and Alternate DNS
server.

Read from PLC

Click to read and update the IP address from the active de-
vice.

Apply IP settings
while download

Select to apply the changed IP address after download.

Project ID

Settings

Description

Set Project ID

Click to set Project ID and PLC ID. For more information, see
Password Management and Data Protection Mechanism.

Note: This function is not available for the AX-8 Windows controller.

Persistent Retain Settings

Setting

Description

Original mode

Select to keep CODESYS persistent variable mode.

%M mode

Select to set up the %M address to retain persistent variables.

e Start Memory Address: Enter the value for the start
memory address. The value can start from 0 and cannot
exceed the value in End Memory Address.
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Setting Description

Note: For the AX-8 Linux series, the start value can
start from 0 only when you select Extended size for
Retain Size.

* End Memory Address: The end memory address is not
editable.

Clear Click to clear all the %M addresses assigned to the variables.

Retain Size

This function is only available for AX-8 Linux series controllers.

Setting Description

Read Retain Size | Click to read and show the retain size mode of the controller.
Mode Use this to check whether the controller’s retain size mode is
consistent with the mode selected in the project before login.

Write Retain Size Click to write the current retain size mode to the controller.

Mode The change takes effect after a controller restart.
Default size Select to use the default retain memory size.
Extended size Select to extend the retain memory size.

5.10.2 System Parameters

How do | open the System Parameters tab?

* On the Devices pane, double-click the device and then go to System
Parameters.

System Parameters shows the communication and controller basic parameters.

Use the following tables to view and configure the parameters.

Item Description

Parameter Shows the parameter name, not editable.
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Item Description
Type Shows the data type of the parameter, not editable.
Value Shows the initial value of the parameter or the corresponding

symbol name. Double-click the field to change the value or
select from the dropdown list to change the value if the para-
meter is editable.

Default Value

Shows the default value of the parameter defined by the de-
vice description, not editable.

Unit Shows the unit of measure for the value (example: “ms” for
milliseconds), not editable.
Description Shows the description of the parameter specified by the de-

vice description, not editable.

5.10.3 Device Diagnosis

How do | open the Device Diagnosis page?

* Right-click the controller, and then select Device Diagnosis.

If an error occurs while the controller is running, you can open Device Diagnosis to

inquire about the hardware errors.
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Device Only Show Device With Error Auto Update Login
Built-in 10 Name: Error Id: Messages:
BuiltIn_I0 : DIO Device offiine
FiherCAT Buitin_10 : SSI_Encoder Device offline
Local bus Buitin_10 : Pulse_Encoder Device offline
Builtin_I0 : Capture_Compare Device offline
BuiltIn_I0 : Pulse_Output_Axis Device offline
EtherCAT_Master_SoftMotion Device offiine
AS00SCM_A Device offiine
AS_F232 Device offline
AS_FCOPM Device offline
[ Ethernet Device offine
Name: Type:0 Id: Version:
A Error Id:
Messages:

The following table lists the settings in the Device Diagnosis page and their

descriptions.

Setting Description
Device Lists the device category in the project tree.
You can click one category to show the devices of this cate-
gory.
Search Enter keywords to search the device.

Only Show Device
With Error

Select to show devices with errors.

Auto Update

Select to update device status automatically.

Update Click to update the device status.
Name Shows the device name.
Error Id Shows the error ID. You can see troubleshooting or error

code chapters in different manuals for the device error code.
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Setting Description

* Built-In IO: Delta AX-3 Series Operation Manual

e EtherCAT:

o Delta ASDA-A2 Series Servo Drive User Manual

o Delta ASDA-A3 Series Servo Drive User Manual

o Delta ASDA-B3 Series Servo Drive User Manual

° Other corresponding manuals for non-Delta servos

* Local Bus:
o  AX-3 Series Operation Manual

o AS Series Module Manual

Messages Shows the device status.

5.10.4 High-speed I/O Settings
How do | open the Hardware 10 Configuration page?
* On the Devices pane, double-click Builtin_IO.

High-speed I/O provides the following settings.

* SSI Encoder: Set up the SSI encoding type, clock frequency, SSI data length,
and other functions.

* Counter/Timer: Set up the high-speed counter variable counting mode, and
pulse encoder, enable the Z-phase signal, or declare the high-speed timer
variable.

* Capture/Compare: Set up the high-speed capture variables and high-speed
comparators.
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* Pulse Output: Set up the pulse output mode, direction, origin return mode, and

parameters.

* DIO: Set up the filter, polarity, and DIO I/O mappings.

5.10.4.1 High-Speed 1/O Settings Supported

The following table lists the comparison of high-speed I/O configurations.

AX-

Configur |AX- |AX- |AX- |[AX- |AX- |[AX-
AX-5 | AX-C | 864EP1ME

ations 304 (308 (316 (324 |332 |364

1TP
SSi X X X X
Counter X X X X X X X X
Timer X X X X X X
Capture |x X X X X X X X
Compare |x X X X X X X X
Pulse X X X X X X X X
Output
AXis
DIO X X X X X X X X
Interrupt | x X X X X X X

Note:

1.

This section does not applied to AX-300NAOPA1 and AX-8 other
controllers.

2. There is no differential encoder in AX-304 and AX-324.

5.10.4.1.1 Builtln 10: SSI Encoder Configuration

How do | open the SSI Encoder Configuration page?
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1. On the Devices pane, double-click Builtin_lO and go to Hardware 10
Configuration.

2. Select SSI Encoder.
The SSI Encoder Configuration tab shows below Hardware 10 Configuration.

The AX series controller supports a set of SSI encoder functions on the I/O end. It is
connected to the controller through the D-SUB interface. This interface provides 5V
power output for the encoder power. The parameters required by the encoder can be
received through the hardware configuration channel.

SSI Encoder architecture

AX PLC
Data 551 Encoder Parameter Setting
- — *
Clock 551 Encoder
L LT L

The following tables show the SSI Encoder settings and descriptions.
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Hardware I0 Configuration
General
551 Encoder Configuration
Clock Frequency Cloch Pause Tima
—
IEC Objects ! ! ] :
Clock f f ;‘\ f f f f f \( f f
BuiltIn_I0 /0 Mapping : : :
Data R e\ e e v e cms N S G S
Status .
| Multi-Tuen Data Single-Tumn Data
Information L e -
Encoder Type: | Gray Code =
Clock Frequency: 500 kHZ  Clock Pause Time: 50 E us
Single Turn Settings: | 13 Multiple Turns Settings: |12
Axis Standard
Positive Command Negative Command
Encoder Type: 551 Encoder
® R OFF
(@) Finite () Modulo
cwW CCow
Modulo: 360 [ Unit]
() Rewverse On @9_ @ '9‘
Ccow cw
e Transmission Mechanism
Mechanism Type | Ball Screw - Mechanism Settings
(1) Command pulse per motor rotation: |1 [ Pulse ]
@)
@ — (4) Pitch: |1 [ Unit ]
Gear Box
(2) Gear ratio numerator E
3) Gear Ratio =
(3) Gear ratio denominator |1 E
o General
Setting Description

Encoder Type

Select the encoding type.

Clock Frequency

Select or enter the frequency of the transmission clock signal
used for SSI encoder communication. The value range is 0—
10000.

Note: AX-332 and AX-C can only select the value
from the list.
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Setting

Description

Clock Pause Time

Select or enter the time that the data line remains low af-
ter the last falling edge of the clock and before the data line
is pulled high (see the SSI encoder data sheet). The value
range is 0-65523.

Note: AX-332 and AX-C can only select the value
from the list.

Single Turn Set-
tings

Select or enter the bit length of the single turn resolution (see
the SSI encoder data sheet). The value range is 0-65523.

Multiple Turns Set-

Select or enter the bit length of the multi-turn resolution (see

tings the SSI encoder data sheet). The value range is 0—65523.
9 Axis Standard
Setting Description
Encoder Type Shows the SSI encoder type.
9 Axis Type
Setting Description

Finite / Modulo

Select the axis type. When the modulo axis is selected, enter
the rotation value. The default value is 360.

o Positive/Negative Command

Setting

Description

Reverse OFF / On

Select the forward or reverse command.

9 Transmission Mechanism

Setting

Description

Mechanism Type

Select the mechanism type.
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Setting Description
Mechanism Set- Set the parameter value for the selected mechanism. The set-
tings tings differ by type. The default value is 1.
Gear Ratio Select or enter the gear ratio’s numerator and denominator.
The default value is 1.

You can right-click Builtln_lO, and then select Edit IO Mapping to set up the SSI
Encoder Mapping variables. The following table lists Encoder Position and Error ID
descriptions on the Edit IO Mapping page.

Item Description

Encoder Position The location of SSI

ErroriD The SSI Encoder Communication status
0: No Error
1: Error Communication

2: Wrong Parameter Setting

* ErrorlD = 1 when the SSI Encoder is not connected or the SSI Encoder is
disconnected from the CPU.To clear the error, check the connection between
the SSI encoder and CPU. The updated firmware ensures the communication
channel is connected correctly to restore EncoderPosition updates of BusCycle.
There are many reasons for the cause of errors, for example, the SSI encoder
incorrectly connected, a broken SSI encoder, or an abnormal drive board.

* ErrorlD = 2 when MultiTurns + SingleTurns is greater than 32. To clear the error,
ensure the value of MultiTurns + SingleTurns does not exceed 32.

SSI Encoder used in a program

The SSI encoder device contains the axis encoder variables that can be used for MC
function blocks in POU, for example, MC_Camin.

Use the variable Encoder_Axis when the axis is used in POU.
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Hardware 10 Configuration Variable Type Configuration Function
S51_Encoder DFE_S5I_FMCODER_REF 551 Encoder

551 Encoder Configuration DMC_ENCODER_AXIS_REF 551 Encoder [FreeEncoder_Axis

IEC Objects

BuiltIn_ID I/O Mapping

Status

Information

MC_CamIn_0
HC CamIn

Hs5lave Busy —
=|Execute Commandiborted
—MascerOffsetc Error
=1S5lavelffser ErrorID f—-
—MasterScaling EndOfProfile
—|SlaveScaling Tappets [
={5tartMode
—CamTableID
=VelocityDiff
—hcceleration
—|Deceleracion
= Jerk
—|TappecHysteresis

5.10.4.1.2 Builtin 10: Counter/Timer Configuration
How do | open the Counter Configuration page?

1. On the Devices pane, double-click Builtin_lO and go to Hardware 10
Configuration.

2. Select a counter.
The Counter Configuration tab shows below Hardware 10 Configuration.

High-speed counter
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Pulse Input

L L

AX PLC

Counter Channel

Counter Parameter Setting
!

Counter

——+ Counter Cutput

The following tables show the Counter settings and descriptions.
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Hardware I0 Configuration

IEC Objects

BuiltIn_IO I/O Mapping

Status

Information

00 O O

Counter 2

Counter Configuration Q Counter Mode
Counter Mode Description

Clockwise Pulse —+_|—+_|
O up
Counter-clockwise Pulse f f
Pulse _+—|
O PD
Direction Clockwize | Counter-clockwise
A-Phase Pulse _f_| I 1
J AB
B-Phase Fulse I | I | I
A-Phase Pulse f 1 £ i f t f t
O 44B
8-Phase Pulze + * + * + * + *

[] External Trigger

Axis Standard o
Positive Command Negative Command
Encoder Type: Incremental Encoder
(®) Reverse OFF i i % 9 : t % 9
Axis Type = - -
W cow

(@) Finite ) Module
Module: 360 [ Unit ]
Encoder Filter
() Reverse On . .
Pulse Encoder: |1 E
Cow oW

Transmission Mechanism

Mechanism Type | Ball Screw " Mechanism Settings

{1) Command pulse per motor rotation: E [ Pulse ]
(@)

q=:> {4) Pitch: |1 [ unit ]
s (

@)

@

(Gear Box
(2) Gear ratic numerator E
Gear Ratio =
(3) Gear ratic denominator |1 EI
o Counter Mode
Setting Description

ub

Forward pulse train and reverse pulse train

PD

Pulse train + direction
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Setting

Description

Note: AX-332 and AX-C do not support.

AB AB phase pulse train
Note: AX-332 and AX-C do not support.
4AB AB phase pulse train (4x)

External Trigger

Select to turn on the Z phase signal.

Note: AX-332 and AX-C do not support.

9 Axis Standard
Setting Description
Encoder Type Shows the encoding type.
9 Axis Type
Setting Description
Finite Set linear or rotary axis.
Modulo Set the modulo value. This function is only available when se-
lecting Modulo as the axis type. The default value is 360.

0 Positive/Negative Command

Setting

Description

Reverse OFF/On

Select the forward or reverse command.

9 Encoder Filter
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Setting

Description

Pulse Encoder

Select the pulse encoder. The value range is 1-100.

@ Transmission Mechanism

Setting

Description

Mechanism Type

Select the mechanism type.

Mechanism Set-
tings

Set the parameter value for the selected mechanism. The set-
tings differ by type. The default value is 1.

* Command pulse per motor rotation: Enter the number
of pulses required for a motor to rotate for one cycle.

* Pitch: Enter the pitch of the screw.

* Diameter: Enter the diameter of the gear. Diameter*m =
Movement distance per motor rotation

* Movement distance per motor rotation: Enter the dis-
tance the motor moves to rotate for a cycle.

Gear Ratio

Select or enter the (2) gear ratio’s numerator (number of teeth
of the worktable) and (3) denominator (number of teeth of the
motor gear) to set the reduction ratio. The default value is 1.

Counter used in a program

The high-speed counter contains the axis encoder variables that can be used for MC

function blocks in POU, for example, MC_Gearlin).

Use the variable Encoder_Axis when the axis is used in POU.
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Hardware I0 Configuration Variable Type Cenfiguration Function
Counter_0 DFB_COUNTER._REF Counter 0

Counter Configuration DMC_ENCODER _AXIS_REF Counter 0/FrecEncoder_Axis

IEC Objects

BuiltIn_IO If0 Mapping

Status

Infarmation
1 MC GearIn
Ture MC GearIn
11 EN B ENO——
Encoder Axis -lﬁl-_'laster InGear [~
Hs5lave Busy —
—Execute Active [~
—RatioNumerator CommandAborted —
—RatioDenominator Error —
—|Acceleration ErrorID —
—Deceleration
—|Jerk
—|BufferMode
High-speed timer
AX PLC

Pulse Input Timer Channel |

¥
LT LT :
Timer  |— Timer Output

Timer used in a program

Timer contains variables that can be used for function blocks in POU, for example,
DFB_HTmr.

In the Hardware 10 Configuration page, select a Timer pin, for example, Timer 0.
The variable Timer_0 will show on the IEC Objects page. Use this name when the
axis is used in POU.
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Hardware 10 Configuration Variable Type Configuration Function
| Timer 0 | DFE_TIMER_REF  Timer 0

IEC Objects

BuiltIn_IO If0 Mapping

Status

Information

1 DFE_HTmr 0
Ture DFE HTmr
EN B ENO——
Timer bValid —
—bEnable bBusy —
—TriggerMode bError —
ErrorID —
dwlimerValue —

5.10.4.1.3 Builtin 10: Capture/Compare Configuration

This section describes the high-speed comparator and capture functions.

Capture
AX PLC
Pulse Input | Counter Channel
*
AT LIrLr Counter Qutput
* Counter
Capture
- ——
Capture Output
*
Trigger Capture Signal

Capture used in a program

Capture variables can be used for MC function blocks in POU, for example,
DFB_Capture.
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On the Hardware 10 Configuration page, select a Capture pin, for example,
Capture 0. The variable Capture _0 will show on the IEC Objects page. Use this
name when the axis is used in POU.

Hardware I0 Configuration Variable Type Cenfiguration Function
| Capture_0 ] DFE_CAPTURE_REF Capture 0

IEC Objects

BuiltIn_IO If0 Mapping

Status

Information

1 DFE_Capture_ 0
Ture DFB Capture
11 EN ENO——
HCapturs bValid
—Counter bBusy —
—bEnable bError —
—udiMazkValus ErrorID —
—dileltaMin bCapFlag —
—diDeltaMax diCapValue —
—bEdgeSelect diCapValuePrevious [—
—bCycle diDelta —
bCaplenBeyvondFlag —
dwCaplLenBeyondCount —
Compare
AX PLC
Pulse Input | Counter Channel
+
TLTLLr . Counter Output
Counter
Compare * Compare »| Compare Output
Value Setting - i
Output Channel Option
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Compare used in a program

Compare variables can be used for MC function blocks in POU, for example,

DFB_Compare.

On the Hardware 10 Configuration page, select a Compare pin, for example,

Compare 0. The variable Compare_0 will show on the IEC Objects page. Use this

name when the axis is used in POU.

IEC Objects

BuiltIn_IO If0 Mapping

Status

Hardware I0 Configuration

Variable

[ Compare_0 ]

Type Configuration Function

DFE_COMPARE_R.EF Compare 0

Information
DFE_Compare_0
Ture DFE Compare
11 EN - ENO——

HCompare bValid —
—Counter bBuay [~
—bEnable bError [~
—Mode ErrorID—
—OutputAction TableState —
—wRefreshCycle
—diCmpValue
—diTablePogition
—uiTableS5ize

5.10.4.1.4 Builtin 10: PoAxis Configuration

How do | open the PoAxis Configuration page?

1. On the Devices pane, double-click Builtin_lO and go to Hardware 10

Configuration.

2. Select Pulse Output Axis.
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The PoAxis Configuration tab shows below Hardware 10 Configuration.

This section describes the 1/O pulse output function module.

[

After selecting a Pulse Output Axis, you can click L1 to open the Pin Selection

dialog and select the 1/0O terminal number of LSP, LSN, Z Phase, and Home Switch.

Note:

* [f two pins select the same 1/O terminal number, the system
automatically changes the first one to None.

* The I/O terminal number will not show if Counter, Capture, or
Compare occupies it.

* [f you select a Pulse Output Axis, but the pin is already occupied by
Counter or others, the Pin Selection dialog will open automatically to

let you select other pins.

The following tables show the PoAxis settings and description.
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Hardware IO Configuration Rxis 0
Pulse Output Settings e
Potxis Configuration Mode Settings Axis Type and Limits
o Mode | AJB v D Virtual mode
IEC Objects

(@ Finite Linear Axis Software Limits o
Positive Command Negative Command Modulo [ ] Actvated

BuiltIn_IO I/O Mapping Negative [u]: |0
Positive [u]: | 1000
Status
(@) Reverse OFF Rotary Axis Modulo Settings
Infarmation Modulo value [u]: 360

Motion Parameter

Error Reaction
Quick Stop

| Reverse On .
Velodty Ramp Type

(@) Trapezoid () Sin? (O) Quadratic () Quadratic(smooth)
Transmission Mechanism o

Mechanism Type | Ball s . Mechanism Settings

(1) Command pulse per motor rotation: E [ Pulse ]

(4) Pitch: 1 [ Unit ]

@)
Qo =,
1) '
'/// " Gear Box
| (2) Gear ratio numerator 1 E
Gear Ratio =
(3) Gear ratio denominator ‘1 E
(3)

Homing Settings e

Homing Mode Mo¥35 v

Homing speed during search for switch :IUU @ [ Unitfs ]
Homing speed during search for z phase pulse |50 E [ Unitfs ]
Homing Acceleration | 1000 [ Unitfs2 ]

Description

Mode 35 : Depending on the current position

In made 35, The heming instruction is executed, the axis does not move and its current positien is regarded as
the home position.

o Mode Settings

Setting Description

Mode Select the pulse output type.

Reverse OFF / On | Select the forward or reverse command.

9 Axis Type and Limits

Setting Description

Virtual mode Select to start virtual axis.
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Setting

Description

Finite / Modulo

Select to set the axis type.

9 Linear Axis Software Limits

Setting

Description

Activated

Select to start software limit (only supports linear axis).

Negative [u]

Enter reverse software limit. The default value is O.

Positive [u]

Enter forward software limit. The default value is 1000.

0 Rotary Axis Modulo Settings

Setting

Description

Modulo value [u]

Enter a circle range (only supports rotary axis). The default
value is 360.

9 Error Reaction

Setting

Description

Quick Stop

Select to stop the axis in emergency.

Deceleration [u/sz]

Enter the axis decelerating to stop value (only shows when
the Quick Stop checkbox is not selected). The default value
is 1000.

@ Velocity Ramp Type
Setting Description
Trapezoid Select the axis motion curve.
Sin®
Quadratic
Quadratic(smooth)
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o Transmission Mechanism

Setting Description

Mechanism Type Select the mechanism type.

Mechanism Set- Set the parameter value for the selected mechanism. The set-
tings tings differ by type. The default values are 1.

* Command pulse per motor rotation: Shows the num-
ber of pulses required for a motor to rotate for one cycle.

¢ Pitch: Enter the scalable distance the worktable moves
for a unit.

See the following picture for examples.

(4) Pitch value | Worktable movement | Function block The actual
distance base input value distance the
worktable moves
10000 100 cm 10000 100 cm
100 100 cm 100 100 cm
10000 100 cm 1 0.01 cm
100 100 mm 1 1 mm

* Diameter: Enter the diameter of the gear. Diameter*m =
Movement distance per motor rotation

* Movement distance per motor rotation: Enter the dis-
tance the motor moves to rotate for a cycle.

Gear Ratio Select or enter the (2) gear ratio’s numerator (number of teeth
of the worktable) and (3) denominator (number of teeth of the
motor gear) to set the reduction ratio. The default values are
1.

9 Homing Settings

Setting Description

Homing Mode Select the homing mode. The actual homing mode is deter-
mined by the drive.
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Setting

Description

You can click to open the Homing Mode Assistant dia-
log to decide the homing mode based on your selection. The

default value is Mode 35.

Homing speed
during search for
switch

Select or enter the homing switch speed. The default value is
100.

Homing speed dur-
ing search for z
phase pulse

Select or enter the Z-Seek speed. The default value is 50.

Homing Accelera-
tion

Select or enter the acceleration rate of the axis when search-
ing for the velocity change. The default value is 1000.

Pulse Output Axis used in a program

Pulse Output Asix variables can be used for MC function blocks in POU, for

example, MC_Power.

On the Hardware 10 Configuration page, select a Pulse Output pin, for example,

Pulse Output Axis 0. The variable Pulse _Output_Axis_0 will show on the IEC

Objects page. Use this name when the axis is used in POU.

Hardware 10 Configuration

Polxis Configuration

IEC Objects

BuiltIn_IO IO Mapping

Status

Information

Variable Type Ceonfiguration Function

I Pulse_Qutput_Axis_D I DMC_PULSE_AXIS_REF Pulse Qutput Axizs 0
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1 MC_ Power_ 0
Ture MC Power
01 EN B ENO——
Pulse_Cutput Axis_0|-“axis Status —
—(Enable bRegulatorBealState
—bBegulatorOn bDriveStartBeal3tate
—bDriveStart Buay —
Error —
ErrorID —

5.10.4.1.5 DIO: DIO Configuration
How do | open the DIO Configuration page?
* On the Devices pane, under the Builtin_IO node, double-click DIO.

The DIO device sets the 1/0 points of the host to interrupt, filter, and polarity.

The following tables show the DIO settings and description.

Note: The following figure is an example of the AX-308 DIO Configuration
page. The user interface differs for different controllers.
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DIO Configuration Configuration n e e a
Port

DIO If0 Mapping Interrupt Filter (0.01us) Polarity

IND \lﬂl]

status o Lfﬂ_ﬂ N1 100
Information N1 \_f_llﬂ IN2Z \100
N2 Lfllﬂ IN 3 \mu
N3 u—ﬂ_ﬂ IN 4 Fuu
IN5 100

Lim4 U_I_Lﬂ IN & \mu
[Jms Hi%% IN7 \mu
lmes N \mu
[Jmz U_I_Lﬂ NG \mu
[Ims IN 10 \mu
Clms Lufll%% IN 11 \mu
IN 12 [1uu

Lm0 U_I_Lﬂ N 13 100
Cm \_fl—vt_ﬂ IN 14 [100
1z \_f_llﬂ IN 15 llDD
WERE Encoder Al llDD
O g{%% Encoder B1 llDD
Encoder 71 llDD
I:l 1N 15 \—f_llﬂ Encoder AZ [lﬂl]
(] Encoder 21 \_fﬂ_ﬂ EncoderB2 100

] Encoder 22 Lf_llﬂ Encoder 22 \100

(s[e][=Tw]|[<Te][S[e] [aTe][<Tw][<Te][aTe | [aTw][aTe | [a]e | |a]e] [aTe|[<]e ] [aTe ] [aTe ][] [<]e | o] [ [o| [<]e | [a]e] [a]w]|
B
FrExssEEEEEEIEEEEESESS S

551 DATA \IDI]
Mo v ”f;'}|
Setting Description
o Interrupt Select to turn on the external interrupt.

u_SeIect to set the input contact to upper differential signal

after the external interrupt is turned on.

n— Select to set the input contact to the lower differential sig-

nal after the external interrupt is turned on.

Lﬂj Select to set the input contacts to the upper and lower dif-

ferential signals after the external interrupt is turned on.
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Setting Description
9 Shows the contact number.
Port
e Eiltor Select or enter the IN filter time. The value range is 0—
30,000,000.
9 Polarity Click to set the input contact polarity to A contact.
CIick to set the input contact polarity to B contact.

AX-864EP1ME1TP DIO Configuration

DIO Configuration Configuration a Q

DIO Parameters Interrupt DI Function DO Type (Select for all)

DIO /O Mapping Cn l_f_ﬂ_lﬂl 10 |Generallnput  ~ Q0 NEN .
T Q1 NP .
Information

Setting Description

e Bl Eunction Select the Ix to work as a general input contact or special

software function.

@ DO Type (Select Select the polarity type for the output contact. Selecting

for all) an option for one output contact synchronize the other

output contacts to the same option.

I/0 Interrupt used in a task
1. On the DIO page, turn on the interrupt function.
2. On the Devices pane, double-click the task that needs to set up interrupt.
3. On the Task page, select External for Type.
4. Select an interrupt for External event.

The IN input hardware filter time is less than the IN input Duty On duration, as shown
in the following:
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1. Hardware filter input range is 1-50000000, and the unit is 0.1us.

IN input Duty on duration

£{IN input hardware filter time)

2. The relationship between filter frequency and time is:
Filter frequency x 2 (Hz): Filter frequency = 1/(2xt); t is the filter time (unit 0.01 us).

When the input frequency is higher than the filter frequency range, the signal will be
filtered.

This function is for the IN input points such as DFB_Capture, DFB_Hcnt, DFB_HTmr,
DFB_Compare, and the body I/O interrupt.

5.10.4.1.6 High-speed I/O Settings (AX-8)
This section describes the High-speed 1/O settings of the AX-8 series controller.
5.10.4.1.6.1 Builtin_DIO
How do | open the Builtin DIO page?
* On the Devices pane, double-click Builtin_DIO.

The following tables show the Parameter settings and description.

Setting Description

DI Filter Select Select the input filter time for X0 to X7.

X0 Function Type | Select X0 as a general output or special software function.
Choose

DO Output Inverse | Set the output reserve value for YO to Y7.
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Note: The value should be selected offline. After downloading, the field
shows Run.

Stop/Start PLC Control Timing diagram
* When X0 is Low, Application — Reset — Run

* When X0 is High, Application Stop

A

High

X0 Status  Low

Run . ' p—

Application  stop ’ >

Reset

5.10.4.1.6.2 Builtin Pulse Encoder (AX-8xxEPO0 series only)
How do | open the Builtin Pulse Encoder page?
* On the Devices pane, double-click Builtin Pulse Encoder.

The following table shows the Builtin Pulse Encoder Parameters settings and
descriptions.

Setting Description

Pulse Encoder in- | Select the input type.
put type

Pulse Encoder in- | Select the input direction.
put direction

Pulse Encoder Z Select the Pulse Encoder Z direction.

Inverse

Pulse Encoder Fil- | Enter the pulse encoder filter level.
ter Level
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Note: The value should be selected offline. After downloading, the field

shows Run.

On the Builtln Pulse Encoder page, go to Builtin_Pulse_Encoder I/O Mapping to

set the counter and reset mappings.

Reset Timing diagram

6000

4000
Counter

Reset High

v
i :
1 1 one Cyclic
el

Low

10000

Position

4000

5.11 Motion Control Device

Motion control equipment is mainly used to set axis parameters for most

applications. DIADesigner-AX provides a user-friendly editing environment where

you can view an |IEC object in IEC Objects and its axis parameters related to motion

control in Library Manager.

In a motion control system, the object of motion control is called an axis which has

different forms, including physical servo drives, encoders and virtual servo drives.

The following table lists all axis types.
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Type

Description

Synchronous axis

Perform servo and synchronous motion control such as elec-
tronic cams through EtherCAT communication.

Note: Synchronous axis needs to be used with the
DL_MotionControl and SM3_Basic library.

Positioning axis

Perform basic positioning control, such as absolute and rela-
tive positioning through EtherCAT communication.

Note: Positioning axis needs to be used with the DL_-
MotionControl library.

Velocity axis

Perform velocity control and torque control.

Pulse type servo
axis

Perform physical servo control through pulse.

Virtual axis

Only used in the program to run motion control commands
without physical servo motors.

Encoder axis

Use physical encoder (SSI encoder or incremental encoder)
as the signal source.

Virtual encoder ax-
is

Only used in the program without physical encoders.

5.11.1 Add a Synchronous Axis

Supported slave device:

* ASDA-A2-E, ASDA-A3-E, ASDA-A3-EP, ASDA-B3-E, ASDA-W3-E, ASDA-E3-
E, ASDA-E3C-E, ASDA-H3-E

* R1-EC5621

The multi-axis servo system ASDA-W3 supports adding up to 12 axes.

Use the following steps to add a synchronous axis.

DIADesigner-AX Version 1.8.0

134



A AELTA Chapter 5: Hardware Configuration

To add a synchronous axis
1. On the Devices pane, right-click EtherCAT_X and then select Add Device.

2. In the Add Device dialog, select Fieldbus > EtherCAT > Slave > Delta
Electronics, Inc. and then select a slave.

When the servo is added to the project, the system automatically generates its servo
axis (you can rename it).

Devices > 0 X
=5 Untitled1 -
=[] controller_1 (AX-308EAIMALT)
@ Hardware Configuration
= A Network Configuration
A, EtherCAT Topology
A, EtherNetlP Topology
A, ModbusTCP Topology
=B pPLC Logic
=1 Application
m Library Manager
Motion_PRG (PRG)
PLC_PRG (PRG)
= @ Task Configuration
= \% EMIPScannerIOTask (IEC-Tasks)
@ EtherMet_IP_Scanner_1.10Cycde
@ EMIPScannerServiceTask (IEC-Tasks)
@ EtherMet_IP_Scanner_1.ServiceCyde
=% EtherCAT Task (IEC-Tasks)
&

] Motion_PRG
MainTask (I[EC-Tasks)
8 pLc_PRG
= [{ Builtin_10 (Builtin_10)
[ oo (o)

m Delta_LocalBus_Master_1 (Delta LocalBus Master)
= m EtherCAT_1 (AX Series EtherCAT Master SoftMotion)

= m Drive_1 (Delta ASDA-A2-E EtherCAT(CoE) Drive 5M)

Hs SM_Fiive_EI'C_Delm_ASDA_AZ_l (SM_Drive_ETC_Delta_ASD...

= m Ethernet_1(E Fret)
SM_Drive_ETC_Delta_ASDA_A2_1 (SM_Drive_ETC_Delta_4

[0 Ethernet_|
'& SoftMation General Axis Pool

If select Delta ASDA-W3-E EtherCAT (CoE) Drive, after adding to the project, you
need to right-click it to add its SM axis.

When using the motion function block, if you need to use the corresponding axis,
enter the name of the axis as the variable to the Axis parameter, for example,
SM_Drive_ETC_Delta_ ASDA_A2 in the Axis parameter.

HMC.Fawsr.0
MC Power
SM Drive ETC Delta ASDA A2 —Hpxis Status ——
—Enable bRegulatorRealState [—
—|bDrivesStart bDriveStartBealState —
Busy [~
Error —
ErrorID [~
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After creating a servo axis or virtual axis, you can configure the corresponding axis
parameters. The following tables list the axis parameters and descriptions.

General

#9 SM_Drive_ETC_Delta_ASDA_A3_1 X

General Setting

Commissioning

IEC Objects

[] Enable Mapping Pago

Axis Type and Limi

Positive [u]: | 1000

@

Motion Parameter

Motor Setting [ virtual mode Velocity Ramp Type Error Reaction

1 (@ Finite Linear Axis Software Limne @ Trapezoid Quick Stop,
Homing Setting () Modulo  [] Activated Q sinz

1 Negative [u]: |0 Q Quadratic e
SM_Drive_ETC_Delta_ASDA_A3: () Quadratic(smooth)

Dynamic Limits|
Velocity [u/s]: cceleration [ufs?]:  Deceleration [u/s2]:  Jerk [u/s?]:

Status Rotary Axis Modulo Settings =
. Modulo value [u]: |360 5 [100 :1‘797E+305 10000
Information
L Position Lag Supervision
Position Lag Reaction | Deactivated Lag Limit [u]: 1
Transmission Mechanism
Mechanism Type | Ball Screw 9 Mechanism Settings
(4) (1) Command pulse per motor rotation: | 16777216 [ Pulse ]
(4) Pitch: | 10000 [ Unit]
@ o <=,

1 f

@ 5 Z7A
Gear Box

— (2) Gear ratio numerator [l @
Gear Ratio =
(3) (3) Gear ratio denominator [1
Positive Command Negative Command
@ cow aw
O Reverse On @9 @9
o cow
.
0 Enable Mapping Page
Setting Description

Enable Mapping Select to show the Scaling/Mapping tab.

Page

9 Axis Type and Limits

Setting Description

Virtual mode

Select to turn on the virtual mode.
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Setting

Description

The drive is replaced by a simulation similar to a virtual drive
unit. When there is a coupled drive, this does not have any ef-
fect on the fieldbus device.

Finite

Select to set the axis type as a linear axis.

The drive has a fixed work area.

Modulo

Select to set the axis type as modulo.

The drive turns endlessly without limiting the traversing range.

e Linear Axis Software Limits

Setting

Description

Activated

Select to turn on the software limit (only supports linear axis).
Position values are restricted by the lower limit Negative and
the upper limit Positive.

Negative [u]

Enter reverse software limit.

Positive [u]

Enter forward software limit.

oRotary Axis Modulo Settings

Setting

Description

Modulo value [u]

Enter one circle range. This function is only available when
selecting Modulo as the axis type. The default value is 360.

eError Reaction
Setting Description
Quick Stop Select to stop the axis in emergency.

Deceleration [u/sz]

Enter the axis decelerating to stop value (only shows when
the Quick Stop checkbox is cleared).
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eVeIocity Ramp type
Setting Description
Trapezoid Select the axis motion curve.
Sin®
Quadratic
Quadratic (smooth)

o Dynamic Limits (Only for AX-8 series)

Setting Description

Velocity [u/s] Enter the dynamic limit of velocity, acceleration, deceleration,
_ 2. |and jerk.

Acceleration [u/s”]

Deceleration [u/sz]

Jerk [u/s’]

@ Position Lag Supervision

Setting Description

Position Lag Reac- | Select the behavior of the axis after overflow.
tion

Lag Limit [u] Enter the overflow value.

eTransmission Mechanism

Setting Description

Mechanism Type Select the mechanism type.

Mechanism Set- Set the parameter value for the selected mechanism. The set-

tings tings differ by type.

DIADesigner-AX Version 1.8.0 [EE



A NELTA

Chapter 5: Hardware Configuration

Setting

Description

Command pulse per motor rotation: Shows the num-
ber of pulses required for a motor to rotate for one cycle.

Pitch: Enter the scalable distance the worktable moves
for a unit.

See the following picture for examples.

(4) Pitch value | Worktable movement | Function block The actual
distance base input value distance the
worktable moves
10000 100 cm 10000 100 cm
100 100 cm 100 100 cm
10000 100 cm 1 0.01 cm
100 100 mm 1 1 mm

Diameter: Enter the diameter of the gear. Diameter*m =
Movement distance per motor rotation

Movement distance per motor rotation: Enter the dis-
tance the motor moves to rotate for a cycle.

Command pulse: Shows the number of pulses needed
to move 1 mm, nm, or um of the worktable. The unit is
selected in (4).

This setting is only available when selecting Linear Mo-
tor in the Motor Setting tab.

Movement distance: Enter the scalable distance the
worktable moves for 1 mm, nm, or um. If no specific re-
quirements exist, set the value to 1.

This setting is only available when selecting Linear Mo-
tor in the Motor Setting tab.
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Setting Description
See the following picture for examples.
(4) Movement | Worktable movement Function The actual
distance value distance base (only block input distance the
related to the unit value worktable moves
selected in (4))
1nm 1nm 1 1 nm
1um 1um 1 1um
1 mm 1 mm 1 1 mm
2nm 1nm 1 0.5nm
2um 1um 1 0.5um
2mm 1 mm 1 0.5 mm
2 nm 1nm 2 1nm
2 nm 1 nm 4 2nm
Gear Ratio Select or enter the (2) gear ratio’s numerator (number of teeth
of the worktable) and (3) denominator (number of teeth of the
motor gear) to set the reduction ratio. Not available for Linear
Motor.
Servo Gear Ratio | Enter Unit numerator (P1-44) and Unit denominator
Settings (P1-45) to get the value of (1).

@PositivelNegative Command

Name

Description

Reverse OFF/Re-

verse On

Select the forward or reverse command.

Scaling/Mapping
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- —
General Setting Ppng ) .
Automatic mapping
Scaling/Mapping Inputs:
Cydic object Object number Address Type
Commissioning status word (in.wStatusWord)  16%6041:16%00  '%IW212  'UINT
| . . actual position (diActPosition) 16%6064:16%00 '%ID107' ‘DINT'
HomngSsting actual velodity (diActvelodity)  16#606C:16500 " "
| SM Drive ETC Delta ASDA A2: actual torque (wActTorque) 16#6077:16+%00
IEC Objects Modes of operation display (OP) 16#6061:16%00
I digital inputs (in.dwDigitallnputs) 16#60FD: 16300
Status
Touch Probe Status 16+6089:16+00
. Touch Probe 1rising edge 16%60BA: 16200
Information
Touch Probe 1 falling edge 16#608B: 16200
Touch Probe 2 rising edge 16#60BC: 16200
Touch Probe 2 falling edge 16#60BD: 1600
Following error (A632) 16#60F4:16200 "
Outputs:
Cydlic object Object number Address Type

ControlWord (out.wControlWord) 16%6040:16%00 '%QW214  'UINT'

set position (diSetPosition) 16#607A:16%00  '%QD108" ‘DINT'
set velodty (diSetVelocity) 16%60FF: 16200 " "
set torque (wSetTorque) 16%6071:16=00 " "
Modes of operation (OP) 16%6060: 16200 " "
Touch Probe Function 16#6088:16%00 " "
Add velodity value 16#60B1:16%00 " "
Add torque value 16%6082:16=00 " "
Digital outputs (A637) 16%60FE: 16201 " "
< >
Setting Description

Automatic mapping | Select to automatically map the IEC parameters that affect
the drive to the corresponding inputs and outputs of the de-
vice.

Commissioning

DIADesigner-AX Version 1.8.0 S



A NELTA

Chapter 5: Hardware Configuration

Online
General Setting

Power

||
Inch

&

variable set value actual value Status: |SMC_AXIS_!>‘I’ATE.pnwer_an |
Scaling/Mapping ] 01 L) Cummunicatiun1imtalizatun of base communication (10) |
Velocity [u/s] 0.00 0.00
Commissioning Acceleration [u/s] 0.00 0.00 Errors
Torque [Nm] 0.00 poo | | Axis Eror
Homing Setting ‘U [16+00000000] |
. FB Error:
SM3_Drive_ETC_Delta_ASDA_W3: ‘SMC ERROR.SMC NO ERROR |
IEC Objects = -
uiDriveInterfaceErrar:
Status ‘U |
strDrivelnterfaceError:
Information |
Power Error reset Homing

@000 00

Distance:

Velocity:

Acceleration:

~ | Deceleration:

Jerk:

Reset Start

Read&Write

Value:

Prepared Value: I:I 7

This tab is used for testing purposes when commissioning physical drives. It is
available only if Online Config Mode is turned on. In this mode, the development
system is connected to the device; however, an application does not have to be

downloaded.

Motor Setting (Only available for the ASDA-A3 and A3-EP series)

44 SM_Drive_ETC_Delta_ASDA_A3_1 X

General Setting Motor Settings
Commissioning Motor selection Linear Motor -
Motor Setting
Encoder Settings
Homing Setting Linear encoder connected ® Yes No
SM_Drive_ETC_Delta_ASDA_A3: Encod luti [ ipulse ]
IEC Objects ncoder resolution 1 nm/pulse
Status
Information
Setting Description
Motor Settings

Motor selection

Select the motor type based on the actual topology.
The selection will change Transmission Mechanism

settings in the General Setting tab.
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Setting Description

Encoder Settings

Only available when Motor selection is Linear Motor.

Linear encoder connected | Select whether to connect the encoder to the axis. For
linear motors, the encoder is connected by default.
Other motor types will be supported in the future.

Encoder resolution Enter the optical encoder resolution. The value range
is 1—200,000,000.

Homing Setting

General Setting Homing Mode | Mode 35 ¥

Scaling/Mapping Homing speed during search for switch | 100 [0.1rpm]

Homing spead during search for z phase pulse |ZU E [01mpm]
Commissioning .

Homing Acceleration |100 E [ms]
Homing Setting Description

SM_Drive_ETC_Delta_ASDA_A3: Mode 35 : Depending on the current position

IEC Objects

i In mode 35. The homing instruction is executed, the axis does not move and its current position is regarded as

) the home position.
Information

Setting Description

Homing Mode Select the homing mode. The actual homing mode is deter-
mined by the drive.

You can click to open the Homing Mode Assistant dia-
log to decide the homing mode based on your selection.

Homing speed Select or enter the homing switch speed. The unit of this set-
during search for ting for A3 and A3-EP linear motor is uym/s.
switch

Homing speed dur- | Select or enter the Z-Seek speed. The unit of this setting for
ing search for z A3 and A3-EP linear motor is ym/s.
phase pulse
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Setting Description

tion ing for the velocity change.

Homing Accelera- | Select or enter the acceleration rate of the axis when search-

Note: The unit of homing settings for ASDA-W3 is user unit/s.

IEC Objects

General Setting gk Add.. [ Edit... Delete Go to Variable

Variable Mapping Type
Scaling/Mapping

Commissioning

Homing Setting

SM3_Drive_ETC_Delta_ASDA_W3:
IEC Objects

Status

Information

& 5M3_Drive_ETC_Delta... @ AXIS_REF_ETC_DS402_CS

Lists the "objects" that access the device from the IEC application. In the online

mode, this is used as the monitoring view.

Status
SensreliSetting I SM_Drive_Logical: : |n/a
Scaling/Mapping
SM_Drive_ETC_Delta_ASDA_A3: [/a

Commissioning

Homing Setting

SM_Drive_ETC_Delta_ASDA_A3:
IEC Objects

Status

Information

Shows the status of the drive.

Information

DIADesigner-AX Version 1.8.0

144



A AELTA Chapter 5: Hardware Configuration

General Setting General

Names: SM3_Drive_ETC_Delta_ASDA_W3

Scaling/Mapping Vendor: Delta Electronics, Inc.
Categories: EtherCAT drives
Commissioning Type: 1027
ID: 16f7 0030
Homing Setting Version: 1.0.0.0
Order number: 0
5M3_Drive ETC_Delta_ASDA_W3: Description: SoftMotion axis for Delta ASDA W3 drives

IEC Objedts

Status

Information

The general information of the drive.

5.11.1.2 CoE Parameters

CoE parameter configuration applies to the following devices.
* ASDA-A3-E, A3-EP
* ASDA-B3-E
* ASDA-E3-E
* ASDA-W3-EAS-RTU

* AX-5 EtherCat Remote I/O modules

These devices also support device update. For more information about how to
update the device, see Update Devices.

How do | open the CoE configuration page?

1. Add a supported device.

2. Double-click the device, and then click CoE Parameters.
All Parameters and Favorites

All the CoE parameters are listed in All Parameters category, and you can right-
click them to add to Favorites category. You can only edit the parameter when the

F

module is online. Click to expand All Parameters and then select a device, only

the parameter of this device shows.
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The following table lists the settings of All Parameters category and their

descriptions.

Setting Description

= Click to upload the selected parameters to the software.

2, Click to upload all parameters to the software. You need to
click this button when you first connect to the device so that
the parameters in the device can be updated to the CoE para-
meter editor.

= . Click to download the selected parameters to the device.

2, Click to download all parameters to the device.

= Click to synchronize the value of the selected parameter to
the corresponding ones in Startup Parameters.

& Click to synchronize all the parameters to the corresponding
ones in Startup Parameters.

O Click to compare the values.

Provides results where Value does not match Current Value.

The following table lists the options that you can select when you right-click the

parameter and their descriptions.

Setting

Description

Add to Favorites

Click to add the selected parameter to Favorites category.

Add to Startup Pa-
rameters

Click to add the selected parameter to Startup Parameters
category.

Import

Click to import parameters from an .xml file.

Export

Click to export parameters to an .xml file.

Startup Parameters
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The parameter listed under this category writes the value to the module after the
module is started. You can edit the parameter when the device is not connected.

The following table lists the settings to manage startup parameters and descriptions.

Setting Description
% Click to delete the parameter.
o Click to move up the parameter.
v Click to move down the parameter.

5.11.1.2.1 Change the CoE Parameter Value Display Mode

DIADesigner-AX supports changing the format of the CoE parameter values when
monitoring in the online mode. You can change the value format to:

* Binary
* Decimal

* Hexadecimal

Prerequisites

* The project is in the online mode.
To change the display mode of the CoE parameter value
1. On the menu bar, select Project > Project Settings > Monitoring.

2. On the Monitoring pane, under Display Mode for Integer Variables, select
one of the display modes.

3. Click OK.
Or
1. On the menu bar, select Debug > Display Mode.

2. Select one of the display modes.
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5.11.2 Add a Positioning Axis

A positioning axis provides the basic positioning control functions through EtherCAT
communication, for example, the absolute positioning and relative positioning. The
positioning axis needs to be matched with the DL_MotionControlLight library.

To add a positioning axis
1. On the Devices pane, right-click EtherCAT_X, and then select Add Device.

2. Inthe Add Device dialog, select Fieldbuses > EtherCAT > Slave > Delta
Electronics, Inc., and then select one of the following devices.

o C2000Plus

° CH2000

o ASDA-A2-E DML
° ASDA-A3-E DML
o ASDA-B3-E DML
o ASDA-E3-E DML

° ASDA-W3-E DML

After adding ASDA-Wa3 to the project, you need to right-click it to add its
positioning axis.

The multi-axis servo system ASDA-W3 supports adding up to 12 axes.

3. Click Add Device.

5.11.2.1 Positioning Axis Settings

After adding a positioning axis, you can configure the axis parameters. The following
tables list the axis parameters and descriptions. Settings may vary slightly depending
on the device. For more information about the supported functions of each device,
see the respective device manuals.

General Setting
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General Setting focis Type and Limits Motion Parameter
® Finite Linear Ais Software Limil Velocity Ramp Type

Homing Setting ) Modulo  [] Ativated
Negative [u]: 0

Trapezoid v
DML_Drive_ETC_Delta ASDA_B3:
IEC Objects Positive [u]: | 1000

Status Rotary Axis Modulo Settings 0
Modula value [u]: |360
Information
Transmission Mechanism Q

Mechanism Type | Ball Screw v Mechanism Settings
(1) Command pulse per motor rotation: | 16777216 [ Pulse ]
‘2} ) (4) Fitch: | 10000 [ Unit]

~
17/

Wy

Gear Box

(2) Gear ratio numerator 1 E
Gear Ratio =

(3) Gear ratio denominator 1 E
b)) '

Servo Gear Ratio Settings

0 Positive Command Megative Command
(®) Reverse OFF

BB
-6 ®

oAxis Type and Limits

Setting Description

Finite Select to set the axis as a linear axis.

The drive has a fixed work area.

Modulo Select to set the axis type as modulo.

The drive turns endlessly without limiting the traversing range.

eLinear Axis Software Limits
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Setting

Description

Negative [u]

Enter reverse software limit.

Positive [u]

Enter forward software limit.

Activated

Select to turn on the software limit (only supports linear axis).
Position values are restricted by the lower limit Negative and
the upper limit Positive.

eRotary Axis Modulo Settings

Setting

Description

Modulo value [u]

Enter one circle range. This function is only available when
selecting Modulo as the axis type. The default value is 360.

°Velocity Ramp Type
Setting Description
Trapezoid Select a trapezoidal velocity profile (with constant accelera-

tion in each segment).

S-curve

Select the S-curve as the velocity ramp type. If select this
type, set the acceleration range and deceleration range.

9 Transmission Mechanism

Setting

Description

Mechanism Type

Select the mechanism type.

Mechanism Set-
tings

Set the parameter value for the selected mechanism. The set-
tings differ by type.

* Command pulse per motor rotation: Shows the num-
ber of pulses required for a motor to rotate for one cycle.

* Pitch: Enter the scalable distance the worktable moves
for a unit.
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Setting Description
See the following picture for examples.
(4) Pitch value | Worktable movement | Function block The actual
distance base input value distance the
worktable moves

10000 100 cm 10000 100 cm
100 100 cm 100 100 cm

10000 100 cm 1 0.01 cm
100 100 mm 1 1 mm

* Diameter: Enter the diameter of the gear. Diameter*r =
Movement distance per motor rotation

* Movement distance per motor rotation: Enter the dis-
tance the motor moves to rotate for a cycle.

Gear Ratio Select or enter the (2) gear ratio’s numerator (number of teeth
of the worktable) and (3) denominator (number of teeth of the
motor gear) to set the reduction ratio.

Servo Gear Ratio | Enter Unit numerator (P1-44) and Unit denominator

Settings (P1-45) to get the value of (1).
ePositivelNegative
Setting Description

Reverse OFF/Re- | Select the forward or reverse command.
verse On

Homing Setting

General Seting Homing Mode | Mode 35 ¥

Homing Setting Homing speed during search for switch | 100 [0.1rpm]

OML_ Drive_£TC Delta_ASDA_A3: Homing speed during search for z phase pulse |ZU B [01mpm]
IEC Objects Homing Acceleration 100 E [ms]

Status Description

Mode 35 : Depending on the current position

Information

In mode 35, The homing instruction is executed, the axis does not move and its current pasition is regarded as

the home position.
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Setting Description

Homing Mode Select the homing mode. The actual homing mode is de-
termined by the drive.

You can click to open the Homing Mode Assistant
dialog to decide the homing mode based on your selec-

tion.

Homing speed during | Select or enter the homing switch speed.
search for switch

Homing speed dur- Select or enter the Z-Seek speed.
ing search for z phase
pulse

Homing Acceleration Select or enter the acceleration of the axis when search-

ing for the velocity change.

Note: The unit of homing settings for ASDA-W3 is user unit/s.

Parameters
General Setting Parameter Type Value Default Value Unit  Description
) =+ AXIS_REF: Standard
Homing Setting § dwRatiaTechUnitsDenom DWORD 1048578 16777216 conversion inc. ftech,units denominator
DML_Drive_ETC_Delta_ASDA_A3: # iRatioTechUnitsNum DINT 625 10000 conversion inc. /tech. units numerator
Parameters # MovementType INT 1 1 movement type: 0: modulo, 1: finite
DML_Drive_ETC_Delta_ASDA_A3: @ fPositionPeriod LREAL 360.0 360.0 modulo value for modulo drives
R @ blnvertHomeOffset BOOL TRUE TRUE Whether the home offsetis inverted when writing it to or reaj
Status @ fConstVelFactor LREAL 1 1 A constant factor applied to the conversion from velodtiesin
@ fConstAccFactor LREAL 1 1 A constant factor applied to the conversion from acceleration)
Information @ bSWLimitEnable BOOL FALSE FALSE Activate /deactivate software imits
@ fSWLimitNegative LREAL 0.0 0.0 Software limit in negative direction
@ fEUiLimitPositive LREAL 1000.0 1000.0 Software limit in positive direction
=~ 1 logical device settings
@ logical device number USINT 0 0
=+ 1 possible cydiic driver in-foutputs

Shows the device-specific parameters.

To show this tab, on the menu bar, select Tools > Options > Device editor > Show
generic device configuration views.

IEC Objects
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& Edit... Delete Go to Variable

General Setting gr Add...
Warnable

Homing Setting

DML_Drive_ETC_Delta_aSDA_A3:

IEC Objects

Status

Information

Mapping  Type

4 DML_Drive_ETC_Delta... @ AXIS_REF_ETC_Delta_ASDA_A3_DML

Lists the "objects" that access the device from the IEC application. In the online

mode, this is used as the monitoring view.

Status

General Setting

Homing Setting

DML_Drive_ETC_Delta_ASDA_A3:
IEC Objects

Status

Information

DML_Drive_ETC_Delta_ASDA_A3: nfa

Shows the status of the drive.

Information

General Setting General

Haoming Setting

DML_Drive_ETC_Delta_ASDA_A3:
IEC Objects

Status

Information

Name: DML_Drive_ETC_Delts_ASDA_A3
Vendor: Delta Electronics, Inc.

Categories: SoftMotion Light EtherCAT drives
Type: 1185

IDe 16F7 0002

Version: 1.3.2.0

Order number: 0

Description: DML axis for Delta ASDA A3

Shows the general information of the drive.

5.11.2.2 Axis Reference (Axis_REF_DML)

The following table lists the control type of the axis and their instructions.
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Category

Functions

Description

Single-axis
motion control
instructions

Positioning control

Velocity control

Torque control

Synchronous control

Administrative

MC_": Motion control instructions based on
PLCopen

"DMC_": Delta’s motion control instructions
"SMC_": Motion instructions

"MC_XXX_DML": Delta’s motion control in-
structions for positioning axis

Multi-axis mo-
tion control in-
structions

Axis group move-
ment

Multi-axis movement

Multi-axis manage-
ment

Multi-axis setting, monitoring, and reset

5.11.3 Add a Velocity Axis

The velocity axis provides the velocity control and torque control. The velocity axis

needs to be matched with the DL_MotionControlLight library.

To add a velocity axis

1. On the Devices pane, right-click EtherCAT_X, and then select Add Device.

2. Inthe Add Device dialog, select Fieldbus > EtherCAT > Slave > Delta
Electronics, Inc. > AC Motor Drives > Delta Softmotion Light — Velocity

Axis and then select one of the following devices.

° C2000Plus

° CH2000

° MH300

° MS300

° MX300-E

3. Click Add Device.
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4. (For MX300) Right-click the <Empty> node and then select Plug Device.

Note: The node position you select to plug the device should match
the Absolute Axis Number you set for the axis using the keypad on the
MX300 hardware device. For example, if the Absolute Axis Number
you set is 10 (parameter 09-57=10), you must plug the device into the
10th<Empty> node. To find the Absolute Axis Number, you can go
online, select Scan for Devices, and then check the Absolute Axis
Number from the scanned INV axis.

5. In the Plug Device dialog, select MX300 Frequency Converter-Axis-VL-DML
and then click Plug Device.

5.11.3.1 Velocity Axis Settings

After adding a velocity axis, you can configure the axis parameters. The following
tables list the axis parameters and descriptions. Settings might vary slightly
depending on the device. For more information about the supported function of each
device, see the respective device manuals.

General Setting
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General Setting Axis Type and Limits Motion Parameter o
o ® Finite ~ Linear Ais Software Limite Velodity Ramp Type v

MotorSettings (O Modulo  [] Activated t

S-curve "
Negative [u]: |0 T —
Homing Settin . /1 [N
g seting Positive [ul: | 1000 A:fccBegin [s] 0.2 s LN L
T ™) I T
DML_Drive_ETC_Delta_C2000_FPl " " Acc A X A ! i
: IEC_(];_I]':e:t_s . Delta_ _Plus Rotary Axis Mo_dl:l\o ??t_tmo BiAcc.Amival[s] 0.2 X E : | i ! E
Modulo value [u]: 360 C:Dec.Begin[s] 0.2 ! oy | !
Status ) ' ﬁl B i !
DDecAmvalls] 0.2 TN }5 o,
Information ’
Transmission Mechanism
Mechanism Type | Ball Screw v Mechanism Settings
(1) Command pulse per motor rotation: |4 [ Pulse ]
(4) Pitch: |1 [ Unit ]
Gear Box

(2) Gear ratio numerator 1 B

Gear Ratio =
(3) Gear ratio denominator |1 EI
Positive Command Negative Command
(@ Reverse OFF g Q@a
cow cw
) Reverse On Q 9 @g
cw cow
OAxis Type and Limits
Setting Description
Finite Select to set the axis as a linear axis.
The drive has a fixed work area.
Modulo Select to set the axis type as modulo.
The drive turns endlessly without limiting the traversing range.

eLinear Axis Software Limits

Setting Description

Negative [u] Enter reverse software limit.
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Setting Description
Positive [u] Enter forward software limit.
Activated Select to turn on the software limit (only supports linear axis).

Position values are restricted by the lower limit Negative and
the upper limit Positive.

eRotary Axis Modulo Settings

Setting

Description

Modulo value [u]

Enter one circle range. This function is only available when
selecting Modulo as the axis type. The default value is 360.

°Velocity Ramp Type
Setting Description
Trapezoid Select a trapezoidal velocity profile (with constant accelera-

tion in each segment).

S-curve

Select the S-curve velocity profile. If selecting this type, set
the acceleration range and deceleration range.

eTransmission Mechanism

Setting

Description

Mechanism Type

Select the mechanism type.

Mechanism Set-
tings

Set the parameter value for the selected mechanism. The set-
tings differ by the mechanism type.

* Command pulse per motor rotation: The value can
only be edited in Motor Settings > Encoder Pulse Per
Revolution. It is four times the value set in Encoder
Pulse Per Revolution. MX300-E does not support
editing this value.
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Setting Description
* Pitch: Enter the scalable distance the worktable moves
for a unit.
See the following picture for examples.
(4) Pitch value | Worktable movement | Function block The actual
distance base input value distance the
worktable moves
10000 100 cm 10000 100 cm
100 100 cm 100 100 cm
10000 100 cm 1 0.01 cm
100 100 mm 1 1 mm
* Diameter: Enter the diameter of the gear. Diameter*m =
Movement distance per motor rotation
* Movement distance per motor rotation: Enter the dis-
tance the motor moves to rotate for a cycle.
Gear Ratio Select or enter the gear ratio’s numerator and denominator.

ePositive/Negative Command

Setting

Description

verse On

Reverse OFF/Re-

Select the forward or reverse command.

Motor Settings
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General Setting

MotorSettings

Homing Setting

DML_Drive ETC_Delta_C2000_Plus
: IEC Objects

Status

Information

Motor Settings

Motor Selection

Pole Number

Maximum Operation Frequency

Motor Rated Frequency

Rated Current

Rated Power

Rated Voltage

Rated Spead

Encoder Settings

Encoder Connected

Encoder Type Selection

Encoder Input Type Setting

Encoder Pulses Per Revolution

60.00

60.00

4.50

0.75

200.0

1705

® Yes

MNone

MNone

[Hz]

[Hz]

[Aa]

[kw ]

(vl

[ RPM ]

MNo

[ppr]

Set the parameters of the existing motor and encoder for Delta drives.

Note: MX300-E does not support the encoder.

Homing Setting

General Setting

Homing Mode | Mode 35

Homing speed during search for switch | 100 E

3l

MotorSettings
Homing speed during search for z phase pulse |20 E
Homing Setting . .
Homing Acceleration | 100 E
DML_Drive_ETC_Delta_C2000_PI
:IEC_Obr;iect_s - Descrpton
Mode 35 : Depending on the current position
Status
e In mode 35, The homing instruction is executed, the axis does not move and its current position is regarded as
the home position.
Setting Description
Homing Mode Select the homing mode. The actual homing mode is deter-
mined by the drive.
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Setting

Description

You can click

to open the Homing Mode Assistant dia-

log to decide the homing mode based on your selection.

Homing speed
during search for
switch

Select or enter the homing switch speed.

Homing speed dur-
ing search for z
phase pulse

Select or enter the Z-Seek speed.

Homing Accelera-
tion

the velocity change.

Select or enter the acceleration of the axis when searching for

Note: Only C2000PIlus and CH2000 support Homing Setting.

Parameters

General Setting
MotorSettings

Homing Setting

DML_Drive_ETC_Delta_C2000_Plus
_VL: Parameters

DML_Drive_ETC_Delta_C2000_Plus
_VL: [EC Objects

Status

Information

Parameter

=--[ AXIS_REF: Standard

# dwRatioTechUnitsDenom
# iRatioTechUnitsNum

# MovementType

# fPositionPeriod

# binvertHomeOffset

# fConstvelFactor

# fConstAccFactor

= AXIS_REF: Scalings

 ScalingMotorTurns1
# ScalingMotorTurns2
# ScalingGearOutput1
# ScalingGearOutput2

Type

DWORD
DINT
INT
LREAL
BOOL
LREAL
LREAL

DINT
DINT

Value

360.0
TRUE

Default Value  Unit

360.0
TRUE

Description

conversion inc./tech.units denominator
conversion inc. /tech.units numerator
movement type: 0: modulo, 1: finite
modulo value for modulo drives
Whether the home offset is inverted whi
A constant factor applied to the converg
A constant factor applied to the converg

Shows the device-specific parameters.

To show this tab, on the menu bar, select Tools > Options > Device editor > Show

generic device configuration views.

IEC Objects
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General Setting ok Add.. [ Edit... Delete Go to Variable
Variable Mappin Type
MotorSettings pping ¥P
% DML_Drive_ETC_Delta... @ AXIS_REF_ETC_Delta_C2000_Plus_DML

Homing Setting

DML_Drive ETC_Delta_C2000_Plus
: IEC Objects

Status

Information

Lists the "objects" that access the device from the IEC application. In the online

mode, this is used as the monitoring view.

Status

General Setting

MotorSettings

Homing Setting

DML_Drive_ETC_Delta_C2000_Flus
: IEC Objects

Status

Information

DML_Drive_ETC_Delta_C2000_Plus: |nfa

Shows the status of the drive.

Information

General Setting

MotorSettings

Homing Setting

DML_Drive_ETC_Delta_C2000_Plus
: IEC Objects

Status

Information

General

Mame: DML_Drive_FETC_Delta_C2000_Flus
Vendor: Delta Electronics, Inc.

Categories: SoftMotion Light EtherCAT drives
Type: 1155

ID: 16F7 0021

Version: 1.3.0.0

Order number: 0

Description: DML axis for Delta C2000 Plus

Shows the general information of the drive.
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5.11.4 Add a Virtual Drive

A virtual drive is an analog drive in the software to test programs or implement
extended functions, for example, the axis motion control and the cam driver control.
The virtual drive is not connected to any physical servo and is only used in the

program to run motion control commands.

To add a virtual drive

1. On the Devices pane, right-click SoftMotion General Axis Pool and then
select Add Device.

2. Inthe Add Device dialog, select Softmotion drives > virtual drives >
SM_Drive_Virtual.

3. Click Add Device.

5.11.4.1 Virtual Drive Settings

After adding a virtual drive, you can configure the virtual drive parameters. The
following tables list the parameters and descriptions.

General
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General Setting
Axis Type and Limits Motion Parameter
Commissioning | Virtual mode e Error Reaction o

(@) Finite Linear Axis Software Lim: Quick Stop

SM_Drive_Virtual: I/O Mapping (O Modulo  [7] Activated
Megative [u]: |0 Velocity Ramp Type

SM_Drive_Virtual: IEC Objects Positive [u]: |1000 (@) Trapezoid (O Sin® ") Quadratic () Quadratic(smooth)

Status Rotary Axis Modulo Settingxe
Modulo value [u]: | 360

Information
Transmission Mechanism

Mechanism Settings

Mechanism Type | Ball Screw )
(1) Command pulse per motor rotation: |1 . [ Pulse ]
@ @) (4) Pitch: |1 [ Unit ]
| " Gear Box
L (2) Gear ratio numerator 1 E
Gear Ratio =
| = [3} (3) Gear ratio denominator 1 E
Positive Command Negative Command

(@) Reverse OFF C@g C@g ’_
cow ow

() Reverse On @ 9 9,
cw

cow

oAxis Type and Limits

Setting Description

Virtual mode Not editable.

Finite Select to set the axis as a linear axis.

The drive has a fixed work area.

Modulo Select to set the axis type as modulo.

The drive turns endlessly without limiting the traversing range.

eLinear Axis Software Limits
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Setting

Description

Activated

Select to turn on the software limit (only supports linear axis).
Position values are restricted by the lower limit Negative and
the upper limit Positive.

Negative [u]

Enter reverse software limit.

Positive [u]

Enter forward software limit.

eRotary Axis Modulo Settings

Setting

Description

Modulo value [u]

Enter one circle range. This function is only available when
selecting Modulo as the axis type. The default value is 360.

°Error Reaction
Setting Description
Quick Stop Select to stop the axis in emergency.

Deceleration [u/sz]

Enter the axis decelerating to stop value (only shows when
the Quick Stop checkbox is cleared).

eVeIocity Ramp Type
Setting Description
Trapezoid Select the axis motion curve.
Sin?
Quadratic

Quadratic (smooth)

eTransmission Mechanism
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Setting Description
Mechanism Type Select the mechanism type.
Mechanism Set- Set the parameter value for the selected mechanism. The set-
tings tings differ by type.
* Command pulse per motor rotation: The value can
only be edited in Motor Settings > Encoder Pulse Per
Revolution. It is four times the value set in Encoder
Pulse Per Revolution. MX300-E does not support
editing this value.
* Pitch: Enter the scalable distance the worktable moves
for a unit.
See the following picture for examples.
(4) Pitch value | Worktable movement | Function block The actual
distance base input value distance the
worktable moves
10000 100 cm 10000 100 cm
100 100 cm 100 100 cm
10000 100 cm 1 0.01 cm
100 100 mm 1 1 mm
* Diameter: Enter the diameter of the gear. Diameter*mr =
Movement distance per motor rotation
* Movement distance per motor rotation: Enter the dis-
tance the motor moves to rotate for a cycle.
Gear Ratio Select or enter the (2) gear ratio’s numerator (number of teeth
of the worktable) and (3) denominator (number of teeth of the
motor gear) to set the reduction ratio.

oPositivelNegative Command

Setting

Description

verse On

Reverse OFF/Re-

Select the forward or reverse command.

Commissioning
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General Setting

Commissioning

SM_Drive_Virtual: /0 Mapping

SM_Drive_Virtual: IEC Objects

Status

Information

Orling

variable set value actual value
000 000
Velocity [u/s] 0.00 0.00
Acceleration [u/s] 0.00 0.00
Torque [MNm] 0.00 0.00
Pawer Error reset

Power
Inch
Distance:
Velocity:
Acceleration:

Deceleration:

Jerks

Reset

1

10

10

Status:

|5MC_AXIS_STATE.power_oFF

Cummunicatinnioperaﬁonal (100)

Errors
Axis Errar:

|0 [1600000000]

FB Errar:

|SMC_ERRDF:.SMC_NO_ERROR

uiDriveInterfaceError:

0

strDrivelnterfaceError:

TIT

Homing
Start
Read@ilrite
Parameter: I:I
Value:

Prepared Value: I:I &

This tab is used for testing purposes when commissioning physical drives. It is

available only if the Online Config Mode is enabled. In this mode, the development

system is connected to the device; however, an application does not have to be

downloaded.

1/0 Mapping

General Setting

Commissioning

Bus Cycle Options

Bus cycle task Task

SM_Drive_Virtual: If0 Mapping

SM_Drive_Virtual: IEC Objects
Status

Information

i Recreate required tasks
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Setting Description

Bus cycle task Select a bus cycle task.

Recreate required | Click to recreate the selected task.
task

IEC Objects

General Setting gk Add... [ Edit... Delete Go to Variable

Variable Mapping  Type

Commissioning
& 5M_Drive_Virtual [ ] AXIS_REF_VIRTUAL_SM3

SM_Drive_Virtual: If0 Mapping
SM_Drive_Virtual: IEC Objects
Status

Information

Lists the "objects" that access the device from the IEC application. In the online
mode, this is used as the monitoring view.

Status
G | Setti
EREE SR ‘SM_Drive_Lngical: : Infa
Commissioning
SM_Drive_Virtual: : |nfa

SM_Drive_Virtual: If0 Mapping

SM_Drive Virtual: IEC Objects

Status

Information

Shows the status of the virtual drive.

Information
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General Setting

Commissioning

SM_Drive_Virtual: If0 Mapping

SM_Drive_Virtual: IEC Objects

Status

Information

General

Mame: SM_Drive_Virtual

Vendor: 35 - Smart Software Solutions GmbH
Categories: virtual drives

Type: 1024

1Dz FFFF 0001

Version: 4.0.0.0

Order number: 1305

Description: SoftMotion virtual drive

Shows the general information of the virtual drive.

5.11.5 Add a Free Encoder

Use the free encoder to connect to the external encoder electronic signal source,
which is commonly used for precise positioning during motion control.

To add a free encoder to the project

1. On the Devices pane, right-click SoftMotion General Axis Pool, and then

select Add Device.

2. In the Add Device dialog, select Free Encoder > one of the encoders.

3. Click Add Device.

5.11.5.1 DMC Encoder Settings

After adding a DMC encoder (Delta’s encoder), you can configure the encoder
parameters. The following tables list the encoder parameters and descriptions for

AX-3 controllers.

Encoder Configuration
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Encoder Configuration Encoder
Encoder Standard 0
DMC_Encoder: Parameters Positive Command Negative Command
1 Encoder Device: Data Source
DMC_Encoder: /0 Mapping
: Data Source:
DMC_Encoder: IEC Objects @® Reverse OFF 9 9
Status
| Encoder Type
Information g (®) Finite (O Modulo
—___ Modulo: |360 [ Unit ]
() Reverse On A !
SingleTumSetﬁngs:[bit] S e 9 9
Multiple Turns Settings: [0 E [bit]
Transmission Mechanism
Mechanism Type Ball Screw v Mechanism Settings
(1) Command pulse per motor rotation: |1 @ [Pulse]
4 '
(4) Pitch: |1 [Unit]
@ o= |
: .. 0
W/ 77/ {
Gear Box
—_ (2) Gear ratio numerator I:E
Gear Ratio =
(3) (3) Gear ratio denominator C@
OEncoder Standard
Setting Description

Data Source Click El to select a UDINT variable under Motion_PRG to

map to the encoder.

Encoder Device Not editable.
eEncoder Type
Setting Description
Finite/Modulo Select a linear or rotary encoder.
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Setting Description

* Modulo: The encoder turns endlessly without limiting
the traversing range.

* Finite: The encoder is limited.

Modulo Enter one circle range. The motor rotates one circle after the
encoder rotates the Modulo value set. This function is only
available when selecting Modulo as the encoder type. The
default value is 360.

Single Turn Set- Select or enter the bit length of the single-turn resolution. This

tings function is only available when selecting Finite as the en-
coder type.

Multi Turns Set- Select or enter the bit length of the multi-turn resolution. This

tings function is only available when selecting Finite as the en-
coder type.

ePositivelNegative Command

Setting Description

Reverse OFF/Re- | Select the forward or reverse command.

verse On

°Transmission Mechanism

Setting Description

Mechanism Type Select the mechanism type.

Mechanism Set- Set the parameter value for the selected mechanism. The pa-
tings rameters differ by the mechanism type.
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Setting Description

for a unit.

See the following picture for examples.

* Command pulse per motor rotation: Shows the num-
ber of pulses required for a motor to rotate for one cycle.

* Pitch: Enter the scalable distance the worktable moves

(4) Pitch value | Worktable movement | Function block The actual
distance base input value distance the
worktable moves
10000 100 cm 10000 100 cm
100 100 cm 100 100 cm
10000 100 cm 1 0.01 cm
100 100 mm 1 1 mm

Movement distance per motor rotation

tance the motor moves to rotate for a cycle.

* Diameter: Enter the diameter of the gear. Diameter*mr =

* Movement distance per motor rotation: Enter the dis-

Gear Ratio Select or enter the gear ratio’s numerator and denominator.

When the encoder is connected, the online monitoring information is shown.

& DMC_Encoder x | [f] Device

Encoder Configuration Online

Status: Communication:
DMC_Encoder: 10 Mapping

Errors

variable set value actual value
DMC_Encoder: IEC Objects Axis Error:
Position [u] 0 0 0 [162000000
Status Velodity [ufs] 0 0 FB Error:
. Acceleration [u/s?] SMC_ER -
Information uiDrivelnterfaceError:
Torque [Nm] i E

strDrivelnterfaceError:

DMC_Encoder: Parameters
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Encoder Canfiguration Parameter Type Value  DefaultValue Unit  Description
=l AXIS_REF: Standard
| DMC_Encoder: Farameers 4 wDrivelD WORD 0 1 1D of drive
DMC_Encoder: /0 Mapping @ dwRatioTechUnitsDenom DWORD 159154943 1 conversion inc. ftech, units denominator
@ RaticTechUnitshum DINT 500000000 1 conversion inc. ftech.units numerator
DMC_Encoder: IEC Objects # MovementType INT 1 1 movement type: 0: rotary/modulo, 1: linear
@ fPositionPeriod LREAL 380.0 380.0 modulo value for rotary drives
Status @ MultiTurnsSetup WORD 0 0 bit Mumber of data bits to count turns
# SingleTurnsSetup WORD 18 18 bit Mumber of data bits of per turns
Information =1 possible cydic driver in-foutputs
@ NumberOfOutputMappingParams INT ] ]
# NumberOfinputMappingParams MT 0 0
@ Automatic Mapping BOCL FALSE FALSE
=l AXIS_REF: Scalings
@ Mechanism Type Enumeration of BYTE Belt Pulley Ball Serew 0:Ball Screw f 1:Round Table [ 2:Belt Pulley

Shows the device-specific parameters.

To show this tab, on the menu bar, select Tools > Options > Device editor > Show
generic device configuration views.

DMC_Encoder: /0 Mapping

Encoder Configuration Find Filter Show all » &b Add FB for [0 Channel g
M P Variable Mapping Channel  Address  Type  Unit  Description
+-|_J ECAT_ENCODER_SOUR...

DMC_Encoder: 1/0 Mapping

DMC_Encoder: IEC Objects

Status

Information
IShows the available channels and allows for the mapping of input, output, and
memory addresses of the controller to variables or entire function blocks of the
application.
DMC_Encoder: IEC Objects
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Encoder Configuration ak Add... [ Edit... Delete Go to Variable

Variable Mapping  Type
DMC_Encoder: Parameters
& DMC_Encoder @ ECAT_FREE_ENCODER_REF
DMC_Encader: I/0 Mapping
DMC_Encoder: IEC Objects
Status

Information

Lists the "objects" that access the device from the IEC application. In the online
mode, this is used as the monitoring view.

Status
Encoder Configuration I SM_Drive_Logical: . In/a I
DMC_Encoder: Parameters
I DMC_Encoder: : I”/a I

DMC_Encoder: I/0 Mapping

DMC_Encoder: IEC Objects

Status

Information

Shows the status of the encoder.

Information
Encoder Configuration General
MName: DMC_Encoder
DMC_Encoder: Parameters Vendor: Delta Electronics, Inc.
Categories: Free Encoders
DMC_Encoder: /O Mapping Type: 1152
ID: 16F7 0001
DMC_Encoder: IEC Objects Version: 1.0.3.0
Order number: 1305
Status Description: SoftMotion free Encoder

Information

Shows the general information of the encoder.
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5.11.5.2 SMC Encoder Settings

After adding a SMC encoder, you can configure the encoder parameters. The
following tables list the encoder parameters and descriptions.

Encoder
Encoder general settings
Encoder B T gener g
O] MOdU|Oo Modulo settings Bitwidth: |32
SMC_FreeEncoder: Parameters () Finite Modulo value [u]: |360.0
SMC_FreeEncoder: 1/0 Mapping Scaling

[] tnvert direction

& |
|

strDrivelnterfaceError:

uiDrivelnterfaceError:

SMC_FreeEncoder: IEC Objects 9 increments <=> encoder turns
Status encoder turns <=3 units in application
Online
Information
variable set value actual value Status: ‘ |
Posiion u] Commumcation# |
Velocity [u/s]
Acceleration [u/sd Errors
Torque [Nm] |ij s Error: ‘
FB Error:

oEncoder general settings

Setting Description

Modulo/Finite Select a linear or rotary encoder.

* Modulo: The encoder turns endlessly without limiting
the traversing range.

* Modulo Value [u]: Enter one circle range. The motor
rotates one circle after the encoder rotates the Modulo
value set. This function is only available when selecting
Modulo as the encoder type. The default value is 360.

* Finite: The encoder is limited.

DIADesigner-AX Version 1.8.0 &



A NELTA

Chapter 5: Hardware Configuration

Setting Description
Bit width Select a bit width.
QScaIing
Setting Description

Invert direction

Select to allow the encoder to receive the specified values
with inversed signs and rotate in the opposite direction.

increments < = >
encoder rotations

Enter the number of increments which correspond to the num-
ber of complete encoder rotations.

encoder rotations

Enter the encoder turns which correspond to units in applica-

<=> units in appli- | tion.
cation
eOnIine
Setting Description
Status Shows the current status of the encoder.

Communication

Shows the current communication status.

Errors

Shows the related errors.

SMC_FreeEncoder: Parameters

Encoder

SMC_FreeEncoder: Parameters

SMC_FreeEncoder: If0 Mapping

SMC_FreeEncoder: IEC Objects

Status

Information

Parameter Type Value  Default Value Unit  Description
= AXIS_REF: Standard
@ whrivelD WORD 1 1 ID of drive
# dwRatioTechUnitsDenom DWORD 1 1 conversion inc. ftech.units denominator
# iRatioTechUnitshum DINT 1 1 conversion inc. ftech.units numerator
@ MovementType INT 0 1 mavement type: 0: rotary/modulo, 1t linear
i fPositionPeriod LREAL 360.0 360.0 modulo value for rotary drives
=l AXIS_REF: Scalings
i ScalingIncs DINT 1 16%20000
# ScalingEncoderTurns1 DINT 1 1
# ScalingEncoderTurns2 DINT 1 1
# ScalingUnits DINT 1 1
@ InvertDirection BOOL TRLE FALSE
=--[_1 possible cydic driver in-foutputs
# NumberOfOutputMappingParams INT
# NumberOfinputMappingParams INT 0 0
# Automatic Mapping BOOL FALSE FALSE
=4 ENCODER,_REF: Input
# EncoderBitWidth BYTE 32 32
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Shows the device-specific parameters.

To show this tab, on the menu bar, select Tools > Options > Device editor > Show

generic device configuration views.

SMC_FreeEncoder: I/O Mapping

Encoder Bus Cyde Options
Bus cydle task Use parent bus cyde setting Recreate required tasks
SMC_FreeEncoder: Parameters
SMC_FreeEncoder: If0 Mapping
SMC_FreeEncoder: IEC Objects

Status

Information

Setting Description

Bus cycle task Select a bus cycle task to synchronize with the SMC encoder
communication time.

SMC_FreeEncoder: IEC Objects

Encoder gk Add... [ Edit... Delete Go to Variable

Variable Mapping  Type
SMC_FreeEncoder: Parameters
# SMC_FreeEncoder @ FREE_EMCODER_REF
SMC_FreeEncoder: If0 Mapping
SMC_FreeEncoder: IEC Objects
Status

Information

Lists the "objects" that access the device from the IEC application. In the online
mode, this is used as the monitoring view.

Status
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Encod
NCoder ‘ M _Drive_Logical:

SMC_FreeEncoder: Parameters

SMC_FreeEncoder:
SMC_FresEncoder: [/0 Mapping
SMC_FreeEncoder: [EC Objects

Status

Information

Shows the status of the encoder.

Information

Encoder General

SMC_FreeEncoder: Parameters

SMC_FreeEncoder: If0 Mapping

SMC_FreeEncoder: IEC Objects

Status

Information

Name: SMC_FreeEncoder

Vendor: 35 - Smart Software Solutions GmbH
Categories: Free Encoders

Type: 1152

ID: FFFF 0001

Version: 3.5.5.0

Order number: 1805

Description: SoftMotion free Encoder

Shows the general information of the encoder.

5.11.6 Axis Group

The axis group defines the mechanism relationship between axes. Use the axis

group movement when running multiple axes and running linear and circular

interpolation. DIADesigner-AX supports setting the axis group.

Maximum control axes

Linear interpolation

6 axes

Circular interpolation

6 axes (3 follower axes)

5.11.6.1 Add an Axis Group

To use the axis group movement, you must create the axis group and add individual

axes.

To create an axis group
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1. Add axes. Take two virtual axes as an example. For more information about

adding a virtual axis, see Add a Virtual Drive.

Devices

=5 Uniied? i
=[] controller_1 {AX-308EAOMA1T)

>&£ Hardware Configuration
- ﬁ. Metwork Configuration
,J;‘ EtherCAT Topology

----- A, EtherNetlP Topology

,Jx. ModbusTCP Topology
=-El] PLE Logic
=i} Application

..... o |Del13.ﬁ.xisGrDup

’ﬁ] Library Manager
-[E] Motion_PREG (PRG)
5] PLC_PRG (PRE)
= @ Task Configuration
=g EtherCAT Task (IEC Tasks)
. g8 Motion_PRG
- @ MainTask (IEC-Tasks)
] PLC_PRG
=[] Builtin_10 (Builtin_10)

..... @ DIO {DIO)
@ Delta_LocalBus_Master (Delta LocalBus Mastd

@ EtherCAT_1 (A¥X Series EtherCAT Master Sofi
@ Ethernet_1 (Ethernet)

= "% SoftMotion General Axis Pool

: 53 SM_Drive_Wirtual (SM_Drive_Virtual)
rj;;j SM_Drive_Virtual_1 (SM_Drive_Virtual)

2. Right-click Application, and then select Add Object > Delta Axis Group.

3. Inthe Add Delta Axis Group dialog, enter the name, and then click Add.

4. On the DeltaAxisGroup pane, in the Axis X row, click
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i%/) DeltafxisGroup X

£ Kinematic

Configuration
Axis 2
Axas Group

Axis X: (Confiqure) [Please Enter an Axis Mapping

Axis ¥: (Configure) Please Enter an Axis Mapping

Axis Y - - —
Axis Z:  (Configure) [Flease tnter an Axis Mappir

[I's]

Auis X

Following Axis 3 )
. Feollowing Ratia

Axis A: (Configure) [Please Enter an Axis Mapping
Axis B: {Configure) [Please Enter an Axis Mapping

= Axes Group Axis C: (Configure) Please Enter an Axis Mapping

5. In the Input Assistant dialog, select the virtual axis SM_Drive_Virtual, and
then click OK.

6. Inthe Axis Y row, click

7. In the Input Assistant dialog, select the virtual axis SM_Drive_Virtual_X, and
then click OK.

& DeltaAxisGroup X

A Kinematic

Configuration
Axis 2
Axes Group

Axis X: (Configure) | SM_Drive_Virtual

Axis Y: [Cenfigure) | SM_Drive_Virtwal_1

Axis Y

Axis Z: (Configure) |Please Enter an Axis Mappir

(=]

Axis X

Follawing Axis . .
d Fellowing Ratio

ter an Axis Mapping

Axis A: [Configure) [Fl2ase £n
Axis B: {Configure) |Please Enter an Axis Mapping

* Axes Group Axis C: [Configure) |Please Enter an Axis Mapping

8. Add the DMC_GroupEnable function block in Motion_PRG, and enter the
axis group name in the AxisGroup pin.
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=l AxEGrous
= [{] Device (A%-C12EBOMDIT)
@ Hardware Configuration
= A, Metwork Configuration
A, EtherCAT Topology
=81 PLC Logic
=L} Application
& DeltaAxisGroup
m Library Manager
Motion,PRG (PRG)
PLC_PRG (PRG)
9 pou (ero)
= @ Task Configuration
=-$8 EtherCAT Task
H] Motion_PRG
=g MainTask
&) PLC_PRG
=[] Builtin_10 (Builtin_I0)

Scope Mame  Address Data type Initialization Comment]

L]

BMC. GronpEnabls.l
TRUE DMC_GroupEnable
] {1 EN ENO
DeltaRAxisGroup —5|AxisGroup bDone [— 27?
—bExecute bBusy —
bError [~
ErrorID

9. Compile the program and fix errors if any.

10. Log in and download the program.

5.11.6.2 Axis Group Settings

After adding an axis group, you can configure the axis group parameters. The
following tables list the axis group parameters and descriptions.
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A Kinematic -
Configuration
Axis Z

Axes Group

Axis Y

Axis X: (Configure) |Please Enter an Axis Mapping

Axis Y: (Configure) |Please Enter an Axis Mapping

Axis A: (Configure) |Please Enter an Axis M

Axis B: (Confiqure) |Please

Axis X
Following Axis . .
ing A Following Ratio
Axes Group
) Note
/
I..
Axe X
ey Fues Group

Cacuation

\_  Following Ratio =

Motion Parameter
RampType | S Curve
A\

Target Position of Following Axis

Target Position of Axis Group

N

\

A Tasks

Bus Task: | <Unknown>

Axis C: (Confiqure) |Please Enter an Axis

Axis Z: (Confiqure) |Please Enter an Axis Mapping

apping

m

nter an Axis Mapping

Mapping

/

Max Velocity Limit (1000000
Max Acceleration Limit  |2000000
Max Deceleration Limit :2000000

Max Jerk Limit (Reserved) iO

; (user unit)/s
: (user unit)/s?
: (user unit)/s?

(user unit)/s®

Kinematic

Setting Description
Axis X Enter or select the X axis in the axis group.
Axis Y Enter or select the Y axis in the axis group.
Axis Z Enter or select the Z axis in the axis group.
Axis A Enter or select the A axis in the axis group.
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Setting Description
Axis B Enter or select the B axis in the axis group.
Axis C Enter or select the C axis in the axis group.

Motion Parameter

Setting

Description

RampType

Select the velocity curve type.

Maximum Velocity
Limit

Enter the maximum velocity of the axis group.

An error occurs when the axis group movement velocity ex-
ceeds the value set.

Maximum Acceler-
ation Limit

Enter the maximum acceleration of the axis group.

An error occurs when the axis group movement acceleration
exceeds the value set.

Maximum Deceler-
ation Limit

Enter the maximum deceleration of the axis group.

An error occurs when the axis group movement deceleration
exceeds the value set.

Maximum Jerk
Limit (Reserved)

Enter the maximum acceleration (jump) of the axis group.
This function is reserved.

Tasks

Setting

Description

Bus Task

Set the axis group task.

5.11.7 Homing Setting Reference

The following table shows the devices and their homing functions and settings.

Function:
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1.

Homing speed during search for switch

Homing speed during search for z phase pulseswitch
Homing acceleration

Torque Detection Level

Level Reached Timer

Function Device

Homing Mode E3/ C2000
E3C Plus

CH2000

Reverse to look VIV|IV|V|V V |V |V V
for the collision
point

Go forward to look |V |V [V |V |V V |V |V V
for the collision
point

Reverse to look V|IV|V|V|V V |V |V \
for the collision
point and then re-
turn to look for Z
pulse

Go forward to look |V |V |V |V |V vV |V |V Vv
for the collision
point and then re-
turn to look for Z
pulse

Depend on the VIV |V vV |V |V |V vV |V
negative lim-

it switch and Z-
pulse

Depending on VIV |V vV |V |V |V vV |V
the positive lim-
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Function Device
Homing Mode E3/ C2000
112(3|4 A2|A3|B3 H3 CH2000
E3C Plus
it switch and Z
pulse
3 Depend on the V|V |V V |V |V |V vV |V \
4 home switch and viviv viv v v v v Vv
Z pulse
5 VIV|V V |V |V |V V |V Vv
6 V|V|V V |V |V |V V |V Vv
7 Depend on the VIV |V vV |V |V |V vV |V \%
8 home switch, and vIviv v Iviv v v v Vv
positive limit and
9 Z pulse VIV|V V |V |V |V V |V Vv
10 VIV|V V |V |V |V V |V Vv
11 Depending on V|V|V V|V |V |V vV |V \%
12 the home switch viviv viv v v v v Vv
and negative lim-
13 it switch Z-phase VIV |V VIV IV IV Vv v
14 |pulse VvV VIVIVIV |[v|v |V
17 Similartomode 1 |V |V |V vV |V |V |V vV |V \%
that depending on
the negative limit
switch but without
Z-pulse
18 Similartomode 2 |V |V |V vV |V |V |V vV |V \%
that depending on
the positive limit
switch. but without
Z pulse
19 Similar to mode VIV|V V |V |V |V V |V Vv
g0 |Sthatdepend- |\ 1y, 1y, vI{vivi v |v|v Vv
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Homing Mode

Function

Device

A2

E3/
E3C

A3|B3

H3

C2000
Plus

CH2000

ing on the home
switch but without
Z pulse

21

Similar to mode

22

5 that depend-

ing on the home
switch. but without
Z pulse

23

Similar to mode 7

24

that depending on
the home switch
and positive limit
switch but without
Z pulse

25

Similar to mode

26

10 that depend-
ing on the home
switch and pos-
itive limit switch
but without Z
pulse

27

Similar to mode

28

11 that depend-
ing on the home
switch and negtive
limit switch but
without Z pulse

29

Similar to mode

30

14 that depend-
ing on the home
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Homing Mode

Function

Device

A2

A3

B3

E3/
E3C

H3

C2000
Plus

CH2000

switch and negtive
limit switch but
without Z pulse

33

Depending on Z
pulse in the nega-
tive direction

34

Depending on Z
pulse in the posit-
ige direction

35

Depending on the
current position

E, and ASDA-H3-E devices.

5.11.8 SoftMotion Version Compatibility

Note: The Homing Setting -1~-4 is only applicable to ASDA-A3-E, ASDA-B3-

Softmotion v4.10 is supported from DIADesigner-AX version 1.4.0. Use the following

table to check the version compatibility among SoftMotion, Axis devices, and related

libraries. You can modify the version or update the device if any related incompatible

errors exist.

DML or Supported Device Library
VLDML Soft-
, : DL_ Mo-
Axis  |c2000+MH300 MX azlaslsaleays K1 | A% Motion o e
. . ion Con-
Device (cH2000MS300 300 FC5621502PU Version _
Ve trolLight
1.0.0.0 VI|V]|V 1.0.0.13
1.0.0.5 V| |V Vv 46.1.0 | 1.0.0.13
1.0.0.6 Vv 1.0.0.13
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DML or Supported Device Library
VLDML Soft-
. - DL Mo-
Axis |c2000+MH300 MX nolaslgaleaa RY | AX Motion oo
. . ion Con-
Device cH2000MS30( 300 FC5621502PU Version _
eI trolLight
1.0.0.14 VIV|V V 1.0.0.13
1.1.0.0 V V V| V|V V 1.1.0.0
1.3.0.0
1.3.0.0 V V V| V|V V
and later
1.3.2.0 VIV |V 1.3.0.0
and later
1.4.0.0 V V V 1.4.0.0
and later
46.1.0
1.4.0.1 V VIiV|IV|V 14.0.0
4.10.0.0
4.16.0.0 and later
141.2 V V V 141.2
and later
1414 V 141.2
and later
142X | V vV | vV I|v|vIviv|v| v | Vv 142X
and later

Note: * indicates that the version is that released in the software.

To update the axis device version
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1. On the Devices pane, right-click the Axis device, and then select Update

Device.

2. In the Update Device dialog, select the latest version (for example, v1.3.0.0),

and then click Update Device.

3. Inthe Update Device List dialog, check the Source and Target version, and

then click Update.

To change the SoftMotion version

1. Go to Project > Project Settings.

2. Select SoftMontion.

3. On the SoftMotion pane, select the version, and then click OK.
To change the library version

1. On the Devices pane, double-click Library Manager.

2. On the Library Manager pane, click Placeholders.

3. Inthe Placeholders dialog, select the library version, and then click OK.
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Chapter 6: Network Configuration

In Network Configuration Editor, you can do the following:
* View the device and network information.
* Double-click or drag the device in Product List to add it to the editor.
* Cut, copy, and paste the device.

* Configure the network for a project.

03 b LA R rrerortdV
A
'] EtherCAT
[l ModousTCP/EtherNetlP
Modbt
e o o
/ 7/
& &
N N
¢ ¢
AX-308EAOMAIT AX-S64EB0MBIT
AX-308EAQ AX-564E80
MALT MB1T
_ .‘ _
M\ N ,‘\
Ethernet_1 ‘
Ethernet_2 dh dh dh
Ethernet_3 "‘ "‘
MODBUS_1 d I I
AX-500CEC00-0A
AXS,_Local10_Bu (EterCAT ASRTU. Defta Modbus
s coupler) ECIBAPITA Slave COM Port —
AXS_Local_ AX-500CEC ASRTU- Delta
10_8us 00-0A EC16AP1TA Modbus
(EtherCAT Slave COM
coupler) Port
4 J
b\> §0 Q
o oy
o S/ Y o8
¥, Q Q &/
K ¢ N Sty
(\,/
v
< >

Device information includes the following:
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%
et~
{'Q:ﬁ‘ 1
ol 2
Davice
3
4
BBEA 5

1. Device name

2. Device default name (won’t change if the name is changed on the project tree)
3. Device image

4. Box to enter note

5. Communication ports on the device

Network information includes the following:

. _ _ _ _ 1
- 2
Ethernat_2
Ethernat_3
Modbus_4
3

1. Network name
2. Network lines
3. Connections to the devices

The following table lists the toolbar items and descriptions in Network
Configuration Editor.
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Setting

Description

Click to scan the connected devices and show in the editor.
Only support scanning the devices connecting with Ethernet
or EtherCAT protocol.

Click to open the Device Repository dialog to install a de-
vice. The installed device will show in Product List > Field-
buses, and then you can add the device to the editor.

Click to open the Axis Selection dialog. Double-click the axis
to open the Select the Device Description dialog to change
the axis.

Select or enter the value to zoom in or zoom out on the editor.

Drag to zoom in or zoom out on the editor.
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6.1 Network Topology

Network topology refers to how various nodes, devices, and connections on your

network are physically or logically arranged in relation to each other.

6.1.1 Set up Network Topology

Use the following steps to set up a network topology.

To set up a network topology

1. On the Devices pane, double-click Network Configuration.

2. From Product List > PLCs, double-click or drag the device to the Network
Configuration Editor.

3. Click the device port and connect to the network line.

Devices

viX

= {{) Controler_t (A%-308EAOMALT)

M
6 Hardware Configuration
=& Network Confiquration
A EtherCAT Topology
A\ EtherNetlp Topology
A ModbusTCP Topology
= B0 pLcLogi
= @ Application
m Library Manager
[£] Motion_PRG (PRG)
[5) pic_pra (ro)
= @ Task Configuration
= EtherCAT Tesk (EC-Tasks)
&) wotion PRG
= MaiTask (ECTasks)
&) me o
= (f) Buitin_10 (it 10)
oo o)
Eﬂ Delta_LocalBus_Master_t (Delta LocalBus Master)
3 \ﬂ EtherCAT_1 (AX Series EtherCAT Master SoftMotion)
= @ Drive_1 (Delta ASDA-A2-€ EtherCAT(CoE) Drive DML)
K4 DML_Drive ETC_Delta_ASDA_A2_1 (ML Drive ETC.
[ﬂ Ethernet_1 (Ethernet)
% Softotion General Ais Pool

= (f) Controler 2 (4 $x0P0 Linux SM Seres)

8 Herdware Configuration
= & Network Configuration
A, EtherCAT Topology
A ModbusCOM Topology
= Bl pucLogi
= @ Application
m Library Manager
(5] Motion_PRG (R6)
= @ Task Configuration
= EtherCAT Tesk (EC-Tasks)
&) wotion PRG
& MaiTask (EC-Tasks)

m

A Network Configuration Editor X
W3 b

EtherCAT
[l ModbusTCP/EtherNietlP
W Modbus

AISEAUAIT
AX-208EA0
MAIT

AXEOERO Lnix
S Setes

AXBoEP)
LinuxSM
Series

Ethernet_1

MODBUS_1

[ ————1]

QoL ASDAN2E

ENeCATICCE)

Ortve DML
Delta
ASDA-A2E
EtherCAT
(CoE) Orive

4. Set the controller as master and connect to slave devices. Right-click the

controller and then select Set As Master / Scanner > Port x.
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Note:

° [If you import a project from a higher version to a lower version, the
slave device can only restore part of it. The network configuration
topology may also be different because different network devices
support different software versions.

° You can delete slave devices and network lines simultaneously
in Network Configuration Editor when deleting slave devices
from the project tree. On the menu bar, select Tools > Options
> Deletingslave devices from the project tree also deletes
the devices and network lines in Network Configuration Editor
simultaneously.

If the slave device is connected to different controllers in the same network, the
slave device and network line are deleted in Network Configuration Editor as
long as the slave device is no longer connected to any master controller and is
all deleted in the project tree.

6.1.1.1 Quick Connection

How do | open the Quick Connection dialog?

* In Network Configuration Editor, right-click the blank area and then select

Quick Connection.

The Quick Connection dialog helps you quickly build a complex network

connection.

The following table lists the items and descriptions in the Quick Connection dialog.
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Please Select Protocol EtherNetIP ~

Please Select Master
Controller Device

4 |H| Device

® Port 1: ModbusTep | EtherMetIP (Has been used)

Please Select Field Devices | A

4 || ASZ22BR

("

Build Network Connection Cancel

Setting Description

Please Select Pro- | Select the protocol to build the connection line.
tocol

Please Select Mas- | Select one master controller based on the selected protocol.
ter Controller De-
vice

Please Select Field | Select the slave devices to connect to the selected protocol.
Devices

Build Network Con- | Click to connect the selected protocol with the selected de-

nection vices. The slave devices will also show in the project tree.

6.1.2 EtherCAT Topology

How do | open EtherCAT Topology?

* On the Devices pane, expand Network Configuration, and then double-click
EtherCAT Topology.
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Use EtherCAT Topology to show the topology of devices in the EtherCAT network
in the project. From DIADesigner-AX version 1.5.0, EtherCAT Topology supports
showing the junction device with more than three ports and the sub devices under

the junction device.

In EtherCAT Topology, you can:
* | ocate network errors.

* Turn on the Show Device Name toggle switch to show the name of each

device in the topology.

* (Click @ to hide the sub devices and click &) to show them.

* View the EtherCAT address by the number above the device.
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6.1.2.1 Set up EtherCAT Topology
Use the following steps to set up EtherCAT Topology.
To set up EtherCAT Topology
1. On the Devices pane, double-click Network Configuration.
2. In Product List, select Fieldbuses > EtherCAT > one of the devices.

3. Drag the device to Network Configuration Editor.
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| /A Wetwork Configuration Editor X | A, EtverCATTopoogy | /[P 5L
W3k o0 {1t
Sting forafullt B
11 EtherCAT
I ModbusTCPEtherhetP Al Vendors [F]
[l Modbus
(7] Display Al Versions
Product List
I W PLCs
N N 4 9 Fieldbuses
& & 4 G EterCAT
& N
¢ ¢ 4 G ASD
ﬂ Delta ASDA-A2-E EtherCAT(CoE)
X20ER0Unx Det*s ASDA-A2-E EtherCAT(CoE)
St
AXSoEP) [l/Delta ASDA-A3-E EtherCAT(CoE)
Pt i Delia ASDA-A3-E EtnerCAT(CE)
[| Delta ASDA-B3-E EtherCAT(CoE)
[! Delta ASDA-B3-E EtherCAT(CoE)
H Delta ASDA-E3 Series EtherCAT(
. ) Delta ASDA-E3 Series EtherCAT({
- Delta ASDA-H3-E EtherCAT(CoE;
% Ethernet_1 moe eICAT(CaE)
[ Delta ASDAW3-E EtherCAT(CoE)
b ASRTU
MODBUS_1 :
b AX5
o 5 I & RIC
I @& RIEC
e Coap - G I % R2EC
Delta Modbus Deita
ASDARZE Siave, COM ASDARE b O RIUECAT
EtherCAT Fort [] EtherCAT I 8 VFD
{Co)Drve: 3] (cog)Drive
N v % EtherNetlP
R e,ﬁj}& b Modbus
& & b B Modbus TCP
7
& < )
Devices v 4 X A, Network C Editor X [}, EtherCAT Topology \
=) Untitleds allg 3 b 80 ] =A——+
hd TR
= (@ controller_1 (AX-308EAOMALT)
8 Hardware Configuration EtherCAT
=& Network Confiquration =x$2usTCP/EmerNeIIP
e y— s
A, EtherCAT Topology |
,‘, EtherNetIP Topology
A, ModbusTCP Topology 0\\6’ o\\c‘/
N 3 ¢
=B0 PLCLoge <,°°\ <,°°\
= @ Application
m Library Manager
] Motion_PRG (PRG) AXLOEPOLnix
£] PLC_PRG (PRG) ’“XX“;;:;‘ 5’;;:;;?‘;
= @ Task Configuration MAIT LinwxSM
= EtherCAT Task (IEC-Tasks) Series
8] Motion_PRG
=& MainTask (IEC-Tasks)
@] PLc_PRG
= (@ Buitn_IO (Buitin_10)
i o10 ©r0)
@ Delta_LocalBus_Master_1 (Delta LocalBus Master) Ethernet 1 | |
= m EtherCAT_1 (AX Series EtherCAT Master SoftMotion) - | ‘
= m Drive_1 (Delta ASDA-A2-E EtherCAT(CoE) Drive DML) | ‘
PoX EIC D (DM Dive MODBUS_1 ! ‘
Wy SM Dnve ‘
[ﬂ Ethernet_1 (Ethernet)
3 SoftMotion General Axis Pool QupsorazE o see, Dot oA
=+ (@) controller_2 (AX-8xxEPO Linux SM Series) 2 Coupe = oo S
) Delta Modbus Deita
8 Hardware Configuration ASDA-A2.E Stave, COM ASDA-A2-E
= &, Network Confiquration EtherCAT Port ﬂ EtherCAT
A, EtherCAT Topol CoE) Drive (CoE) Drive
er opoiogy
}, ModbusCOM Topology \‘5‘°x
=80 pLc Logic N Y
; og» } & °§3 &7
= @ Application & \xgzo &
m Library Manager 4
Motion_PRG (PRG)

In EtherCAT Topology, double-click the device to open the parameter page to
set EtherCAT parameters. For more information, see EtherCAT Settings.

DIADesigner-AX Version 1.8.0

197



A AELTA Chapter 6: Network Configuration

Note: When you start programming, use the motion function block
to write the program in the POU under EtherCAT_Task to ensure the
motion function block runs normally.

Devices v & || /lg] Motion_PRG X v
=1 Untited! v 1| PROGRAM Motion_PRG
=@ Controler_t (Ax-308€A0MAIT) Y VR
END VAR

&8 Hardware Configuration
= A Network Configuration
A, EtherCAT Topology
A EtherNetlP Topology
A, ModbusTcp Topology
=B0 pLC Logic
= O Application
m Library Manager
1) oton PRG (RG) .
[ pLc_pR6 (PRG) Wl@s
= (B Task Configuration 1 M
=B EtherCAT Task (IEC-Tasks) MC Pover
@ Motion_PRG Axis - Status ——
= @ MainTask (IEC-Tasks) Enable bRegulatorRealState
&) picpre bRequlator0n  pDriveStartRealState
= f) Buitin 10 (uitin 10) bDrivestart Busy
@ oo (o10) Error
Ej Delta_LocalBus_Master_1 (Delta LocalBus Master) ErrorID
@ EtherCAT_1 (AX Series EtherCAT Master SoftMotion)
tﬁﬂ Ethernet_1 (Ethernet)
4 Softotion General Axis Pocl

1 1 1 1T

T T T T T

6.1.2.2 EtherCAT Device Diagnosis

This section describes the basic diagnosis functionalities and the most typical
errors of the devices within an EtherCAT network. Use this function to diagnose the
EtherCAT errors for master and slave devices online.

To diagnose errors within an EtherCAT network

1. Log in to the controller.
Note: The diagnosis function is not available in the simulation mode.

2. On the Devices pane, double-click EtherCAT Topology.

3. Click Pto diagnose the EtherCAT network. You can also click € to get the
diagnosis information continuously. If you switch to another editor, the auto

diagnosis stops. When you switch back, the auto diagnosis starts again.
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4. Click the device respectively to view its diagnosis information on the Properties
pane.

5. (optional) Turn on the Clear Register toggle switch to clear the historical
register data of all slaves before auto and manual diagnosis.

You can view the diagnosis result and status on the Messages pane at the bottom.

6.1.2.2.1 EtherCAT Diagnosis Device Status

The master device controls the operation of each EtherCAT slave device. Depending
upon the state, different functions are accessible or executable in the EtherCAT
slave.

Device Status

The following table lists the status and its descriptions of the master device
(controller).

Status Description

|i| The device is mismatched.

Hard Error

The following table lists the status and its descriptions of the slave devices.

Status Description

IEI The device is mismatched.

Hard Error

@ The device has software errors, such as unsupported cycle
time.

Soft Error

O Communication is established, but mailbox communication
and process data are not available.

Init
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Status

Description

D

Pre-Operational

Mailbox communication is possible, but process data is not
transferred.

O

Safe-Operational

Process data has already been transferred. Inputs are read,
but outputs are not given.

D) All process data is transferred. The slave copies the output
data of the master to its outputs.

Operational

O The firmware file is transferred to or from the slave.

BootStrap

You can set and change the slave device state. Right-click the device and then click
Set State to set the state of the current slave to the selected one.

Note: This function is not available if the application stops running.

Port Status

To locate the device with errors quickly in the EtherCAT topology, ports are shown in
different colors to indicate the communication status.

Status Description
. Read the register successfully.
There is no CRC/RX error or Lost Link.
Normal
Read the register successfully.
. There is a CRC/RX error or Lost Link.
Warning
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Status

Description

No-Comm

Have not or failed to read the register.

6.1.2.2.2 EtherCAT Diagnosis Properties and Errors

On the Properties pane, you can view the properties and errors for both master and

slave devices.

The following table lists the properties, errors and its descriptions of the master

device (controller).

Item

Description

Property

Shows the basic information about the controller.

Clear Memory Data

Click Clear to set the memory data of all slaves to zero. You

need to click > to get the latest diagnosis information.

Bus Load

Shows the fieldbus load.

Frame Counter

Acknowledge

Click to set all frame counters to zero. You need to click | -

to get the latest diagnosis information. This option is not avail-

able if you click L& |

Send Frames

Shows the number of total EtherCAT frames sent.

Frames Per Se-
cond

Shows the number of frames sent per second.

Lost Frames

Shows the number of total lost frames. A frame is lost due to
Electro Magnetic Compatibility (EMC), connection, or other
hardware problems. In addition, if the CRC does not match,
then this counter increases as the network driver skips the
frame.

Rx Error

Shows the number of missing received frames. Each sent
frame must be received at least in the next IEC cycle. If the
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Item Description
runtime system (TCP-IP stack) is busy or the priority is low,
then frames will be delayed for sending or receiving and this
counter will increase.
Tx Error Shows the number of frames that was not sent.

Last Message

Shows the last message of the EtherCAT stack.

Task Information

Task Name

Shows the task you select in EtherCAT_Master_SoftMotion
> EtherCAT 1/O Mapping > Bus cycle task.

Task Priority

Shows the priority of the task.

Average Cycle

Shows the average cycle time of the task.

Time
Max Cycle Time Shows the maximum cycle time of the task.
Min Cycle Time Shows the minimum cycle time of the task.

The following table lists the errors and its descriptions of the slave device.

Item

Description

Property

Shows the basic information about the device and its diagno-
sis message.

State Machine

Current State

Shows the current state of the slave state machine.

Request State Shows the requested state of the slave state machine. If the
slave device is in the "Init" state and the "Op" state is request-
ed, the slave device then passes through the "Pre-Op" and
"Safe-Op" states before reaching the "Op" state.

Suggestion Shows the suggestion of how to fix the current topology error.

Diagnosis Mes-
sage

Shows the diagnosis message.

DLL Status

Shows the DLL status of the active port.
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Item Description

* No Carrier / Open: No carrier signal exists at the port,
but the port is open.

* No Carrier / Closed: No carrier signal exists at the port,
and the port is closed.

* Carrier / Open: A carrier signal exists at the port, and the
port is open.

* Carrier / Closed: A carrier signal exists at the port, but
the port is closed.

Lost Link Shows the number of interrupts in the hardware communica-
tion channel during which frames are not sent to the neighbor-
ing device.

Port CRC Shows the number of errors that occurred through the cyclic
redundancy check for the active port.

Rx Error Shows the number of times of the data losses of the network
card during sending and receiving.

AL Status

Error Code Shows the AL status error code.

Error Text Shows the AL status code meaning.

6.1.2.2.3 EtherCAT Diagnosis Scenarios

This section provides some EtherCAT diagnosis scenarios and the corresponding

topology examples for an intuitive explanation.

Scenario 1: Networking failed

The device in the project tree does not match the physical device.

Example:
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Note: If a device has a hard error, the following devices connected will all
be in the hard error status. In this case, you must check and fix all the hard
errors from the first device.

Scenario 2: Networking succeeded

The devices in the project tree match the physical devices.

Example:
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Scenario 3: Unplug the cable and plug it back

In the successful network, unplug the cable of a slave device and plug it back. Check
the diagnosis result of the two situations.

* Unplug the cable of a device.

Example:
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Hil

HH

Note: In this scenario, the disconnected devices and devices connected to it
will be in a hardware error state. The port of the first device will turn gray first,
and the following devices need to wait for a few seconds to turn gray.

* Plug the cable back and diagnose again.

Example:
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® 2 @ @ @

Note: In this scenario, some ports are green while some are orange. The
orange port indicates that the link has been lost before (Lost link is not 0).

6.1.2.2.4 Set up Alias Address for the Slave Device

In EtherCAT Topology, the device address shows on the top of the device. You can
use the following steps to change the address to an alias address.

To set up the alias address
1. Double-click the slave device to open its configuration page.

2. On the General tab, select Expert settings or Optional to show the
Identification settings.

3. Select Configure station alias and then enter or select an alias address.
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6.1.3 Set up Modbus Topology
Use the following steps to set up Modbus Topology.
To set up Modbus Topology
1. On the Devices pane, double-click Network Configuration.

2. In Product List, select Fieldbuses > Modbus > one of the devices.

w

Drag the device to Network Configuration Editor.

4. Connect the slave device to the Modbus line.

CRCIY

EtherCAT
Bl ModbusTCP/EtherNetlP
W Modbus

AXIOEEACUMT
AX-308EA0
MAIT

Ethernet_1
MODBUS_1

s g 0
Data Moctus
Slave COM Poct pr—
Deita
Modbus
Slave COM
01| Port 8]
&/
st <°
@ »
©
\\I'b/ 7/
St
YN
(\.
o O u]

5. Right-click the controller and then select Set As Master/Scanner > Port x :
Modbus to set the controller as Modbus master.

6. Double-click the slave device to open the parameter page to set Modbus

parameters.

DIADesigner-AX Version 1.8.0

208



A AELTA Chapter 6: Network Configuration

A Metwork Configuration Editor ﬂ'j ASD_ AZ M X
| General General Configuration
Slave Address [1..247] 1
Madbus Slave Channel | E
Response Timeout [ms] | 1000 E
Modbus Slave Init
Device Type Standard Modbus Devices b

Status

Information

For more information, see Modbus COM Settings.

6.1.4 Set up Modbus TCP Topology
Use the following steps to set up Modbus TCP Topology.
To set up Modbus TCP Topology
1. On the Devices pane, double-click Network Configuration.
2. In Product List, select Fieldbuses > Modbus TCP > one of the devices.
3. Drag the device to Network Configuration Editor.
4. Connect the slave device to the Modbus TCP line.

5. Right-click the controller and then select Set As Master/Scanner > Port x :
ModbusTcp to set the controller as Modbus TCP master.
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() Delta_LocaBus._Master_t (Delta LocalBus Master)
() EtherCaT_1 (AX Series EtherCAT Mster Softotion)
=[] ethernet_t (Ethemet)
= T Delta_Modous TCP_Master_1 (Delta Modbus TCP Master)
(f) velta_Modous TCP_Sive._t (Delta Modbus TCP Siave)
% Softhotion General Axs ool

Ethernet_1

Devices v 3 X||/lg] MotonPRG )"A Network Configuration Editor X v \mmaﬁm v A X
=4 ntteds MIITR] =
et 43 o *
= Controler_t (Ax-308EAOMAIT) Sting for a full text search
o8 Hardware Configuration [ EtherCAT
= & NebiorkConfuration :Mwwﬂcmsm»m:n? All Vendors n
Modbus )
i Em”:::; (7] Display Al Versions
EtherNetP Topology
A
2 :C ’l’“’"‘“” b @‘V Product List
g O.\:ucaﬁon ¢ | W PLOs
mmayManaga 4 O Fieldbuses
18 oo, 85 686) I O EtherCAT
%] PLC_PRG (PRG) I G EtherNetIP
= (&4 Task Configuration
= EtherCAT Task (EC-Tasks) I G Modbus
8] Moton PRG 4 O Modbus TCP
= & Mansk (ECTests) + Della Modbus TCP Sive
@ﬂ:;fs*(ﬁc ) @ Modbus TCP Slave
¥ Tas T
= suitinJ0 (uittn 10)
@ oo pr0)

Ostalloza
TCPSae
Deita

Modbus
TCP Slave

Version: 1.0.5.0
aModbus TCP Master.

A generic Modbus device that is configured as Slave for

6. Double-click the slave device to open the parameter page to set Modbus TCP

parameters.

General

Maodbus Slave Channel

Madbus Slave Init

Delta Modbus TCP Slave IEC
Objects

Status

Information

General Configuration

Slave Address [0..247]

Response Timeout [ms] |1000

Port
Device Type
IP Address

Auto-Reconnect

+
<
]

Standard Modbus Devices ~

168

For more information, see Modbus TCP Settings.

6.1.5 Set up EtherNet/IP Topology

Use the following steps to set up EtherNet/IP Topology.

To set up EtherNet/IP Topology
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1. On the Devices pane, double-click Network Configuration.

2. In Product List, select Fieldbuses > EtherNet/IP > one of the devices.
3. Drag the device to Network Configuration Editor.
4. Connect the slave device to the EtherNet/IP line.

5. Right-click the controller and then select Set As Master/Scanner > Port x :
EtherNet/IP to set the controller as EtherNet/IP master.

Devices v A X @ Motion PRG ' A, Network Configuration Editor X v} Product List Editor v AaXx
=4 et MITCRON N A vrven *
= (f controker_t (X-306€AMAIT) Sting fora full 1 search
o8 Hardware Configration EtherCAT
= A lebwrkCofoatin I VodbusTCPEertet AlVendors 7]
Il Modbus
A EberCAT Topdogy (7] Display Al Versions
A\ EtherNetlP Topdogy N
. A ModbusTCP Topoogy @\ﬂ" Product List
= EJY PLCLogic &
; ¢ )
= ©) Aopcatn W PLCs
i oy Manager 4 Oy Fieldbuses
3
9] Motin PRG PR6) I @ EtherCAT
@ PLC PRG (PRG) ALJEAMATT -
@ - 0620 4 O EtherNetlP
= {24 Task Configuration MALT
= & BUPScomeIOTask (EC-Tasks) I & AHCPU
@) Etherlet IP_Scamer_110Cyde 4 G pSCPU
= & BUPSamersenviceTok (ECTodk) AS218PX
&) Etheret IP_Scamer_1.SenviceCyde W AS2IERK
=& EtherCAT Task (EC-Tasks)
&) oo 726 W AS218TX
=) ; W AS28P
v Wﬂ“k (ECTik) Ethernet_1
IR W AS2SR
= (f) euitinJo (uitin J0) 0 AS2287
@ oo (or0)
() Delta LocaBus Master_t (Dela LocaBus Mster) 0 ASI0ON
() EtherCAT_1 (A Seris EtherCAT Master Softotion) b W ASI2P
= (f) ethemet_t Ethemet) W AS3207
= ({) Ethertet IP_Scanner_1 (theret[P Scanne) - W AS324MT
Tl asaex 1 (as2160y) o
% Softoton Generl Ais ol W AS33ZP
W AS332T
I G VFD
QQ I O Modbus
§
;3‘\ Version: 1.0.0.1
EtherNetIP Target imported from EOS File:
031FO00E021400010001.eds Device: AS218PX
S S

6. Double-click the slave device to open the parameter page to set EtherNet/IP
parameters.
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| General
Connections
Assemblies
User-Defined Parameters
Log
EtherMet/IP If0 Mapping
EtherNet/IP IEC Objects
Status

Information

Address Settings

IP address 192 . 168 .

Electronic Keying

] Compatibility check

Vendor ID
Device type

Product code 533

Majorrevision |1

Minorrevision |1

.2

Check match
Check match
Check match
Check match

[] Check match

Ether\'et/IP

For more information, see EtherNet/IP Settings.

6.2 Communication Setting

How do | open the Communication Settings tab?

Communication Settings.

* On the Devices pane, double-click the controller and then go to

ScanNetwork | Gateway v Device v

Devices v & X|| /[ Controller_1 x
=) Untited? v
= controler_t (Ax-308EAOMAIT) ppCommuniction Settngs
8 Hardware Configuration o
=- A Network Configuration | Aepliciion
A EtherCaT Topdlogy Backup and Restore
A EtherNietlP Topology
A, ModbusTCP Topology
= 8l pLciogec
= Application Log
m Library Manager
8] motion PRG (PRG), PLC Settings
[8] pic_prG (PRG)
=@ Task Configuration PLC Shell
= ENIPScannerIOTask (IEC-Tesks) I
8) EtherNet IP_Scamner_110Cyde Licensed Software Metrics
= @ EﬁPScannerServwc:Task (IEC-Tasks) System Settings
@) EtherNet_IP_Scanner_1.ServiceCyde
= EtherCAT Task (EC-Task) Right Settings
8] Motion_PRG
= & MainTask (IEC-Tasks) System Parameters
@) e 6
= @ Builtn_IO (Buitin_IO) Task Deployment
@ oo (10) 1
() Delta_LocalBus_Master_1 (Delta LocalBus Master) Status
] EtherCAT_1 (AX Series EtherCAT Master SoftMoton) 1 :
= @ Ethernet_1 (Ethernet) Information
= ({) EtherNet_IP_Scanner_t (EtherNet/IP Scanner) L
[l s21spx 1 (as218e%)
3 SoftMotion General Axis Pool

Files —— o =.

.
Gateway .
V] [oosEsenens Y]
IP-Address: Press ENTER to set active path
localhost
Port:

1217

Settings tab.

The following table lists the functions and descriptions on the Communication
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Function

Description

Scan Network

Click to open the Select Device dialog that lists all configured

gateways and related devices. Select the target device from

the list to connect.

Gateway

* Add New Gateway: Click to open the Gateway dialog to

add a new gateway channel.

* Manage Gateways: Click to open the Manage Gate-

ways dialog with an overview of all gateways. You can

add, delete gateways, or change their order.

* Configure the Local Gateway: Click to open the Gate-

way Configuration dialog to configure the block drivers

for the local gateway.

Device

* Options

o

o

Add Current Device to Favorites: Select to add
the current device to the list of favorite devices.

Manage Favorite Devices: Select to open the
Manage Favorite Devices dialog. You can add,
delete favorite devices, or change their order in the
list. The first one is the default device.

Filter Network Scans by Device ID: Select to only
display devices with the same target ID when click-
ing Scan Network.

Confirmed Online Mode: For security reasons, se-
lect to show a confirmation dialog when calling the
following online commands: Force Values, Write
Values, Unforce All Values, Single Cycle, Start,
Stop.
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Function

Description

o Store Communication Settings in Project: Select
to save the communication settings in the project
for reuse on the same computer.

Note: If you use the project on another
computer, then you need to reset the active
path.

Rename Active Device: Click to open the Change De-
vice Name dialog to change the name of the currently
connected device.

Wink Active Device: Select to wink the active device.

Send Echo Service: Select to send five echo services
to the controller to test the network connection. The ser-
vices are sent first without a payload and then with a
payload. The scope of the payload depends on the com-
munication buffer of the controller.

Encrypted Communication: Select to encrypt the com-
munication to this controller. After encrypted, a certifi-
cate of the controller is required to log in to the con-
troller.

This function is unavailable if you select View >Security
Screen > Enforce encrypted communication.

6.2.1 Connect to a Controller

After setting up the communication, connect to the controller where the application

should run.

To connect to a controller

DIADesigner-AX Version 1.8.0

214



A hELTA Chapter 6: Network Configuration

1. On the Communication Settings tab, click Scan Network.
2. Inthe Select Device dialog, select the controller to connect and then click OK.
Or

1. Enter the target controller IP address (Example: 192.168.101.109), device
address (Example: [056D]), or device name (Example: My Device).

2. Press Enter.

Note: Searching by device name requires a unique name in the
network.

6.2.1.1 Connection Status

After logging in to the controller, you can view the connection status of the device on
the left side of the device in the project tree.

i : The device is connected and the application is running. Data exchanges if
Update 1/0 while in stop on the PLC Settings tab is selected.

e Z: The application is not running.
e = There were errors but are fixed now.

° ﬂ: The device is in preoperative mode and is not running yet. Diagnostic
information is available.

o A The device is not exchanging data; bus error, no configuration, or

simulation mode.

o : The device is running in demo mode for 30 minutes. After 30 minutes, the
demo mode will end and the fieldbus will end the data exchange.

£5: The device is configured but not operational. No data exchanges.
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i : Redundancy mode is active. The fieldbus master is not sending any data
because another master is active.

* -4 The device is running, but its child device is not. The child device is not
visible due to the collapsed device tree.

6.2.2 Modbus COM Settings
Use the following steps to add Modbus COM.
To add Modbus COM
1. On the Devices pane, right-click the controller, and then select Add Device.

2. Inthe Add Device dialog, select Fieldbuses > Modbus > Modbus Serial Port
> Delta Modbus COM (or Modbus COM).

3. Click Add Device.

6.2.2.1 Delta Modbus COM

How do | open the Delta Modbus COM page?

* On the Devices pane, double-click Modbus_X.

Supported controller:
e AX-3
e AX-5

* AX-C

AX-864E30CE2T, AX-864E30ME2T, AX-8H1E30CD2T, AX-8H1E30CD2P

The following table lists the settings and descriptions of Delta Modbus COM.

General
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{J Modbus_1 X
| General
Serial Port Configuration
Status
Port ID 1 v
Information
Port Type RS-485 v
Baud Rate 9600 v
Parity Even v
Data Bits 7 v
Stop Bits 1 N
Delay Time to
Send (ms) 0 @
Transmission Mode () RTU  (e) ASCII
Setting Description
Port ID Select a port ID.
Port Type Select RS-232 or RS-485 port.
Baud rate Select the tandem transmission rate (in bits/second).
Parity Select the parity bit usage in the communication packets.
Data Bits Select the number of bits of data per character.
For the AX-C controller, 7 is not available for None Parity.
Stop Bits Select the number of stop bits per character.

Delay Time to
Send (ms)

Select or enter the time to delay packet sending.

Transmission
Mode

Select the mode of transmission.
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Setting Description

* RTU: Transmission in binary.

* ASCII: Transmission in ASCII code (currently not sup-
ported by all drivers).

Status

([ Modbus_1 x v

General ModbusSerid : In/a

Status

Information

Shows the status of the Delta Modbus COM serial port.

Information

] Modbus_1 x

General

General

Name: Delta Modbus COM
Status Vendor: Delta Electronics, Inc.

Categories: Modbus Serial Port
Information Type: 40001

1D: 16F7 8702

Version: 1.0.0.2

Order number: -
Description: Delta serial port of Modbus

Shows the general information of Delta Modbus COM.

6.2.2.1.1 Delta Modbus Master COM Port

How do | open the Delta Modbus Master COM Port page?
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1. On the Devices pane, right-click Modbus_X, and then select Add Device.

2. Inthe Add Device dialog, select Fieldbuses > Modbus > Modbus Serial
Master > Delta Modbus Master COM Port, and then click Add Device.

3. On the Devices pane, double-click Delta Modbus Master COM Port_X.

Use the settings in the Delta Modbus Master COM Port_X page to configure the

port when the controller is used as the Modbus master station.

The following table lists the settings and descriptions of Delta Modbus Master COM

Port.

General

General

Mapping

Objects

Status

Information

(] Delta_Modbus_Master_COM_Port_1 X

DeltaModbusSerialMaster IJO

DeltaModbusSerialMaster IEC

General Configuration

Retry Count 3 4

Auto-Reconnect

Setting

Description

Retry Count

Select or enter the number of times of COM Port re-communi-
cation.

Auto-Reconnect

Select to automatically confirm the error and attempt to con-
tinue running the ModbusModbus command after an error oc-

curs.

Delta Modbus Serial Master 1/0 Mapping
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@ Delta_Modbus_Master_COM_Port_1 X
General Bus Cycle Options
| Bus cycle task mdbsComTask v Recreate required tasks

| DeltaModbusSerialMaster I/O

Mapping

DeltaModbusSerialMaster IEC

Objects

Status

Information

Setting Description

Bus cycle task Select a bus cycle task to synchronize with the Modbus com-

munication time.

Recreate required | Click to create a ModbusModbus COM task.
task

Delta Modbus Serial Master IEC Objects

@ Delta_Modbus_Master_COM_Port_1 X

General dk Add... [# Edit.. < Delete ” Go to Variable
DeltaModbusSerialMaster /0 Variable Mapping  Type

Mapping _ @ Delta_Modbus_Master... ) DFB_ModbusComMaster
DeltaModbusSerialMaster EC

Objects

Status

Information

Configure the variable information of Delta Modbus Master COM Port. In the online
mode, this is used as the monitoring view.

Status
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ﬂ’j Delta_Modbus_Master_COM_Port_1 X

General

‘ DeltaModbusSerialMaster I/0
Mapping

DeltaModbusSerialMaster EC
Objects

Status

Information

’ DeltaModbusSerialMaster

nfa

Shows the execution status of Delta Modbus Master COM Port.

Information

General

DeltaModbusSerialMaster If0
Mapping

DeltaModbusSerialMaster IEC
Objects

Status

I Information

({] Delta_Modbus_Master_COM_Port_1 X

General

Name: Delta Modbus Master COM Port

Vendor: Delta Electronics, Inc.

Categories: Modbus Serial Master

Type: 40001

ID: 16F7 8705

Version: 1.0.5.0

Order number: -

Description: Delta Serial Port Setting of Modbus Master

Shows the general information of Delta Modbus Master COM Port.

Note:

* Each ModbusModbus Serial Port can add one ModbusModbus Master

COM Port, and each ModbusModbus Master COM Port can add 32
ModbusModbus Slave COM Ports.

* Up to 32 Modbus Slave COM Port with RS232 can be added. RS232
only supports 1-to-1 communication, so only the first Modbus Slave
COM Port can be used. RS485 is without this limitation.
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6.2.2.1.2 Delta Modbus Slave COM Port

How do | open the Delta Modbus Slave COM Port page?

1. On the Devices pane, right-click Delta Modbus Master COM Port_X, and then

select Add Device.

2. Inthe Add Device dialog, select Fieldbuses > Modbus > Modbus Serial
Slave > Delta Modbus Slave COM Port, and then click Add Device.

3. Double-click Delta Modbus Slave COM Port_X.

Use the settings in Delta Modbus Slave COM Port_X page to configure the slave

station to be connected when the controller is used as the Modbus master station.

The following table lists the settings and descriptions of Delta Modbus Slave COM

Port.
General
(] Delta_Modbus_Slave_COM_Port_1 X
General General Configuration
Slave Address [1..247] \1 E]
Modbus Slave Channel
Response Timeout [ms] {1000 E]
Modbus Slave Init
Device Type Standard Modbus Devices v
DeltaModbusSerialSlave IEC
Objects
Status
Information
Setting Description

Slave Address
[1..247]

Select or enter the slave station number.

Response Timeout
[ms]

Select or enter the time interval for the master to wait for the
response from a slave node. This is configured especially for
this slave node and overwrites the general response timeout
setting of the respective master.
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Setting Description

Device Type Select the device type.

You can select standard Modbus devices or Delta devices. If
you select Delta devices, the system converts the protocol in-
to Modbus protocol automatically so that you do not need to
see the register map for the conversion.

Modbus Slave Channel

General Name Access Type Trigger READ Offset Length Error Handling WRITE Offset Length

Modbus Slave Channel

Modbus Slave Init

DeltaModbusSerialSlave IEC
Objects

Status

Information

Move Up Move Down Add Channel... Delete... Edit...

@ Delta_Modbus_Slave_COM_Port_1 X v

Add slave channels. Each channel represents a single Modbus request. You can
create up to 10 channels for each slave. The controller will send out Modbus request
packets in the chronological order. All channels share the same Modbus connection.

Click Add Channel to open the Modbus Channel dialog. The following table lists
the settings and descriptions.

Modbus Channel
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1%

Enable

Remote Device Settings

Channel Mame Item 1
Slave Address [1..240] 1
Device Type Standard Modbus Devices |v
Read
Access Type Read Coils L]
* Device Address OxD
Length 1

Write

Access Type Write Single Coi hd

* Device Address 0x0

Setting Description
Enable Select to turn on the data exchange channel.
Name Enter the name of the channel.

Access Type Select the access type.
Trigger Select the trigger.

* Cyclic: The request occurs periodically according to the
cyclic time set.

* Rising edge: The request occurs as a reaction to a rising
edge of the Boolean trigger variables. The trigger vari-
able is defined in the 1/0O Mapping.

* Application: The request is triggered by the Modbus
COM Channel function block.

Comment Enter notes for the channel.
Device Address Enter the device address in the hexadecimal format.
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Setting Description
Length Enter the word length that reads or writes from or to the regis-
ter. The value varies with different Access Type and Device
Address.
Error Handling Select the option when communication error occurs.

Modbus Slave Initialization
-_1 Delta_Modbus_Slave_COM_Port_1 X
General Line = Access Type WRITE Offset Default Value Length Comment
Modbus Slave Channel

Modbus Slave Init

DeltaModbusSerialSlave IEC
Objects

Status

Information

Add Channel...

After the Modbus connection between the controller and the slave devices is

established, you can click Add Channel to edit the Initialization Value of the Coil or
Register.

Access Type Write Coils hd
Device Address ¥ Coil ™ 0x0
Length 1
Initialization Value 0
Comment
QK Cancel

Delta Modbus Serial Slave 1/0 Mapping
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(@ Delta_tModbus_Slave_COM_Port_1 X

General Find

Filter Show all

v &k Add FB for 10 Channel... * Go to Instance

Variable
P %

Modbus Slave Channel

Modbus Slave Init

DeltaModbusSerialSlave /0
Mapping

DeltaModbusSerialSlave IEC
Objects

Status

Information

Mapping  Channel ~ Address  Type

Chamnel 0 %IB3 ARRAY [0..0] OF BYTE

Unit  Description
Read Colls

| Reset Mapping

Always updatevariables :Enabled 1 (use bus cyde task if not used in any task) v:

Set the mapping variable after the Modbus Slave Channel is added.

Delta Modbus Serial Slave IEC Objects

(7] Delta_Modbus_Slave_COM_Port_1 X |

General
Modbus Slave Channel

Modbus Slave Init

‘ DeltaModbusSerialSlave I/0
Mapping

gk Add... [# Edit... < Delete ~

Go to Variable

DeltaModbusSerialSlave IEC
Objects

Status

Information

Variable

@ Delta_Modbus_Slave_...

Mapping
K

Type
DFB_ModbusComSlave

Shows the variable information of Delta Modbus Slave COM Port.
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Status

//{f] Delta_Modbus_Slave_COM Port 1 x|

General

Acknowledge

Status

Information

DeltaModbusSerialSlave
Modbus Slave Channel Last diagnosticmessage
Modbus Slave Init Diagnosis Message:
' DeltaModbusSerialSlave /0
Mapping
' DeltaModbusSerialSiave IEC
Objects

Shows the execution status of Delta Modbus Slave COM Port.

Information

General
Modbus Slave Channel

Modbus Slave Init

DeltaModbusSerialSlave I/O
Mapping

| DeltaModbusSerialSlave IEC
Objects

Status

Information

(] Delta_Modbus_Slave_COM_Port_1 X

General

Name: Delta Modbus Slave COM Port

Vendor: Delta Electronics, Inc.

Categories: Modbus Serial Slave

Type: 40001

1D: 16F7 8706

Version: 1.0.5.1

Order number: -

Description: A generic Modbus device thatis configured as Slave for a Modbus COM Master.

The general information of Delta Modbus Slave COM Port.

6.2.2.1.3 Delta Modbus Serial Device

How do | open the Delta Modbus Serial Device page?

1. On the Devices pane, right-click Modbus_X, and then select Add Device.

2. Inthe Add Device dialog, select Fieldbuses > Modbus > Modbus Serial
Device > Delta Modbus Serial Device, and then click Add Device.
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Note: If Delta Modbus Master COM Port is added, you need to delete it
first then add Delta Modbus Serial Device.
3. On the Devices pane, double-click Delta Modbus Serial Device_X.

AX controllers can act as a Modbus Serial slave device after you add Delta Modbus
Serial Device and configure the related settings.

The following lists the settings and descriptions of Delta Modbus Serial Device.

General
({) Delta_Modbus_Serial_Device_1 X
General
Serial Port Settings
Delta Modbus Serial Slave Device
1/0 Mapping COMID 1 F
Status
Information Address Information Settings
Holding Register Coils
%W [0 Bl wnw o H
S%LMW Quantity 10 K %MW Quantity o F
Modbus Start Address [0 E Modbus Start Address loigi
Holding Register Coils
%QW o Bl waw lo B
%QW Quantity [0 B %qwquantty 10 H
Modbus Start Address [256 ] Modbus start Address (256 Bl
Input Register Discrete Inputs
%W o Bl ww o Bl
%IW Quantity 10 Bl o quantity [10 B
Modbus Start Address [0 E Modbus Start Address IO E]

Select and enter the station number of the controller and the allowed Coils or
Registers section. If Modbus Serial Master uses Delta specific communication
protocol, all sections can be accessed without restrictions.

Delta Modbus Serial Slave Device I/O Mapping
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(] Delta_Modbus_Serial_Device_1 X

General Bus Cycle Options

Bus cycle task mdbsComTask v Recreate required tasks
Delta Modbus Serial Slave Device
1/0 Mapping
Status

Information

Setting Description

Bus cycle task Select a bus cycle task to synchronize with the Modbus com-
munication time.

Recreate required | Click to create a Modbus COM task.
task

Status

[{ Delta_Modbus_Serial_Device_1 X

|
Genera Delta Modbus Serial Slave Device In/a

Delta Modbus Serial Slave Device
1/0 Mapping

Status

Information

Shows the execution status of Delta Modbus Serial Device.

Information

ﬂ’j Delta_Modbus_Serial_Device_1 X

General

General
Name: Delta Modbus Serial Device
Bgﬁ:;‘:)?:;s Serial Slave Device Vendor: Delta Electronics, Inc.
Categories: Modbus Serial Device
Status Type: 40001
ID: 16F7 8703
Information Version: 1.0.4.3

Order number: -
Description: Delta Serial Port Setting of Modbus Slave

Shows the general information of Delta Modbus Serial Device.

DIADesigner-AX Version 1.8.0 [ZE]



A hELTA Chapter 6: Network Configuration

6.2.2.2 Modbus COM

How do | open the Modbus COM page?

1. On the Devices pane, right-click the AX-8 controller, and then select Add
Device.

2. Inthe Add Device dialog, select Fieldbuses > Modbus > Modbus Serial Port
> Modbus COM, and then click Add Device.

3. On the Devices pane, double-click Modbus_X (Modbus COM).

Supported controller:

* AX-8 Windows Series

* AX-8 Linux Series

The following tables list the settings and descriptions of Modbus COM.

General
(] Modbus_1 x
General Serial Port Configuration
SerialPort Parameters COM port ! :
Baud rate 9600 v
Status
Parity EVEN v
Information Data bits
Stop bits
Setting Description
COM port Select or enter a port ID.
Baud rate Select the baud rate (in bits/second).
Parity Select the parity bit usage in the communication packets.
Data bits Enter the number of bits of data per character.
Stop bits Enter the number of stop bits per character.

Serial Port Parameters

DIADesigner-AX Version 1.8.0 SN



A NELTA

Chapter 6: Network Configuration

({J Modbus_1 x|
General Parameter Type Value  Default Value Unit  Description
SeialPortP # Baudrate  Enumeration of UDINT 9600 9600 Baudrate of the serial port.
eralport Parameters # Parity Enumeration of STRING EVEN' 'EVEN' Parity for messages on the serial port.
Status ¥ DataBits  USINT 8 8 Number of data bits
| % Stopkits ~ USINT 1 1 Number of stop bits
Information % ComPort  USINT 1 1 COM port number to use for the serial communication
L
Edit the parameter information.
Status
() Modbus_1 x| v
e Seraot s |
SerialPort Parameters
PCLBus s |
Status
Information

Shows the status of the Modbus COM serial port.

Information

General

Status

Information

]ﬁ Modbus_1 X

SerialPort Parameters

General

Name: Modbus COM
Vendor: 35 - Smart Software Solutions GmbH
Categories: Modbus Serial Port

Type: 92

ID: 00000001

Version: 4.1.0.0

Order number: -

Description: A serial COM Port on a Windows PC.

Shows the general information of Modbus COM.

6.2.2.2.1 Modbus Master COM Port

How do | open the Modbus Master COM Port page?
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1. On the Devices pane, right-click Modbus_X(Modbus COM), and then select

Add Device.

2. Inthe Add Device dialog, select Fieldbuses > Modbus > Modbus Serial
Master > Modbus Master, COM Port, and then click Add Device.

3. On the Devices pane, double-click Modbus Master COM Port_X.

Use the settings in Modbus Master COM Port_X page to configure the port when

the controller is used as the Modbus master station.

The following table lists the settings and descriptions of Modbus Master COM Port.

General

General

ModbusGenericSerialMaster I/0
Mapping

ModbusGenericSerialMaster IEC
Objects

Status

Information

{J Modbus_Master_COM_Port_1 X

Modbus RTU/ASCII

Transmission mode @ RTU O ascI ]
Response timeout(ms) '1000 |
Time between frames (ms) '10

[] Auto-restart communication

Setting

Description

Transmission
mode

Select the mode of transmission.

* RTU: Transmission in binary.

* ASCII: Transmission in ASCII code (currently not sup-
ported by all drivers).

Response timeout
(ms)

Enter the interval that the master waits for the answer from a
slave. If the slaves do not answer within this interval, an error
will be recorded for the implicit slave function block. The value
entered for the time interval is also the default value for each
slave if no specified value is set.
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Setting Description
Time between Enter the master’s pause sending time between the last re-
frames (ms) sponse (and a timeout) and the next request. Use this para-

meter to make the communication less liable to disruption.

Auto-restart com- | Select to automatically confirm the error and restart the com-
munication munication after an error occurs.

Modbus General Serial Master 1/0 Mapping

() Modbus_Master_COM_Port_1 x
General ’ Bus Cyde Options
| Bus cycle task Use parentbus cyde setting v Recreate required tasks
ModbusGenericSerialMaster I/0
Mapping
ModbusGenericSerialMaster IEC
Objects
Status
Information
Setting Description
Bus cycle task Select a bus cycle task to synchronize with the Modbus com-
munication time.

Modbus Serial Master IEC Objects

() Modbus_Master_COM_Port_1 X

General db Add... [# Edit... < Delete " Go to Variable
ModbusGenericSerialMaster I/0 Variable Mapping  Type

plapping ||~ @ Modbus_Master_COM... @ IoDrvModbusComPort
ModbusGenericSerialMaster IEC

Objects

Status

Information

Show the variable information of Modbus Master COM Port.

Status
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(fJ Modbus_Master_COM_Port 1 X v
General o )

ModbusGenericSerialMaster: |n/a I
ModbusGenericSerialMaster 1/0
Mapping ModbusSeria : In/a l

ModbusGenericSerialMaster IEC
Objects

Status

Information

Shows the execution status of Modbus Master COM Port.

Information

([ Modbus_Master_COM_Port_1 X

General General

Name: Modbus Master, COM Port

m:gsil:]ngenericSeriaIMaster 1o Vendor: 35 - Smart Software Solutions GmbH
Categories: Modbus Serial Master
ModbusGenericSerialMaster IEC Type: 90
ORiscts 1D: 0000 0002
Status Version: 4.3.0.0
Order number: -

Information Description: A device that works as a Modbus Master on a serial COM Port of a Windows PC.

Shows the general information of Modbus Master COM Port.

6.2.2.2.2 Modbus Slave COM Port
How do | open the Modbus Slave COM Port page?

1. On the Devices pane, right-click Modbus Master COM Port_X and select Add
Device.

2. Inthe Add Device dialog, select Fieldbuses > Modbus > Modbus Serial
Slave > Modbus Slave , COM Port and then click Add Device.

3. On the Devices pane, double-click Modbus Slave COM Port_X.

Use the settings in Modbus Slave COM Port_X page to configure the slave station
to be connected when the AX-8 series controller is used as the Modbus master
station.

The following table lists the settings and descriptions of Modbus Slave COM Port.

General
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| General
Modbus Slave Channel
Modbus Slave Init
Objects
Status

Information

-_"j Modbus_Slave_COM_Port_1 X

ModbusGenericSerialSlave IEC

Modbus RTU/ASCIT

Slave address [1..247] ,1

Response timeout (ms) ,1000

Setting

Description

Slave address
[1..247]

Enter the address of a serial Modbus device.

[ms]

Response timeout

Enter the time interval for the master to wait for the response
from the slave. This timeout value is configured for this slave
and overwrites the general response timeout setting of the

(@ Modbus_Slave_COM_Port_1 x =
General Name Access Type Trigger READ Offset Length  ErrorHandling  WRITE Offset Length  Comment
0 Channel0  Read Holding Registers (Function Code 03)  Cydic, t#100ms 1620000 1 Keep last value
Modbus Slave Channel
Modbus Slave Init
| ModbusGenericserialsiave /o
Mapping
| ModbusGenericserialslave IEC
Objects
Status
Information
L
Move Up

Move Dovin Add Channel.. Delete Edit...

Add slave channels. Each channel represents a single Modbus request.

Click Add Channel to open the Modbus Channel dialog. The following table shows

the settings and descriptions.
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Channel

Name Channel 1 |

Access type Read Holding Registers (Function Code 3) ~

Trigger Cydlic ~ | Cycle time (ms) 100

Comment | |

READ Register

Offset [oxoo00 |

Length

Error handling Keep last value ~

WRITE Register

Offset 0x0000

Length 1

Cancel
Setting Description

Name Enter the name of the channel.
Access type Select the access type.
Trigger Select the trigger.

* Cyclic: The request occurs periodically according to the
cyclic time set.

* Rising edge: The request occurs as a reaction to a ris-
ing edge triggered by the Boolean variables. The trigger
variable is defined in the 1/0O Mapping.

* Application: The request is triggered by the Modbus
COM Channel function block.

Cycle time (ms) Enter the cycle time when the trigger is Cyclic.
Note: The request interval should be the same or a
multiple of the cycle time of the application.
Comment Enter the description of the channel.
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Setting Description
Offset Enter the start address where reading should start (value
range 0-65535).
Length Enter the word length that reads or writes from or to the regis-

ter. The value varies with different Access Type and Device
Address.

Error handling

Select the option when a communication error occurs.

Modbus Slave Initialization

General
Modbus Slave Ch,

Modbus Slave Ini

ModbusGenericS
Mapping

| ModbusGenerics:
Objects

Status

Information

(@ Modbus_Slave_COM_Port_1 x

annel

it

erialSlave /O

erialSlave IEC

Line  Access Type

WRITE Offset Default Value  Length ~ Comment

Move Up

Move Down Nevi... Delete Edit...

After the Modbus connection between the controller and the slave devices is

established, you can click New to edit the Initialization Value of the Coil or Register.

Length
Initializ

Comme

Access type

Register offset

ation value

nt

Write Multiple Registers (Function Code 16) w

|nxnnnn v |

1

II

=

Modbus Generic Serial Slave I/0 Mapping
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@ Modbus_Slave_COM_Port_1 X -

General | Find Filter Show all ~ dk Add FB for 10 Channel... ™ Go to Instance

Variable Mapping  Channel  Address  Type Unit  Description
M Channel 0 %IW0 ARRAY [0..0] OF WORD Read Holding Registers

Modbus Slave Channel

Modbus Slave Init

ModbusGenericSerialSlave [/O
Mapping

ModbusGenericSerialSlave IEC
Objects

Status

Information

| Reset Mapping Alwiays updatevariables |Use parent device setting v

Set the mapping variable after Modbus Slave Channel is added.

Modbus Generic Serial Slave IEC Objects

@ Modbus_Slave_COM_Port_1 X

General ok Add... [ Edit... < Delete ” Go to Variable
Variable Mappin: Type
Modbus Slave Channel EP 9| YP
@ Modbus_Slave_COM_... @ ModbusSlaveComPort

Modbus Slave Init

ModbusGenericSerialSlave I/O
Mapping

ModbusGenericSerialSlave IEC
Objects

Status

Information

Shows the variable information of Modbus Slave COM Port.

Status

ﬁi Modbus_Slave_COM_Port_1 X | -
| ~
cerers ModbusGenericSerialSlave © /2
Modbus Slave Channel Last disgnosticmessage Acknovledge
Modbus Slave Init Slave Diag
= IStave Request Counter
ModbusGenericSerialSlave /O
Mapping Error Counter
+
ModbusGenericSerialSlave IEC LastError
Objects
Status

Information

Shows the execution status of Modbus Slave COM Port.

Information
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@ Modbus_Slave_COM_Port_1 X

General General
Name: Modbus Slave, COM Port
Modbus Slave Channel Vendor: 35 - Smart Software Solutions GmbH
Categories: Modbus Serial Slave
Modbus Slave Init Type: 91
1D: 00000001
ModbusGenericSerialSlave /0 Version: 4.1.0.0
Mapping Order number: -
ModbusGenericSerialSlave IEC Description: A generic device that works as a Modbus Slave on a serial bus.
Objects Configuration version: 3.5.3.0
Status

Information

Shows the general information of Modbus Slave COM Port.

6.2.2.2.3 Modbus Serial Device
How do | open the Modbus Serial Device page?

1. On the Devices pane, right-click Modbus_X (Modbus COM), and then select
Add Device.

2. In the Add Device dialog, select Fieldbuses > Modbus > Modbus Serial
Device > Modbus Serial Device, and then click Add Device.

3. On the Devices pane, double-click Modbus Serial Device_X.

The AX-8 controller can act as a Modbus Serial Slave device after you add Modbus
Serial Device and configure the related settings.

The following table lists the settings and descriptions of Modbus Serial Device.

General
-_(-j Modbus_Serial_Device_1 X
General
Unit ID 1 =
Modbus Serial Device I/O Mapping [] watchdog 500 s
Modbus Serial Device IEC Objects Holding registers 10 3 (%IW) [] writeable
Status Input registers 10 2 (%QW)
Information [[] Discrete Bit Areas
Coils 0 s (%)
Discrete Inputs 0 S (%QX)
StartAddresses
Coils 0 =
Discreteinputs 0 =
Holding register 0 =
Input register 0 2
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Setting Description
Unit ID Select or enter the unit ID of the slave device.
Watchdog Select to activate the watchdog function.

The incoming data (Holding Registers / %l range) is set to ze-
ro when the Modbus device does not receive any valid query
from the master.

* Holding registers (%IW): Select or enter the number of
holding registers. The value range is 1-4096.

* Writable: Select to generate writable I/O mappings
(% QW addresses) instead of read-only I/O mappings
(%IW addresses). This option allows the holding regis-
ters to be set by the Modbus device application (servo
application) though the usual I/O mapping.

* Input registers (%QW): Select or enter the number of
input registers. The value range is 1-4096.

Discrete Bit Areas

Select to enable the discrete input and enter the value for:
* Coils

* Discrete Inputs

Start Address

Select or enter values for:

* Coils

* Discrete inputs

* Holding register

* Input register

Modbus Serial Device I/O Mapping
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ﬁi Modbus_Serial_Device_1 X

General ’ Find

Filter Show all

~ dk Add FB for [0 Channel...

Go to Instance

Variable
I S ]
Modbus Serial Device IEC Objects + "y

Modbus Serial Device 1/0 Mapping

Status

Information

Mapping ~ Channel
Holding Registers  %IW0
%QW0

Address  Type

Input Registers

ARRAY [0..9] OF WORD
ARRAY [0..9] OF WORD

Uit Description

Reset Mapping

¥4 = Create new variable

Bus Cyde Options
Bus cycle task

" =Mapto existing variable

[Use parentbus cyde setting Recreate required tasks

Always updatevariables ste parent device setting 9|

Set the mapping variable after Modbus Slave Channel is added.

Modbus Serial Device IEC Objects

() Modbus_serial_Device_1 x

General

Modbus Serial Device I/0 Mapping

Modbus Serial Device IEC Objects

Status

Information

ok Add... [ Edit.. < Delete " Go to Variable

Variable Mapping  Type
% Modbus_Serial_Device_1 ) )

IoDrvModbusSerialSlave

Shows the variable information of Modbus Serial Device.

Status

({J Modbus_Serial_Device_1 x

General
Modbus Serial Device I/O Mapping

Modbus Serial Device IEC Objects

Status

Information

Modbus Serial Device ln/a

Shows the execution status of Modbus Serial Device.

Information
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@ Modbus_Serial_Device_1 X
' General General
Modbus Serial Device I/0 Mapping
Modbus Serial Device IEC Objects

Status

Information

Name: Modbus Serial Device

Vendor: 35 - Smart Software Solutions GmbH

Categories: Modbus Serial Device

Type: 94

1D: 0000 0001

Version: 4.2.0.0

Order number: -

Description: A device that works as a Modbus Serial standalone slave.
Configuration version: 3.5.5.0

Shows the general information of Modbus Serial Device.

6.2.3 Modbus TCP Settings

How do | open the Ethernet page?

1. On the Devices pane, right-click the controller and select Add Device.

2. In the Add Device dialog, select Fieldbuses > Ethernet Adapter > Ethernet,
and then click Add Device.

The following tables list the settings and descriptions of Ethernet.

General
[{) Ethernet_1 x
General
Network interfface  |GLAN1 Browsse...
Ethernet Device /O Mapping
Ethernet Device IEC Objects
Log
Status
Information
Setting Description

Network interface | Shows the current controller's network interface name. Click
Browse to select other communication interface. Only avail-
able when going online.

Note: For AX-8 controllers, if there are two Ether-

CAT nodes in the project tree (the network interface
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Setting Description

R GLANT1 is used), and you add an Ethernet node, its
network interface name is GLAN2 by default.

Ethernet Device 1/0 Mapping

({) Ethernet_1 x
General Bus Cyde Options
| Bus cycle task Use parent bus cyde setting v Recreate required tasks
Ethernet Device /0 Mapping
Ethernet Device IEC Objects
Log

Status

Information

Setting Description

Bus cycle task Select a bus cycle task to synchronize with the Modbus com-
munication time.

Ethernet Device IEC Objects

[{) Ethernet_1 x

General ok Add... Edit.. < Delete * Go to Variable

Variable Mapping  Type
Ethernet Device I/O Mapping
@ Ethernet_1 & IoDrvEthernet
Ethernet Device IEC Objects
Log

Status

Information

Shows the variable information of Ethernet.

Log

DIADesigner-AX Version 1.8.0 [AS]



A AELTA Chapter 6: Network Configuration

[ Ethernet_1 x v
General T 2 3 38 [®o]Oo |‘§‘0 ©0|(®0 | Searchin messages 9\ O\‘ [J utC Time [lap ]
Severity Time Stamp Description Component

Ethernet Device I/O Mapping

Ethernet Device IEC Objects

Log

Status

Information

Shows logs of the communication.

Status

(7 Ethernet_1 x v
A
Seen! Ethernet Device : [n/a
Ethernet Device /0 Mapping Last diagnostic message Acknowledge
Ethernet Device IEC Objects EthDiag
CurrentIP
Log Current subnet mask
Current gateway address
Status IP changes
Information

Shows the status of the Ethernet device, for example, the Running or Stopped
status.

Information

-_T-] Ethernet_1 X

General General
Name: Ethernet
Ethernet Device I/O Mapping Vendor: CODESYS
Categories: Ethernet Adapter, Ethernet Adapter, Ethernet Adapter, Home&Building Automation
Ethernet Device IEC Objects Type: 110
1D: 0000 0002
Log Version: 4.2.0.0
Order number: -
Status Description: Ethernet Link.

Information

The general information of Ethernet.

6.2.3.1 Delta Modbus TCP

This section introduces Delta Modbus TCP device configuration.
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Supported controller:

* AX-3

* AX-5

* AX-C

AX-864E30CE2T, AX-864E30ME2T, AX-8H1E30CD2T, AX-8H1E30CD2P

6.2.3.1.1 Delta Modbus TCP Master
How do | open the Delta Modbus TCP Master page?

1. On the Devices pane, right-click Ethernet_X(Ethernet), and then select Add
Device.

2. Inthe Add Device dialog, select Fieldbuses > Modbus > Modbus TCP
Master > Delta Modbus TCP Master, and then click Add Device.

3. On the Devices pane, double-click Delta Modbus TCP Master_X.

Use the settings in the Delta Modbus TCP Master_X page to configure the port
when the controller is used as the Modbus TCP master station.

Delta Modbus TCP Master I/0O Mapping

] Delta_Modbus_TCP_Master_1 X
Delta Modbus TCP Master I/O Bus Cyde Options
Mapping S
Bus cycle task mdbsEtherTask v Recreate required tasks
Delta Modbus TCP Master IEC
Objects
Status
Information
Setting Description
Bus cycle task Select a bus cycle task to synchronize with the Modbus com-
munication time.
Recreate required | Click to create a Modbus EtherNet task.
tasks
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Delta Modbus TCP

Master IEC Objects

Delta Modbus TCP Master I/O
Mapping

Delta Modbus TCP Master IEC
Objects

Eij Delta_Modbus_TCP_Master_1 X

gk Add... [# Edit... < Delete

Go to Variable

| Variable
¢ Delta_Modbus_TCP_M...

Mapping

Type

) DFB_ModbusTCPMaster

Status

Information

Shows the variable information of Delta Modbus TCP Master.

6.2.3.1.2 Delta Modbus TCP Slave
How do | open the Delta Modbus TCP Slave page?

1. On the Devices pane, right-click Delta Modbus TCP Master_X, and then
select Add Device.

2. Inthe Add Device dialog, select Fieldbuses > Modbus > Modbus TCP Slave
> Delta Modbus TCP Slave, and then click Add Device.

3. On the Devices pane, double-click Delta Modbus TCP Slave_X.

Use the settings in the Delta Modbus TCP Slave_X page to configure the slave
station to be connected when the controller is used as the Modbus TCP master
station.

The following table lists the settings and descriptions of Delta Modbus TCP Slave.

General

() Delta_todbus_TCP_Slave_1 X

General General Configuration

Slave Address [0..247] .0 E
Modbus Slave Channel ‘

Response Timeout [ms] |1000 E
Modbus Slave Init i

Port 502 4

Delta Modbus TCP Slave IEC

Objects Device Type Standard Modbus Devices ¥

Status 1P Address 192 , 168, 1 . 1

Information Auto-Reconnect
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Setting

Description

Slave Address
[0..247]

Select or enter the slave station number.

[ms]

Response Timeout

Select or enter the time interval for the master to wait for the

response from a slave node. This setting is configured espe-
cially for this slave node and overwrites the general response
timeout setting of the respective master.

Port

Select or enter the port number of the slave.

Device Type

Select the device type.

You can select standard Modbus devices or Delta devices.
When you select Delta devices, the system converts the pro-
tocol into Modbus protocol automatically so that you do not
need to see the register map for the conversion.

IP Address

Enter the IP address of the slave device.

Auto-Reconnect

Select to perform the reconnection after a timeout or error oc-
curs.

Modbus Slave Channel

‘ () Delta_Modbus_TCP_Slave_1 x

General

Modbus Slave Channel

Modbus Slave Init

Delta Modbus TCP Slave IEC
Objects

Status

Information

Name

Access Type Trigger READ Offset Length Error Handling WRITE Offset Length Comment

Move Down Add Chann Delete... Edit...

Add slave channels. Each channel represents a single Modbus request. You can

create up to 10 channels for each slave. The controller sends out Modbus request

packets in chronological order. All channels share the same Modbus connection.

Click Add Channel to open the Modbus Channel dialog. The following table lists

the settings and descriptions.
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Modbus Channel

& Modbus Channel X
[J enavle
Channe
Name Channe
Access Type Read/Write Multiple Registers v
Trigger Cyclic \/ 100 ms
Comment
Read Register
Device Address 0x0
@ Length 1
Error Handling Keep last Value 7
Write Register
Device Address 0x0
Length 1
OK Cancel
Setting Description
Enable Select to turn on the data exchange channel.
Name Enter the name of the channel.
Access Type Select the access type.
Trigger Select the trigger.

* Cyclic: The request occurs periodically according to the
cyclic time set.

* Rising edge: The request occurs as a reaction to a ris-
ing edge of the Boolean trigger variables. The trigger
variable is defined on the I/O Mapping tab.

* Application: The request is triggered by the Modbus
COM Channel function block.

Comment Enter notes for the channel.
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Setting

Description

Device Address

Enter the device address in the hexadecimal format.

Length

Address.

Enter the word length that reads or writes from or to the regis-
ter. The value varies with different Access Type and Device

Error Handling

Select the option when a communication error occurs.

Modbus Slave Initialization

() Delta_Modbus_TCP_Slave_1 x

General
Modbus Slave Channel

Modbus Slave Init

Delta Modbus TCP Slave [/0
Mapping

Delta Modbus TCP Slave IEC
Objects

Status

Information

Line  Access Type

WRITE Offset

Default Value

Length Comment

Move Up

Move Down

Add Chan ‘ Delete...

After the Modbus connection between the controller and the slave devices is

established, you can click Add Channel to edit Initialization Value of the Coil or

Register.

Access Type

Device Address

Length
Initialization Value

Comment

Write Coils

Y Coil “ [ 0x0

1
0

DK

Cancel

Delta Modbus TCP Slave 1/0 Mapping
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() Delta_Modbus_TCP_Slave_1 x -

General | Find Filter Show all ~ dk Add FB for 10 Channel... ** Go to Instance J
Modbus Slave Channel Variable Mapping  Channel Address  Type Unit  Description
] Channel 0 %IB3 ARRAY [0..0] OF BYTE Read Coils

Modbus Slave Init

Delta Modbus TCP Slave [/O
Mapping

Delta Modbus TCP Slave IEC
Objects

Status

Information

| Reset Mapping Alviays updatevariables |Enabled 1 (use bus cyde taskiif not used in any task) v

Set the mapping variable after adding channel in the Modbus Slave Channel.

6.2.3.1.3 Delta Modbus TCP Slave Device
How do | open the Delta Modbus TCP Slave Device page?

1. On the Devices pane, right-click Ethernet_X (Ethernet), and then select Add
Device.

2. Inthe Add Device dialog, select Fieldbuses > Modbus > Modbus TCP Slave
Device > Delta Modbus TCP Slave Device, and then click Add Device.

3. On the Devices pane, double-click Delta Modbus TCP Slave Device_X.

AX controllers can act as a Modbus TCP slave device after you add Delta Modbus
TCP Slave Device and configure the related settings.

The following tales lists the settings and descriptions of Delta Modbus TCP Slave
Device.

General
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() Delta_Modbus_TCP_Slave_Device_1 X

Information
Address Information Settings
Holding Register
%MW
%MW Quantity
Modbus Start Address
Holding Register
%QW
%QW Quantity
Modbus Start Address
Input Register
%IW
%IW Quantity
Modbus Start Address

| General
) General Configuration
Delta Modbus TCP Slave Device I/O
Mapping TCP Port >502
Status Station 1D o

B}

o [

o
[10
o

o
[10
[2s6

o
10
o

Coils
B S4tw o B
B %MW Quantity [10 B
E Modbus Start Address \D El
Coils
B %QW o B
B %QW Quantity 10 B
E Modbus Start Address [256 E
Discrete Inputs
5] %IW o B
B %IW Quantity 10 g
E Modbus Start Address [D E

Select or enter the TCP port, the controller station ID, and the allowed Coils or

Registers section. If Modbus Serial Master uses Delta-specific communication

protocol, all sections can be accessed without restrictions.

Delta Modbus TCP Slave Device I/O Mapping

() Delta_Modbus_TCP_Slave_Device_1 X
General Bus Cyde Options
Bus cycle task mdbsEtherTask v Recreate required tasks
Delta Modbus TCP Slave Device I/O
Mapping
Status
Information
Setting Description
Bus cycle task Select a bus cycle task to synchronize with the Modbus com-

munication time.

tasks

Recreate required | Click to create a Modbus Ethernet task.

6.2.3.2 Modbus TCP

This section introduces Modbus TCP device configuration for AX-8 series controllers.
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6.2.3.2.1 Modbus TCP Master

How do | open the Modbus TCP Master page?

1. On the Devices pane, right-click Ethernet_X, and then select Add Device.

2. Inthe Add Device dialog, select Fieldbuses > Modbus > Modbus TCP
Master > Modbus TCP Master, and then click Add Device.

3. On the Devices pane, double-click Modbus TCP Master_X.

Use the settings in the Modbus TCP Master_X page to configure the port when the
AX-8 is used as the Modbus TCP master station.

The following table lists the settings and descriptions of Modbus TCP Master.

General

[#) Modbus_TCP_Master_1 X
General

ModbusTCPMaster I/O Mapping
ModbusTCPMaster IEC Objects
ModbusTCPMasterParameters
Log

Status

Information

Modbus TCP
Response timeout (ms) (1000 5
Socket timeout (ms) 10

[J Auto-reconnect

MODBUS

Setting

Description

Response timeout
(ms)

Select or enter the interval that the master will wait for the an-
swer from a slave. If the slaves do not answer within this in-
terval, an error is recorded for the implicit slave function block.
The value entered for the time interval is also the default val-
ue for each slave if no specified value is set.

Socket timeout
(ms)

Select or enter the maximum time to wait for incoming TCP/IP
packages. The bus cycle task can be blocked during this time.

Auto-reconnect

Select to perform the reconnection after a timeout or error oc-
curs.

Modbus TCP Master I/O Mapping
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[{J Modbus_TCP_Master_1 X
General

ModbusTCPMaster I/0 Mapping
ModbusTCPMaster IEC Objects
ModbusTCPMasterParameters
Log

Status

Information

Bus Cycle Options

! Bus cycle task Use parent bus cyde setting v

Recreate required tasks

Setting

Description

Bus cycle task

munication time.

Select a bus cycle task to synchronize with the Modbus com-

6.2.3.2.2 Modbus TCP Slave

How do | open the Modbus TCP Slave page?

1. On the Devices pane, right-click Modbus TCP Master_X and select Add

Device.

2. Inthe Add Device dialog, select Fieldbuses > Modbus > Modbus TCP Slave
> Modbus TCP Slave, and then click Add Device.

3. On the Devices pane, double-click Modbus TCP Slave_X.

Use the settings in the Modbus TCP Slave_X page to configure the slave station to

be connected when the AX-8 series controller is used as the Modbus TCP master

station.

The following table lists the settings and descriptions of Modbus TCP Slave.

General
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() Modbus_TCP_Slave_1 x

Genen Modbus TCP

Modbus Slave Channel Slave IP address 92.188.0 .1 M@[@B“s
| Response timeout (ms 1000

Modbus Slave Init (ms)

ModbusTCPSlave Parameters

ModbusTCPSlave IEC Objects

Status

Information

Setting Description

Slave IP ad- Enter the IP address of the Modbus TCP slave device.

dress

Response Enter the time interval for the master to wait for the response from
timeout [ms] the slave. This timeout value is configured for this slave and over-
writes the general response timeout setting of the master.

Port Enter the port number of the Modbus TCP slave device.

Modbus Slave Channel

Efj Modbus_TCP_Slave_1 X -

General ' Name  Access Type Trigger READ Offset Length  ErrorHandling ~ WRITE Offset Length  Comment
Modbus Slave Channel ’
Modbus Slave Init

ModbusTCPSlave Parameters
ModbusTCPSlave IEC Objects

Status

Information

Move Up Move Down Add Channel... Delete Edit...

Add slave channels. Each channel represents a single Modbus request.
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Click Add Channel to open the Modbus Channel dialog. The following table lists

the settings and descriptions.

Channel

Mame Channel 1 |

Accesstype Read Holding Registers (Function Code 3) -
Trigger Cydic w | Cycle time {ms) 100
Comment | |

READ Register

Offset |0x0000 v

Error handling Keep last value ~

WRITE Register

Offset 0x0000

Length (|

Conce
Setting Description

Name Enter the name of the channel.
Access type Select the access type.
Trigger Select the trigger.

* Cyeclic: The request occurs periodically according to the
cyclic time set.

* Rising edge: The request occurs as a reaction to a ris-
ing edge triggered by the Boolean variables. The trigger
variable is defined on the I/O Mapping tab.

* Application: The request is triggered by the Modbus
Com Channel function block.

Cycle time (ms) Enter the cycle time when the trigger is Cyclic.
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Setting Description

Note: The request interval should be the same as or
a multiple of the cycle time of the application.

Comment Enter the description of the channel.

Offset Enter the start address where reading should start (value
range 0-65535).

Length Enter the word length that reads or writes from or to the regis-
ter. The value varies with different Access Type.

Error Handling Select the option when a communication error occurs.

Modbus Slave Initialization

() Modbus_TCP_Slave_1 x -

General Line  AccessType  WRITEOffset  DefaultValue  Length ~ Comment
Modbus Slave Channel
Modbus Slave Init
ModbusTCPSlave Parameters
ModbusTCPSlave IEC Objects
Status

Information

Move Up Move Down Delete Edit...

After the Modbus connection between the controller and the slave devices is

established, you can click New to edit the Initialization Value of the Coil or Register.
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Access type Write Multiple Registers (Function Code 16) ~

Register offset |nx|:u:|nn v

Initialization value

Comment |

Conce

Modbus TCP Slave Parameters

[ Modbus_TCP_Slave_1 X -
General Parameter Type Value Default Value Unit  Description
% NewChannelConfig BOOL true true Use the new Channel-Config format
Modble Savechand & Unit-D USINT 164FF 16+FF Unit-ID of the Device
Modbus Slave Init % ResponseTimeout DWORD 1000 1000 Maximum time for a Slave to respond in ms
% IPAddress ARRAY/[0..3] OF BYTE [192, 168, ... [192, 168, 0, 1] Configure IP Address of TCP SLave.
ModbusTCPSlave Parameters @ Port UINT 502 502 Port where the slave is listening
= @ Slave Diag Slave's diagnostic
ModbusTCPSlave IEC Objects % ComState Enumeration of UINT
@ Request Counter UDINT
Status @ Error Counter UDINT
= @ LastError
Information & Timestamp DATE_AND_TIME
[ & ChannelIndex ~ INT 1 1
) @ Error Code Enumeration of UINT UNDEFINED
% Configversion UDINT 1603050800

Set the parameter values of Modbus TCP Slave.

6.2.3.2.3 Modbus TCP Slave Device
How do | open the Modbus TCP Slave Device page?

1. On the Devices pane, right-click Ethernet_X(Ethernet), and then select Add
Device.

2. Inthe Add Device dialog, select Fieldbuses > Modbus > Modbus TCP Slave
Device > Modbus TCP Slave Device, and then click Add Device.

3. On the Devices pane, double-click Modbus TCP Slave Device X.

The AX-8 controller can act as a Modbus TCP Slave device after you add Modbus
TCP Slave Device and configure the related settings.
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The following table lists the settings and descriptions of Modbus TCP Slave Device.

General

General

Serial Gateway

Modbus TCP Slave Device I/O
Mapping

Modbus TCP Slave Device IEC
Objects

Status

Information

[} ModbusTCP_Slave_Device_1 X

Configured Parameters
1 [J watchdog 500 2| (ms) Close TCPsocket
Slave port 502 2| [ Bind to adapter
Holding registers 10 3 (%w) [ writeable
Input registers 10 | (%6QW)

[] Discrete Bit Areas

Coils 0 S| (%)
Discrete Inputs 0 S| (%QX)
Data Model
Startaddresses
Coils 0 =
Discreteinputs 0 =
Holding register 0 =
Input register 0 =

[] Holding- and input register data areas overlay

Setting

Description

Watchdog

Select to turn on the watchdog function.

The incoming data (Holding Registers / %l range) is set to ze-
ro when the Modbus device does not receive any valid query
from the master.

* Holding registers (%IW): Select or enter the number of
holding registers. The value range is 2—4096.

* Writable: Select to generate writable 1/0 mappings
(% QW addresses) instead of read-only I/O mappings
(%IW addresses). This option allows the holding regis-
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Setting

Description

ters to be set by the Modbus device (servo application)
through the usual I/O mapping.

* Input registers (%QW): Select or enter the number of
input registers. The value range is 2—4096.

Close TCP socket

Select to close the TCP socket.

Slave Port

Select or enter the slave port number.

Bind to adapter

Select to bind the server socket of the Modbus slave to the IP
address of the assigned Ethernet Adapter.

Discrete Bit Areas

Select to turn on the discrete input and enter the value for:

* Coils: Number of Modbus coils

* Discrete Inputs: Number of Modbus discrete inputs

Start addresses

Select or enter the start address of the respective Modbus da-
ta area:

* Coils

* Discrete inputs

Holding register

* Input register

Holding — and input
register data areas
overlay

Select to overlay the process image by the holding and input
register.

Serial Gateway
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) ModbusTCP_Slave_Device_1 X

General
Serial gateway active

Serial Gateway Com port 1

Modbus TCP Slave Device I/O
Mapping

Modbus TCP Slave Device IEC
Objects

Baud Rate [s600 v|

Status

Information

Setting Description

Serial gateway ac- | Select to turn on the TCP/RTU gateway.

tive
Com port Select or enter the COM port number used.
Baud Rate Select the transmission rate (in baud).

6.2.4 EtherCAT Settings

The configuration of EtherCAT modules is based on the device description files

for the master and slave devices employed and can be adapted in the project in
configuration dialogs. To make sure the most straightforward and most error-free
use possible, we recommend standard applications for activating the option of Auto
config master/slaves so that the majority of the configuration settings are done
automatically.

Note: The EtherCAT settings in this section do not apply to AX-300NAOPA1
and AX-324NAOPA1P.

6.2.4.1 EtherCAT Master Settings

How do | open the EtherCAT page?

* On the Devices pane, double-click EtherCAT_X.

General
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() EthercAT_1 x
General Autoconfi ter/s| ——h
| utoconfig master/slaves EthQTCAT‘-
Sync Unit Assignment EtherCAT NIC Settings
Overien Destination address(MAC) FE-FF-FF-FFFFFF Broadcast [_] Redundancy
Source address (MAC) 00-00-00-00-00-00 Select...
Log
Network name lECAT
EtherCAT 1/0 Mapping O Select network by MAC (@ Select network by name [[] Compare exact name
EHECATEE Dbreda 4 Distributed Clock 4 Options
Status Cycle time 2000 < s [[] Use LRW instead of LWR/LRD
. ‘ Sync offset oo N [[] Messages pertask
R i o [[] Automatically restartslaves
[ Sync window monitoring
Sync window 1 =T

For the details of the settings, see Tab: EtherCAT Master — General.

Sync Unit Assignment

Devices v & X|| @ ethercaT_1 x| -
=3 Untited1 [v|a
= () Controllr_t (AX-8xXEPO Linux M Series) Seceal DeviceName  Sync Unit
@ Hardware Configuration ) - Drive_1 default
= A Network Configuration Sync Unit Assignment
A, EtherCAT Topology o
A, EtherNetIP Topology
A, ModbusCOM Topology o5
A, ModbusTCP Topology
=80 PLC Logic EtherCAT /O Mapping
=€) Application
() Library Manager EtherCAT IEC Objects
[E] Motion_PRG (PRG)
= (& Task Configuration Status
= EtherCAT Task (IEC-Tasks)
Information
&) Motion_PRG
& MainTask (IEC-Tasks)
£ MainTa: a .
= (T EtherCAT_1 (AX-810EPO Series EtherCAT Master) — <A ekt s e
= () [rive_t (Delta ASDA-A3-E EtherCAT(CoE) Drive DML) ][ sync unit
H4 DML_Drive_ETC_Delta_ASDA_A3_1 (DML Drive_ETC, - default
=+ Modbus_1 (Modbus COM)
() Modbus_Serial_Device_1 (Modbus Serial Device)
=- (@ Ethemet_1 (Ethernet) o
< } >

For the details of the settings, see Tab: EtherCAT Master — Sync Unit Assignment.

Devices v & X|| /[f) EthercAT_1 x
=) Untitled? v/ A —
g u General Update Data Auto Update
=i Controller_1 (AX-8xXEPO Linux SM Series)
@ Hardware Configuration o Name Address Optional Enable Identification Identification Alias
& A Network Configurati Sync Unit Assignment.
letwork Configuration (d orive_t 1001 %] Configured Station Alias 1001
A, EtherCAT Topology Overview
A EtherNetIP Topology
A, ModbusCOM Topology Log
A ModbusTCP Topology
= [0 PLC Logic EtherCAT /O Mapping
= @ Application
) Library Manager EtherCAT IEC Objects
[£) Motion_PRG (PRG)
(& Task Configuration Status
=B EtherCAT Task (IEC-Tasks) —
@ Motion_PRG Information
& MainTask (IEC-Tasks)
= (1) [EtherCAT_1 (AX-8xXEPQ Series EtherCAT Master)
= ({ Drive_1 (Delta ASDA-A3-E EtherCAT(COE) Drive DML) i
K4 DML_Drive_ETC Delta_ASDA_A3_1 (DML _Drive_ETC,

You can set the alias address of all EtherCAT slaves offline. The following table lists
the settings and descriptions on the Overview tab.
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Setting

Description

Update Data

Click to refresh the status of all slaves. This option is only
available online.

Auto Update

Click to read all slaves cyclically. This option is only available

online.
Name Shows the device name.
Address Shows the EtherCAT address.
Optional Select to turn on Enable Identification and change the Iden-

tification option from Disable to others and turn on Optional
on the slave device’s configuration page. You can select the
header to configure for all slaves. The status of this option is
synchronized with that on the slave configuration page.

Enable Identifica-
tion

Select to change the Identification option from Disable to
others and show advanced settings on the slave device’s con-
figuration page. You can select the header to configure for all
slaves. The status of this option is synchronized with that on
the slave configuration page.

This column is hidden online.

Identification

Shows the default available setting under Identification on
the slave configuration page. You can click the field to select
other settings. Only available when Optional or Enable Iden-
tification is selected.

Alias

Click to select or enter the alias address of the slave.

State

Shows the current state of the slave devices. Only shows
when the controller is online.

* |INIT: The slave is in the initialization state.

* PREOP: The slave is in the "Pre-Operational" state.

* SAFEOP: The slave is in the "Safe-Operational" state.
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Setting Description

* OP: The slave is in the "Operational" state.

* BOOT: The slave is in the "Bootstrap" state.

* ERR: An error in the slave

* NO_COMM: No communication with the slave

* LNK_MIS: A connection to the slave is missing (Port =
A, B, C,orD).

* LNK_ADD: There is a connection to the slave (Port = A,
B, C, or D) but not configured in the project tree.

CRC Shows the number of CRC errors for each active port. Only
shows online.

[{ prive_1 x

General Address Additional

—
EtherCAT. ™

AutolInc address 0 S [ Expert settings
CoE Parameters

EtherCAT address 1001 B [ optional

Expert Process Data
Distributed Clock

Process Data
" Select DC DC-Synchronous v

Log Enable 4000 | sync unit eycle (us)
EtherCAT 1/0 Mapping Synco
Enable Sync 0
EtherCAT IEC Objects @ Syncunitcyde [y v 4000 sl cydetime (us)

Status O User-defined o s shifttime (us)

Syncl
Information
[J Enable Sync 1

x1 4000 = Cycle time (ps)

Shift time (ps)

Startup Checking Timeouts
DC Cyclic Unit Control: Assign to Local pC and Latch
Watchdog

Identification
Disabled

@ Configured station alias (ADO 0x0012) Value 1001

ADO (hex)

6.2.4.2 EtherCAT Slave Settings

How do | open the EtharCAT Slave page?
1. On the Devices pane, right-click EtherCAT _X, and then select Add Device.
2. Inthe Add Device dialog, select a device and then click Add Device.

3. Double-click the device in the project tree.
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Or
1. Scan the network and select a gateway.

2. On the Devices pane, right-click EtherCAT_X and then select Scan for
Devices.

3. Inthe Scan Devices dialog, select the device and click Copy to project.
4. Double-click the device in the project tree.
6.2.4.3 EtherCAT Devices Scan

How do | open the Scan Devices dialog?

* On the Devices pane, right-click EtherCAT_X and then select Scan for
Devices.

Use Scan for Devices to detect the devices in the network and you can apply the
scanned devices to the project tree.

DIADesigner-AX provides the following major enhanced device scanning functions.

* Compare the scanned and configured devices by alias address.

* Show the various comparison results in different colors.

¢ Automatically merge the scanned device to the project tree.

* Scan the junction device and its child device.

* Set the alias address of all EtherCAT slaves online.

The following table lists the basic and enhanced scanning settings and their
descriptions. You can add, remove, and move the devices for the project tree
according to the scanned devices.

Setting Description

Scanned Devices | Shows the physical devices connected to the controller.

Configured De- Shows the devices configured in the project tree.
vices
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Setting

Description

Device name

Shows the device name.

Device type

Shows the specific device type.

Alias address

Shows the address that is stored in the ADO 0x0012 register
for the scanned device and the station alias configured in the
project for the configured device.

You can change the alias address for the scanned device.

New address

Enter a new alias address for the slave device and then click
Writealias address to EEPROM to write the new alias ad-
dress to EEPROM. This option is only available when select-
ing Write address.

Write address

Select to allow entering a new alias address in the New ad-
dress column. You can select the header to configure for all
slaves.

Writing results

Shows the results of the writing alias address to the EEPROM
operation.

Turn on alias ad-
dress

Select to compare the devices by alias address and device
type. If the alias address, device type, and slot are the same,
then mark the device as Matched. You can select the header
to configure for all slaves.

Comparison results

Shows the comparison result between the device connected
and the device in the project tree.

* Matched: The device in the project tree is the same as
the device connected. The corresponding matched de-
vice will be highlighted.

* Added: The device is connected but not in the project
tree.

* Moved: The matched device is moved to a different slot.
The corresponding moved device will be highlighted.
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Setting

Description

This result only shows when Turn on alias address is
selected.

* Changed: Its child devices are different from that of the
scanned devices.

¢ Disabled: The device is disabled.

* Removed: The device is not connected and will be delet-
ed from the project tree after clicking OK.

Iﬁ Click to copy the selected device in the Scanned Devices
pane to the position before the selected device in the Config-
ured Devices pane.

IE Click to copy the selected device in the Scanned Devices

pane to the position after the selected device in the Config-
ured Devices pane.

Click to delete the selected device.

gm

Click to turn off the selected device and always keep it in the
project tree. This function is unavailable after login.

-

Click to turn on the selected device.

a

Click to move the selected device up. You can only move the
device between the same level node or between connectors.

g

Click to move the selected device down. You can only move
the device between the same level node or between connec-
tors.

Write alias address
to EEPROM

Click to write the new alias address to EEPROM. This option
is not available if Write address is not selected.

Stop writing alias
address

Click to stop writing the new alias address to EEPROM.

DIADesigner-AX Version 1.8.0

266



A hELTA Chapter 6: Network Configuration

Setting Description
Ignore unknown Select to not compare unknown devices.
devices when auto
merging
Auto merge Click to merge the devices in the Scanned Devices pane to
the Configured Devices pane.
Restore Click to undo all the changes.
Scan devices Click to start a new scan.
OK Click to apply the changes to the project tree.

Note: For the MX300 empty slot, Copy, Delete, Disable, Move up, and
Move down functions are not available; for the MX300 Frequency Converter
module, Disable is not available.

To use the original device scanning function, on the menu bar, select Tools >
Options > General, and clear the Turn on enhanced EtherCAT scanning
checkbox.

6.2.4.4 Add Multiple EtherCAT Ports to the AX-8 Series Controller

The AX-8 series controller supports adding up to three EtherCAT ports (AX-8 without
high speed 10 series support adding two). Use the following steps to add multiple
EtherCAT ports.

To add multiple EtherCAT ports

1. On the Devices pane, right-click the AX-8 series controller and then select Add
Device.

2. Inthe Add Device dialog, select Fieldbuses > EtherCAT > Master > AX
Series EtherCAT Master, and then click Add Device. Two EtherCAT ports

show.
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LR o [0 =t
EtherCAT
B ModbusTCP/EtheriatiP
B Modbus N
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o
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3. Repeat step 2 to add the third EtherCAT port.
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6.2.4.5 Parameter Backup and Restore

The Parameter Backup and Restore function backs up and restores parameters of
the EtherCAT slave device.

* Supported controllers:

° AX-3 series

° AX-332 version 1.0.5.9 and later

o AX-5 series

° AX-8 Linux version 3.5.15.55 and later

°  AX-8 Windows version 3.5.14.35 and later
o AX-8 series

o AX-C series version 1.0.2.10 and later

* Supported SoftMotion devices:

o  ASDA-A3-E version 11165, sub version 92

o ASDA-B3-E version 10665, sub version 75

How do | open the Parameter Backup and Restore dialog?

DIADesigner-AX Version 1.8.0

269



A hELTA Chapter 6: Network Configuration

* Do one of the following:
o Click Tools > Parameter Backup and Restore.

° On the Devices pane, right-click EtherCAT_X > Parameter Backup and

Restore.
2! Parameter Backup and Restore - O X
@ P
General Action
4 || Target Device List -
] 1001 (Delta ASDA-B3-E Backup to File

Generate Target Device List from: @

Current Project

Online Device

Gateway-1/0301.0036

Device Name: AX-308EADMATT
Device Address: (

Device Type: 4102

Device ID:

Device Version:

I @0crors I A\ 0 Warnings I 00 Messages} e

Device Message

Action: Backup to File

The following table lists the settings and description of Parameter Backup and
Restore.

Setting Description

General Select the target device.

When selecting Current Project or Online Topology in Gen-
erate Target Device List from, the target slave device list will
show under General.

Action Select the following actions:
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Setting

Description

* Backup to File: Back up the parameters of the slave de-
vice to a computer file.

* Backup to SD Card: Back up the parameters of the
slave device to the SD card of the controller.

* Restore from File: Restore the slave device parameters
from a computer file.

* Restore from SD Card: Restore the slave device para-
meters from the SD card of the controller.

Generate Target
Device List from

Select the source of the Generate Target Device List.

* Archive File

* Current Project

* Online Topology

Online Device

Browse and select the controller on the network.

Archive

Click to open the Save As dialog to save the archived file.

Start

[“‘:-

-

Click to start to back up or restore parameters.

6.2.4.5.1 Back up parameters to File

Use the following steps to back up parameters to a file in your computer.

To back up parameters to a file
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In the Parameter Backup and Restore dialog, select Backup to File.

In Generate Target Device List from, select an option. If you select Archive
File, you need to browse and select the previously archived files.

In Online Device, browse and select an online device.

-

Click P> to start the parameter backup.

Click Yes if the following dialog shows.

Do you want to stop the controller and servo off the slave
devices?

Yes No

6.2.4.5.2 Back up Parameters to an SD Card

Use the following steps to back up parameters to an SD card attached to the

controller.

To back up parameters to an SD card

1.

2.

In the Parameter Backup and Restore dialog, select Backup to SD Card.

In Generate Target Device List from, select an option. If you select Archive
File, you need to browse and select the previously archived files.

In Online Device, browse and select an online device.

-

Click P> to start the parameter backup.

Click Yes if the following dialog shows.

Do you want to stop the controller and servo off the slave
devices?

Yes No
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6.2.4.5.3 Restore Parameters from a Computer File

Use the following steps to restore parameters from a file in the computer.

To restore parameters from a computer file

1.

2.

In the Parameter Backup and Restore dialog, select Restore from File.

In Generate Target Device List from, select an option. If you select Archive
File, you need to browse and select the previously archived files.

In Online Device, browse and select an online device.

["‘:-

~ | to start to restore parameters.

Click

Click Yes if the following dialog shows.

Do you want to stop the controller and servo off the slave
devices?

Yes No

6.2.4.5.4 Restore Parameter from an SD Card

Use the following steps to restore parameters from an SD card.

To restore parameters from an SD card

1.

2.

In the Parameter Backup and Restore dialog, select Restore from SD Card.

In Generate Target Device List from, select an option. If you select Archive
File, you need to browse and select the previously archived files.

In Online Device, browse and select an online device.

[“‘:-

~ | to start to restore parameters.

Click
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5. Click Yes if the following dialog shows.

Do you want to stop the controller and servo off the slave
devices?

Yes No

6.2.5 EtherNet/IP Settings

Ethernet Industrial Protocol (EtherNet/IP) is an open industrial networking standard
managed by ODVA (Open DeviceNet Vendors Association).

EtherNet/IP works on a TCP/UDP/IP-based Ethernet network and uses the most
widely deployed collections of Ethernet standards to provide a broad range of
applications in different industries that require high speed and stability, including
Factory Automation (FA), Building Automation (BA), Process Automation (PA), and
many more.

6.2.5.1 EtherNet/IP Scanner
How do | open the EtherNet/IP Scanner page?

1. On the Devices pane, right-click Ethernet_X (Ethernet), and then select Add
Device.

2. Inthe Add Device dialog, select Fieldbuses > EtherNet/IP > EtherNetIP
Scanner > EtherNet/IP Scanner, and then click Add Device.

3. On the Devices pane, double-click EtherNet/IP Scanner_X.
The following table lists the settings and descriptions of EtherNet/IP Scanner.

General
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G I
Enere Options

o Auto-reestablish connections §
o Ethen\'et/IP

EtherMetfIP Scanner I/0 Mapping Vendor code 799

EtherMet/IP Scanner IEC Objects Product code 16390

Status

Information

Setting Description
Auto-reestablish Select to perform the reconnection after a timeout or error oc-
connections curs.
Vendor code View or modify the default vendor code of EtherNet/IP Scan-
ner.
Product code View or modify the default product code of EtherNet/IP Scan-
ner.

6.2.5.2 EtherNet/IP Remote Adapter
How do | open the Ethernet/IP Remote Adapter page?

1. On the Devices pane, right-click EtherNet IP Scanner_X, and then select Add
Device.

2. Inthe Add Device dialog, select Fieldbuses > EtherNet/IP > EtherNet/IP
Remote Adapter. Select an adapter and then click Add Device.

3. On the Devices pane, double-click the adapter.

If you want to use a third-party EtherNet/IP remote adapter, go to Tools > Device
Repository and install the EtherNet/IP standard EDS file.

The following table lists the settings and descriptions of the EtherNet/IP remote
adapter.

General
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Bl As218PX x

General

Address Settings

Connections 1P address 192 . 1883 . 0 . 2 Eth \ d
en'et/IP
Assembliss
User-Defined Parameters Electrnic Keying
Log [] Compatibility check
EtherMet/IP /O Mapping Vendor ID Check match
Device type Check match
EtherNet/IP IEC Objects
Product code Check match
Status Majorrevision Check match
Information Minor revision [] check match
Setting Description

Address Settings

IP address

Enter the EtherNet/IP remote adapter IP address.

Electronic Keying

Compatibility check

Select to check whether the key values in the EDS file are

compatible with the device.

Check match Select to check whether the following information in the EDS
file is compatible with the device.
* Vendor ID
* Device type
* Product code
* Major revision
* Minor revision
If the check fails, the 1/0 connection with the device will not
establish, and an error message will show on the status page.
Connections
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[l As21epx x
General ’

Connection Name ~ RPI(ms)  O-->TSize (Bytes)  T-->OSize (Bytes)  Proxy Config Size (Bytes)  Target Config Size (Bytes) Connection Path
Connections Connectionl 20 200 200 16 20042480 2C 64 2C 65
Assemblies

User-Defined Parameters
Log

EtherNet/IP I/O Mapping
EtherNet/IP IEC Objects

Status

<

Information

Add Connection... Delete Connection Edit Connection...
Configuration Data
[0 Raw data values [/] Show Parameter Groups Defaults
Parameters Value Unit DataType ~ Minimum Maximum Default  Help String
= Connection1
= Target Config data
Conn1_Input(T->0) DeviceType D UINT 0 3 0
Conn1_Input(T->0) DeviceQuantity 200 UINT 0 500 200
Conn1_Input(T->0) DeviceIndex 1000 UDINT 0 29999 1000
Conn1_Output(0->T) DeviceType D UINT 0 3 0
Conn1_Output(0->T) DeviceQuantity 200 UINT 0 500 200
Conn1_Output(O->T) DeviceIndex 0 UDINT 0 29999 0
Setting Description

Connection Name

Shows the connection name.

RPI (ms)

Shows the requested packet interval (the exchange interval of
input/output data). Editable.

O — T Size (Bytes)

Shows the producer data size from the scanner to the adapter
(Originator — Target). You can double-click the box to open
the Edit Connection dialog to edit the value.

T — O Size(Bytes)

Shows the consumer data size from the adapter to the scan-
ner (Target — Originator). You can double-click the box to
open the Edit Connection dialog to edit the value.

Proxy Config Size
(Bytes)

Shows the size of the proxy configuration data.
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Setting Description

Target Config Size | Shows the target configuration data size.
(Bytes)

Connection path Show the connection path data. The data is represented as:

address - configuration object - input object - output object.

Add Connection Click to open the New Connection dialog to set up the para-
meters of the new connection.

Delete Connection | Click to remove the selected connection from the list.

Edit Connection Click to open the Edit Connection dialog to modify the para-

meters of the existing connection.

Click Add Connection to open the New Connection dialog. Use the settings in this
dialog to create a new connection.
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(®) Generic connection (freely configurable)
(") Predefined connection (EDS file)
Cannection Path Settings
() Automatically generated path

Cancel

Class ID: 1624 Instance ID: 1650
Class ID: 1644 Instance ID: 16+ 0
Class ID: 1644 Instance ID: 16+ 0

Attribute ID: 16# 3

Attribute ID: 16% 3

Attribute ID: 16% 3

(@) User-defined path
(") Path defined by symbalic name

General Parameters

Connection Path 20 04 2484 2C 6C 2C 6D

Trigger type Cydic

Transporttype Exclusive owner
Scanner to Target (Qutput)

0-—->T size (bytes)

Proxy config size (bytes) I:I
Target config size (bytes)

RPI {ms) 20 $

Timeout multiplier |4 ~

Target to Scanner (Input)

T-->0 size (bytes) |200

Connection type Point to Paint ~ Connection type | Multicast =
Connectionpriority | Scheduled e Connectionpriority | Scheduled ~
Fixed/Variable Fixed e Fixed/Variable Fixed e
Transfer format 32-bit runjidie ~ Transfer format  |Pure data >
Inhibit time {ms) 0 = Inhibit time {(ms} |0 =
Heartbeat multiplier |1 =

Setting Description

Generic connection

Select to configure new connections.

* Automatically generated path: The connection path is
automatically generated based on the combined configu-
ration, consumption and production values.

* User-defined path: Enter the connection path.

* Path defined by symbolic name: The path is defined

by the symbolic name.
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Setting

Description

Note: The device must support a symbolic connection
path.

Predefined connec-
tion

Select to use the existing connection in the EDS file. You can
change the configuration data defined in the EDS file.

General Parameters

Connection Path

The connection path is used to address one or more objects
in the adapter that provides input data and receives output
and configuration data.

Note: The connection path is set up to a custom path.

Trigger type Select the trigger type.
* Cyclic: Periodically exchange data at intervals set by
RPI.
* Status change: After changing the scanner output or
adapter input, data will be exchanged automatically.
* Application: Not implemented
Transport type For details, see the CIP specification.
RPI (ms) Select or enter the time interval (in milliseconds) at which the

transmitting application requests data to be transmitted to the
target application. The value must be a multiple of the bus cy-
cle task.

Timeout multiplier

Select the timeout multiplier. If the device fails, there will be a
time delay (RPI x timeout multiplier) before the device status
switches to Error.

Scanner to Target (Output) /Target to Scanner (Input)
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Setting

Description

O — T size (Bytes)

The size of producer data from scanner to adapter (Originator

— Target)

T — O Size (bytes)

Consumer data size from adapter to scanner (Target —> Origi-

nator)

Proxy Config size
(Bytes)

The size of the proxy configuration data

Target Config size
(Bytes)

Target configuration data size

Connection type

* Empty: No network connection is established.

* Multicast: The network connection has been estab-
lished. Connection data can be received by multiple
user.

* Point-to-point: A network connection has been estab-
lished. Connection data can only be received by one
user.

Connection Priority

Using two scanners with different priorities for a target may
cause conflicts. Adjusting the connection priority can solve
this problem.

Fixed/Variable

For detailed information on parameters, see CIP specifica-
tions.

Transfer format

Conversion format

Inhibit time (ms)

Prohibited time

Heartbeat multiplier

Extend the time interval for the scanner to send heartbeat
messages to the adapter. This value is multiplied by the RPI
value.

Example: RPI = 10 ms, and heartbeat multiplier = 10 causes
a message to be sent every 100 ms.
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Setting

Description

Note: The transmission format is Heartbeat.

Configuration Data

Under Configuration Data, the connection with the configuration parameters in the

EDS file is displayed. The connections are subdivided into configuration groups.

Project

Description

Raw data values

If scaling parameters are defined for the data in the EDS file,
the value can be displayed as raw data or converted data.

* Startup: Display data without any conversion. For the
Enum data type, the index of the enumeration value will
be displayed.

* Not started: Display data and conversion. For the Enum
data type, the enumeration value will be displayed.

Show Parameter

Displays the parameter group.

Groups

Defaults Set as default.

Value Double-click to change the value. According to the Data Type,
you can specify the value directly in the input box, or select
from the drop-down list.

Assemblies

DIADesigner-AX Version 1.8.0

282



A AELTA Chapter 6: Network Configuration

Wl As218Px x -
Geaeral Connections
Connections Connection Name ~ O-->T Size (Bytes) T-->0 Size (Bytes) Proxy Config Size (Bytes) Target Config Size (Bytes)
Connection1 200 200 16
Assemblies
User-Defined Parameters
Consuming Assembly "Output(0->T) Data” (0-->T) Produding Assembly Input(T->0) Data” (T-->0)
Log ok Add X Delete | @ MoveUp & Move Down ok Add X Delete | @ MoveUp & Move Down
EtherNet/IP 1/0 Mapping Name Data Type BitLength  Unit Help String A Name Data Type BitLength  Unit Help String A
Output_data0 UINT 16 Input_datad UINT 16
EtherNet/IP IEC Objects Output_datal UINT 16 Input_datal UINT 16
Output_data2 UINT 16 Input_data2 UINT 16
Status Output_data3 UINT 16 Input_data3 UINT 16
Output_data4 UINT 16 Input_data4 UINT 16
Information Output_datas UINT 16 Input_datas UINT 16
Output_dataé UINT 16 Input_data6 UINT 16
Output_data7 UINT 16 Input_data7 UINT 16
Output_data8 UINT 16 Input_data8 UINT 16
Output_data9 UINT 16 Input_datad UINT 16
Output_data10 UINT 16 Input_data10 UINT 16
Output_datall UINT 16 Input_data11 UINT 16
Output_data12 UINT 16 Input_data12 UINT 16
Output_data13 UINT 16 Input_data13 UINT 16
Output_data14 UINT 16 Input_data14 UINT 16
Output_data15 UINT 16 Input_data1s UINT 16
Output_data16 UINT 16 Input_data16 UINT 16
Output_data17 UINT 16 Input_data17 UINT 16
Output_data18 UINT 16 Input_data18 UINT 16
Output_data19 UINT 16 Input_data19 UINT 16
Output_data20 UINT 16 Input_data20 UINT 16
Output_data21 UINT 16 Input_data21 UINT 16
Output_data22 UINT 16 v Input_data22 UINT 16 v
[ Generate 1/O channels for padding data

Shows the connections. After you select a connection, the consuming assembly
and producing assembly information shows. You can Add, Delete, Move Up, Move
Down the item, and edit each item.

6.2.5.3 EtherNet/IP Local Adapter
How do | open the EtherNet/IP Local Adapter page?

1. On the Devices pane, right-click Ethernet_X(Ethernet), and then select Add
Device.

2. In the Add Device dialog, select Fieldbuses > EtherNet/IP > EtherNet/IP
Local Adapter > Delta EtherNet/IP Adapter (or EtherNet/IP Adapter), and
then click Add Device.

3. On the Devices pane, double-click Delta EtherNet IP Adapter_X (or EtherNet
IP Adapter_X).

The following table lists the settings and descriptions of Delta EtherNet/IP Adapter.

General
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General
Tags

Log

Delta EtherNet/IP Adapter IO
Mapping

Delta EtherNet{IP Adapter IEC
Objects

Status

Information

EDS File
Vendor name
Vendor ID
Product name
Product code
Majar revision
Minor revision
Support ACD
Enable ACD

Enable LLDP

|De|ta electronics, inc.

799

| Etheret/IP

[ax-z08E80MA T

16386

1

-.—

& 0O

Installto Device Repositary...

Setting

Description

Install to Device
Repository

Click to install the device to the device repository.

After the device is installed, it will be added under Ether-

Net/IP Scanner as a remote adapter. You need to update the
device automatically.

Export EDS File

Click to export the EDS file. The EDS file will be saved on the

local computer and can be used in an external setting envi-
ronment.

6.2.5.3.1 Add EtherNet/IP Module

The controller can act as an EtherNet/IP Adapter after you add and configure the
EtherNet/IP Modules.

To add and set up EtherNet/IP Module

1. On the Devices pane, right-click Delta EtherNet IP Adapter _X (or EtherNet
IP Adpater_X), and then select Add Device.

2. In the Add Device dialog, select Delta EtherNet/IP Module (or EtherNet/IP

Module), and then click Add Device.

3. On the Devices pane, double-click Delta EtherNet IP Module_X (or EtherNet
IP Module_X).

4. On the Assemblies page, select Consuming Assembly and Producing

Assembly.
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Note: Select the same connection for Consuming Assembly and
Producing Assembly. For example, if Consuming Assembly selects
Conn1_Output, Producing Assembly should select Conn1_Input.

Assemblies Consuming Assembly | Conn1_Output{0->T) Data (Instance 16254) ~|  ProducingAssembly | Conn1_Input{T->0) Data (Instance 16#65) v
nsuming Assembly "Conn1_Output(0->T) Data” (0—>T) Producing Assembly "Conn 1_Input(T->0) Data” (T—>0)

EtherNet/IP Module IEC Objects °
dp Add Delete Move Up Move Down ok Add Delete Move Up Move Down

Status Mame  DataType  Bitlength  Unit Help String Name  DataType  Bitlength  Unit Help String

Information

5. Inthe Consuming Assembly and Producing Assembly areas, click Add to
create parameters respectively.

6.2.6 PROFINET 1I/O Settings

PROFINET I/O is a Fieldbus protocol that enables communication between
controllers and distributed field devices in Ethernet. The protocol classifies devices
into I/O Controllers, I/0 Supervisors, and 1/0O Devices with specific services.
PROFINET I/O uses three communication channels to exchange data: standard
UDP/IP and TCP/IP channels, real-time (RT) channels, and synchronous real-

time (IRT) channels. Standard UDP/IP and TCP/IP channels are used in the
parameterization and configuration of devices and acyclic operations; Real-time (RT)
channels are used in cyclic data transmission and alarms; Synchronous real-time
(IRT) channels are used in motion controls.

CODESYS PROFINET version 4.3.0.0 and later is supported.

6.2.6.1 Add a PROFINET Device
Use the following steps to add a PROFINET device.
To add a PROFINET device
1. On the Devices pane, right-click the controller and then select Add Device.

2. Inthe Add Device dialog, select Fieldbuses > EtherNet/IP > Ethernet
Adapter > Ethernet, and then click Add Device.

3. Right-click Ethernet_X (Ethernet) and select Add Device.
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4. In the Add Device dialog, select Fieldbuses > Profinet 10 > Profinet 10
Device > CODESYS PROFINET Device, and then click Add Device.

5. Right-click CODESYS_PROFINET_Device_X and select Add Device. You can
select the input and output I/O modules according to your needs.

6.2.6.2 PROFINET Device Settings

The following table and figures show the PROFINET settings.

General

General

PROFINET Device /O Mapping

PROFINET Device IEC Objects

Log

Status

Information

IP and Name Assignment

(O) Load remanent data | PNDevice.data

@ Use project parameters

Station name  |PN-Device

110 Provider | Consumer Status
Use incoming {recommended)

[J use autgeing
Substitute values
(@) Inactive
() Last value

Setting

Description

Load remanent da-
ta

Select the IP and name assignment.

If selecting this option, the IP settings and the station name in
the controller’'s PNDevice.data file are used. The IP address
is 0.0.0.0 and the station name is blank initially.

Use project para-
meters

Select the IP and name assignment.

If selecting this option, when starting the device, the values
defined in the project for IP configuration and station name
are used initially. (Not recommended)

Station name

Enter the station name of the PROFINET device.

I/0O Provider / Con-
sumer Status

Select the I/O provider and consumer status.
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Setting Description

* Use incoming: The I/O data for the provider and con-
sumer status is generated, which is received by the con-
troller.

* Use outgoing: The I/O data for the provider and con-
sumer states is generated, which is sent to the con-
troller.

Substitute values | Select the substitute value for the output data.

* Inactive: The outputs are set to inactive, for example, 0.

* Last value: The output data retain the last valid value.
The value is retained even if the connection to the con-
troller has been interrupted.

PROFINET Device I/0 Mapping

General Find Filter Show all ~ b Add FB for [0 Channel.. ~ Goto Instance

Variable Mapping ~ Channel  Address Type  Unit  Description

* |Application. CODESYS P... " Signal LED SRS BIT 1f & DCP-Signal command is received, this Bit pulses for 3 5 wi

PROFINET Device I[f0 Mapping
PROFINET Device IEC Objects
Log

Status

Information

Create and map variables. For more information, see Edit I/O mapping.

PROFINET Device IEC Objects
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[[] CODESYS PROFINET Device X

General =k Add... [ Edit... Delete Go to Variable
Expression Type Value
PROFINET Device If/0 Mapping .
= ﬂ DeviceApplication.CODESYS_PROFIMET _Device  IoDrvProfinetDevice. ProfinetDevice
L
PROFINET Device IEC Objects % Status DEVICESTATE Run
" ConnectionCount DINT 1
Lag
Status

Information

Shows the running status and connection count.

Log
General no |0 0 | E0 |'ﬂ' 0 (030 | Searchin messages 2 o [durcTme | g

Severity Time Stamp Description

PROFINET Device [/O Mapping

PROFINET Device IEC Objects

Log

Status

Information

Shows the log details.

General
Diagnosis data
PROFINET Device /0 Mapping Module
PROFINET Device IEC Objects
Log
Status
Information
PROFINET-Ethernet : nia

Last diagnosticmessage:

Driver Diag

i+ PN-Device Status

i+~ Connections

i+ Onine

1 1P Active

- stationname

- PParameter

% Ethernet Statistic

+- Link Status
MAUType

Shows the PROFINET device’s running status.

Information
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General

Log

Status

PROFINET Device If0 Mapping

PROFINET Device IEC Objects 1D:0000 1017

Information

General

Name: CODESYS PROFINET Device

Vendor: 35 - Smart Software Solutions GmbH
Categories: Profinet 10 Device

Type: 33

Version: 4.3.0.0

Order number: -

Description: CODESYS PLC running as PROFINET Device,
Configuration version: 3.5.10.0

-

Shows the PROFINET device’s general information.

6.2.6.3 Add a PROFINET Coupler

AX-5 series controllers support adding a PROFINET coupler and then adding the
input and output PROFINET modules.

To add an AX-5 PROFINET coupler

1.

5.

On the Devices pane, right-click Ethernet_X (Ethernet) and select Add
Device.

In the Add Device dialog, select Fieldbuses > Profinet 10 > Profinet 10
Master > PN-Controller, and then click Add Device.

Right-click PN Controller_X and select Add Device.

In the Add Device dialog, select Fieldbuses > Profinet 10 > Profinet 10 Slave
> 1/0.

Select a coupler, and then click Add Device.

After adding the PROFINET coupler, you can add the PROFINET I/O modules
according to your needs.

6.2.7 OPC UA Settings

OPC UA Server is included in the AX series controller. Use OPC UA Client to access
the control interface of the controller to communicate with OPC UA Server through a

TCP connection.

OPC UA Server supports the following functions.
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* Browse data types and variables.

* Standard read or write

* Value change notification (for subscribed and monitored items)

* Basic256SHA256 encrypted communication

6.2.7.1 Assign OPC UA Access Rights to Variables

To use OPC UA Server, you need to assign OPC UA access rights to variables to
allow OPC UA Client to read and write the variables.

To assign OPC UA access rights to variables
1. Declare different types of variables.

2. On the Devices pane, right-click Application and then select Add Object >
Symbol Configuration.

3. In the Add Symbol Configuration dialog, select Support OPC UA features
and then click Add.

4. Inthe Symbol Configuration editor, click Build.
5. Select the variable to allow OPC UA Client to access.

6. Click the icon in the Access Right column to set read and write rights for each
variable.

A Network Configuration Editor i] PLC_PRG [ Device B2 Symbol Configuration X

[N] View ~ |[*¥|Build | [} Settings v Tools

Changed symbol configuration will be transferred with the next download or online change

Symbols Access Rights |Maximal Attribute  Type Members Comment
+ é Constants

= |E] IoConfig_Globals

# DFB_AXSIOFWUpgrade ”’ DL_EtherCATOP.DFB_AXSIOFWUpgrade
# EtherCAT_ErrorLED_Handle » DL_BuiltinIO_IMP.EtherCAT_ErrorLED_Handle
# EtherCAT_Master_SoftMotion ) ToDrvEthercatLib. IODrvEtherCAT
¢ EthercatSlaveParaBackupRestore » DL_SlaveParaBackupRestore, DDF_BackupRestore
# Ethernet £ IoDrvEthernet. IoDrvEthernet
# Pulse_Output K DL_BuiltinIO_IMP.DMC_PO_SLOT_REF

[7] # Pulse_Output_SYNC ) £ DL_BuiltinIO_IMP.Po_Sync
# nloConfigTaskMapCount W DINT

[[] # ploConfigTaskMap £ POINTER TO IoConfigTaskMap

= @[5 rc_rre

v % newVar '90 ”9 BOOL

V| # newVarl 4y £ DINT
# newVar2 "9 DINT
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7.

8.

Icons for access rights (in ascending order)
. Kﬂy: Read only

. %\’: Write only

. % Read and write

Click Build.

Download the project to the controller.

6.2.7.2 Establish a General Connection with UaExpert

UaExpert is a full-featured OPC UA Client and is freely accessible.

Use the following steps to set up a general connection between UaExpert and AX

series controller OPC UA Server. Other OPC UA Clients can follow the similar steps.

To establish a general connection between UaExpert and AX series controller
OPC UA Server

1.

Download UaExpert from http://www.unified-automation.com/downloads/opc-
ua-clients.html.

Open UaExpert.

In the Unified Automation UaExpert dialog, click +

In the Add Server dialog, under Custom Discovery, double-click Add Server.

In the Enter URL dialog, enter opc.tcp://controller IP address, and then click
OK. The server is added.

Enter the URL of a computer with discovery service running:

| ope.tep://192.168.1.5 .

oK Cancel
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ﬂAdd Server

? X

Configuration Name |OPL'.‘IIASC:‘VC:‘@T‘AX—F.{)?{EAU.\’IAlT - None - Nongl

Discovery ] Advanced 1

% ) Local
=69 Local Network
+ 3 Microsoft Terminal Services
= &8 Microsoft Windows Network
# &9 Web Client Network
=69 Custom Discovery
& < Double click to Add Server... >
= O, opc.tep://192.168.1.5
= _g OPCUAServer@AX-308EAOMATT
2 'None - None
() Recently Used

Authentication Settings

& Anonymous

[ Connect Automatically

OK

Cancel ‘

6. Expand the server, select None-None (no Security Policy and no Message
Security Mode), and then click OK.

7. On the Project pane, right-click the server and then select Properties.

8. Inthe Server Settings dialog, change the Endpoint Url to opc.tcp://controller

IP address:4840 and then click OK.
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B server settings - OPCUAServer@AX-3...  ? ped

Configuration

Configuration Name [OPCUAServer@i¥—30BEA0MALT

PKI Store Default b

Server Information

Endpoint Url ||opc.tcp:f}’192.168.l.5: 4340 ||

Reverse Connect | |

Security Settings

Security Policy None ~

Nessage

Security Mode Hone e

futhentication Settings

@ Anenymous

Username Store

Password

Certificate

Private Key

Session Settings

Session Name bZQ:Unifiedﬁutomation:UaExpert

Cancel

9. On the Project pane, right-click the server and then select Connect.
The variables are shown on the Address Space pane.

6.2.7.3 Establish an Encrypted Connection with UaExpert

To encrypt data and securely exchange data with the client, the server needs a
certificate when establishing a connection for the first time, and the client must trust
the certificate. Then, the server also needs to trust the certificate sent by the client.

The process includes the following three parts.

1. Add OPC UA certificate in DIADesigner-AX.

2. Trust the certificate sent by the server in UaExpert.

3. Trust the certificate sent by UaExpert in DIADesigner-AX.
To add OPC UA certificate in DIADesigner-AX

1. Connect to the controller.

2. (Optional) Set the user account and password. For more information, see Set
up Users and Groups.
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3. On the menu bar, select View > Security Screen.

4. Select Devices.

5. Click L“.| > Device (controller name).

All services in the controller that require certificates are shown on the right
pane.

[
F. .

6. Select OPC UA Server (not available), and then click

7. In the Certificate Settings dialog, set the certificate.

[ Device PLCPRG  [™3  Symbol Configuation Q Security Screen x

@ || Information 2 || information Issued for Issued by Valid from
B = [ pevice |2 erver T 10/9/20238:31:58 AM
Own Certificates ] Enaypted Appiication (not available)

Trusted Certificates Encrypted Cor
Unstrusted Certificates Vieb Server (not avaiable)
ined Certificates

X

ation (not available)

Bl BB

!
o

uaran|

Note: Make sure the certificate is not expired.

8. Restart the runtime system.

To trust the certificate sent by the server in UaExpert

1. In the Unified Automation UaExpert dialog, click Ll

2. In the Add Server dialog, under Custom Discovery, double-click Double click
to Add Server.

3. In the Enter URL dialog, enter opc.tcp://controller IP address, and then click
OK. The server is added.

Enter the URL of a computer with discovery service running:

| opc.tep://192.168.1.5 v

oK Cancel

4. Expand the server, select an encrypted communication.

5. In Authentication Settings, select Anonymous or Username based on the
user management settings in DIADesigner-AX.
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6. Click OK.
7. On the Project pane, right-click the server and then select Properties.

8. In the Server Settings dialog, change the Endpoint Url to opc.tcp://controller
IP address:4840 and then click OK.

9. On the Project pane, right-click the server, and then select Connect.

10. In the Certificate Validation dialog, click Trust Server Certificate and then
click Continue.

To trust client certificate in DIADesigner-AX
1. In the Security Screen editor, click Quarantined Certificate.

2. Drag the UaExpert certificate to Trusted Certificate.

(@ Deviee PLC_PR "3 Symbol Configuration @ Security Screen %

@ || Information « | Information  Issued for Issued by Valid from Valid until Thumbprint

Y

Unstrusted Certificates
Quarantined Certificates

aExpert@CNDLSFSUPNBD43  UsExpert@CNDLSFSUPNBD43  10/7/20238:25:13AM  10/5/20288:25:13AM  170CEDC03B0360

After the server and client have trusted each other’s certificate, go back to
UaExpert to connect to the server. Click Ignore if the Connect Error dialog
shows.

6.2.7.4 Change Variable Values in UaExpert
Use the following steps to change the variable value.
To change the variable value

1. On the Address Space pane, select the variable and drag it to Data Access
View.

2. Double-click the Value column to change the value.

6.2.7.5 Establish an Encrypted Connection with Prosys OPC UA Browser

Take Prosys OPC UA Browser as another example. The server and client also need
to trust the certificate sent by each other.

To establish an encrypted connection with Prosys OPC UA Browser
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1. Download Prosys OPC UA Browser from https://downloads.prosysopc.com/

opc-ua-client-downloads.php.
2. Open Prosys OPC UA Browser.

3. Inthe Prosys OPC UA Browser dialog, enter opc.tcp://controller IP

address:4840, and then click .~
8]

Options ~ Help

" New Connection X | =

Disconnected ope.tep://192.168.31.28:4840 v

4. Inthe Security Settings dialog, select Security Mode and Security Policy, and
then click OK.

5. In the User Authentication dialog, select Anonymous or Username based on
the user management settings in DIADesigner-AX, and then click OK.

6. Inthe Accept Certificate? dialog, click Accept Permanently.

7. In DIADesigner-AX, in the Security Screen editor, click Quarantined
Certificate.

]

to refresh.

If no response, click

8. Drag the UaBrowser certificate to Trusted Certificate

@ Security Screen x| [ Device PLCPRG ™3 Symbol Configuration

@ | Information + | Information  Issued for Issued by Valid from Valid uni Thumbprint
5 = Ei Device x L UaBrowser @CNDLSFSUPNB043 UaBrowser @CNDLSFSUPNBD43 10/8/2023 2:46:43 PM 10/5/2033 3:46:43 PM B07AAI652DAFS5(|
<

DDDDDDD

G0 RE R
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Chapter 7: HMI Interactive

DIADesigner-AX supports exporting the user-defined variables to the XML file and
then DIAScreen imports the XML file to communicate between the controller and
Delta HMI devices.

For more information, see DIAScreen Software User Manual.
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7.1 Export Variables from DIADesigner-AX

You can use Symbol Configuration to create symbol descriptions for
project variables. The variables can be exported to an XML file from Symbol
Configuration.

To export variables

1. On the Devices pane, right-click Application, and then select Add Object >
Symbol Configuration.

2. In the Add Symbol Configuration dialog, select Include comments in XML

and Support OPC UA features, and then click Add.

Note: You can only add one Symbol Configuration in the same
application.

Devices - 0 X
=13 Untited? -
=) Controller_1 (AX-308EAOMAT)
o8 Hardware Configuration
= A Network Configuration
A, EtherCAT Topology
A, EtherNetlP Topology
A, ModbusTCP Topology
=2 PLC Logic
=¥ Application
@ o
m Library Manager
\E] Motion_PRG (PRG)
{&i] Pou (FB)
®8 Symbol Configuration
E Task Configuration
T Persistentvars
= [ sBuiltn_10 (Builtin_10)
i oo (p10)
‘_'j Delta_LocalBus_Master (Delta LocalBus Masty
'j Ethernet_1 (Ethernet)
j EtherCAT_1 (AX Series EtherCAT Master Sof|
%3 SoftMotion General Axis Pool

i

T

3. On the Symbol Configuration editor, click 2| Buid or press F11, and then

select variables in the symbol list.
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View ~ ||[¥%|Build | [z Settings ~ Tools -
[

Symbols AccessRights ~ Maximal  Aftribute  Type Members  Comment
#-[7] |5] Constants

+ [ [5] 1oConfig_Globals

= [¥] [Z] Motion_PRG

7| # Variable1 " » BOOL
7| # Variable2 ) " SINT
7| # Variable3 ) K] INT

4. Select the active application in the quick access toolbar
if there are multiple applications under the same project.

File Edit View Project Build Online Debug Tools Window  Help

=] = Jd & ih '?.s ﬂ 'A'L _‘T |ﬁ|| |App|icati0n[De\rice: PLC Logic] |v

5. Do one of the following to download the XML file of the active application.

° Click L2
o Press F11.

° On the menu bar, click Build > Generate Code.

The XML file will be saved in the same folder as that of the project. You can find
the file path from File > Save Project as.

You can also extract the .tgs file to find the XML files.

7.2 Import Tags to DIAScreen with DOP-100 Series Model

DIAScreen supports importing the XML file generated from the DIADesigner-
AX project. DOP-100 series HMI supports sharing tags with DIADesiger-AX and
CODESYS Development System.

Use the following steps to import tags to DIAScreen with the DOP-100 series model.
To import tags to DIAScreen
1. Open DIAScreen.

2. Click New project.
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News project

3

Open file

Recent opened file

3. In the Project Wizard dialog, under the Series list, select DOP-100 series.

4. In HMI List, select an HMI model type and then click Next.

crics
DOP-100 senes - Model Type Resolution  Color A
103BQ 480 * 272 65536 Colors
103DQ 480 * 272 65536 Colors
10350 480 * 272 65536 Colors
103WaQ 480 " 272 65536 Colors
105CQ 320" 234 65536 Colors
1078V 800 * 480 65536 Colors
107CV 800 * 480 65536 Colors
107DV 800 * 480 65536 Colors
107EG 800 * 600 65536 Colors
107EV 800 * 480 65536 Colors
10TV 800 * 480 65536 Colors
107TPV 800*480  True Colors
1075V 800 * 480 65536 Colors W
Project Name: [ NewHMI
Sereen Name: . Screen_1
Screen No. [1
Printer: |é NULL |
System menu language English w
HMI Rotation: 0 ~ | degree
[]5et as default mod Resolution® Custom 480 |+ 272
Back Next Cancel Finich

5. Click Ethernet1 > [a
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6. Select CODESYS in Controller and then click Import.

10.

1.

12.

13.

Communication Settings

[ Device Localhost

COM1 ||1 ™
| 00- EtherLinkl Controller | # CODESYS “mm |
COM2
Commumication Parameters
' Interface Auto detect
Ethernet Controller P “ 192168 0 0 .1
Main
PLC Station [i]
[[]Enable Account and Passweor d
Account
Password
Symbol loading prompt Yes

Y . . 2000
Connection Temeout{ms) 2000

Connect Retries

Back Cancel Finish

In the Tag List dialog, click ¥ .
Select the XML file you exported from DIADesigner-AX and then click OK.

In the Project Wizard dialog, configure Communication Parameters of the
controller and then click Finish.

On the 1- Screen 1 pane, right-click the blank area and then select an
element, for example, Button > Set to On.

On the 1- Screen 1 pane, draw the graphic element.

q 1-Screen_1 x | BuiltinPLC. |

Double-click Set to On.

In the Set to On dialog, under Write Address, click IZ'
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I Main Style Text Picture Operating conds. User Security Level Macro
Coord.

Write Address

|I\'cme E|
Read Address:
State: |N°’“E |
0 v
Write Offset Address:
Language: |Nme |
L 1
g Read Offset Address

|Nme |

Element Description

Set to On_002

OK Cancel

14. In the Input dialog, select EtherLink1 for Link. The imported variables will be

listed below.

Input *
Link: EtherLink1 w
Fmnd Aa Q
Name Type

= Application
- @ PLC_PRG
% Variable1 BOOL
% Variable2 BOOL
% Variable3 BOOL
< »
Array [ ] Bit
Station No 0 = Tag

15. Select a variable and then click OK.
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The Set to On graphic element is linked with the variable.
16. Repeat step 10—-15 to add multiple graphic elements.

17. On the menu bar, click Project and then select Compile All to compile the

project.

18. Click Download All Data to download the screen data to the HMI device.

7.3 Import Variables to DIAScreen with AX-8 Series Model

AX-8 series controller has built-in HMI. Use the following steps to import tags with
AX-8 series model.

To import tags to DIAScreen
1. Open DIAScreen.

2. Click New project.

| New project
L+

Open file

Recent opened file

3. In the Project Wizard dialog, under the Series list, select AX-8 series.
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AX-8

series ~

[[]set as default mod

Model Type
AX-8_Linux_Series

AX-8_Windows_Series 1024 * 768

Project Name:

Screen Name:

Screen No.

Printer:

System menu language:
HMI Rotation:

Resolution:

Resolution  Color

1024 * 768  True Colors
True Colors
| NewHMI |
‘ Screen_1 |
K |
[& NULL |
English b
0 ~  degree

Next Cancel Finish

4. |In HMI List, select an AX-8 series and then click Next.

5. Configure Communication Parameters of the controller and then click
Finish.

6. On the Project pane, double-click Built-ln PLC.

B

[
[

Project

* I

=B NewHMI

H-4=1 Screen

H-Ef Communication
—E% Data Exchange
--@& Tag

o Alarm

H-E41 Recipe

--[&) History Buffer
- Multi-language
- Account Settings
2= Configuration
..[%a) Text Bank

--[&] Picture Bank

TE BultinPIC |

X

7. On the Built-In PLC pane, click

|

8. Select the XML file you exported from DIADesigner-AX and then click Open.
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9. On the 1- Screen 1 pane, right-click the blank area and then select an

element, for example, Button > Set to On.

10. On the 1- Screen 1 pane, draw the graphic element.

q 1-Screen_1 X [ Built-In PLC ]

11. Double-click Set to On.

12. In the Set to On dialog, under Writer Address, click |1|

Main Style Text Picture Operating conds. User Security Level Macro
Coord.

Write Address
|I\'cme E|

Read Address:

State: |I\ one |

i} ~
Write Offset Address:

Language: |Nme |

Languagel Read Offset Address

|Ncme |

Element Description:

Set to On_002

OK Cancel

13. In the Input dialog, select Built-In PLC for Link. The imported variables will
be listed below.
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Input

Link: Built-In PLC

Find Aa |

Name Type
[£-2 Application

5@ nstants

-@ DL_EtherCATOP

@ loConfig_Globals

=@ PLC PRG

% newVart INT

<

= Y new\ar BOOL

Array [ 5 : ] Bt

[3

Station No. Tag

OK

14. Select a variable and then click OK.
The Set to On graphic element is linked with the variable.

15. Repeat step 8-13 to add multiple graphic elements.

16. On the menu bar, click Project and then select Compile All to compile the
project.

17. Click Download All Data to download to the AX-8 series controller.

7.4 Upload and Download

You can upload an application from DIADesigner-AX to an HMI device and also

download an application from the HMI device. This allows you to change the running

project for different needs.

Supported devices:

* DOP-100 series

* AX-8 series

To upload the application file
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1. On the HMI screen, press the blank area for more than three seconds to start

the screen system.

2. Click L.

3. Click Up/Download.

[ pac-ax viot2

B/

x

S
—
ke

System Setting Up/Download System Info HMI Doctor
4. Click Transfer Mode.
[T T FITE. - W
PAC-AX + ™}up/Download Py riome
p— - . -
! -4 L) A
(.= 0=/ B 0-=

Standard Mode

Bypass Mode

Transfer Mode
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5. Do one of the following to upload the application file.

°  Open the DIADesigner-AX project and click Online > Create Boot
Application.

o Save the APP and CRC files in the project directory to the following path:

= DOP-100 series: USB flash drive

= AX-8 series: \Delta Industrial Automation\PLC-APP

Or

1. Click @ to search the controller.

The controller needs to be started and login in the DIADesigner-AX project.
2. Select the controller.

3. Select the folder path to upload.

4. Click to upload.
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M pac-a vidgiiog

PAC-AX =+ ™jup/Download

Boot APP (*.app) @

W oana
w. @ | |E

" Gateway IP g o

¥ Device

g ©

=

&Bmc A Home

[03B2.C00A] DESKTOP-8FFCUD e

[ pac-ax, vioni0.2

CODESYS
Boot APP (*.app) @

W AX8
Application.app
New..

PAC-AX ¢ ®M}up/Download

=

® GatewayIP 1921681120 €3

W Device
[0382.CO0A] DESKTOP-8FFCUO

To download the application file

1. Select the application file to be downloaded.

2. Select the controller.

DIADesigner-AX Version 1.8.0

309



A NELTA

Chapter 7: HMI Interactive

3. Click to download.

PR shc-an, Wig 102

Boot APP (*.app)

W A
Application.app

™ 9

@

PAC-AX <« ®MAup/Download

g

E

" Gateway IP

W Device

[0382.C00A] DESKTOP-8FFCUO

@Eacl: ﬁH ome

=)
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Chapter 8: Tools and Configurations

Use the options available in the Tools menu to customize the development
environment and access additional tools.
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8.1 Options

How do | open the Options dialog?

* Select Tools > Options.

Use the Options dialog to configure the appearance and the behaviour of the user

interface for DIADesigner-AX.

8.1.1 General

The following table lists the settings and descriptions in the General tab.

Setting

Description

Deleting slave
devices from the
project tree also
deletes the devices
and network lines
in Network Config-
uration Editor si-
multaneously

Select to delete slave devices and network lines simultane-

ously in Network Configuration Editor when deleting the

slave device from the project tree.

Note: If the slave device is connected to different con-

trollers in the same network, the slave device and net-

work line are deleted in Network Configuration Ed-

itor as long as the slave device is no longer connect-

ed to any master controller and is all deleted in the

project tree.

Enable all the de-
vices (include sub
devices) update

Select to update and add all supported sub devices and re-

move unsupported sub-devices when updating devices.

Turn on enhanced
EtherCAT scanning

Select to turn on the enhanced functions of device scanning

for EtherCAT.

Read alias address
from ADO 0x0012
register

Select to read the device alias address from the ADO 0x0012
register. If clear the checkbox, read from EEPROM.

Show Legend in
Network Configura-
tion Editor

Select to show the color icon of each network line in Network

Configuration Editor.
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8.2 Device Repository

How do | open Device Repository?

* Select Tools > Device Repository.

The device repository is used to manage the device description files installed in

the local system. You can also install a third-party device description file in Device

Repository and add the device to the project.

Use the following table to configure the Device Repository dialog.

Setting

Description

Location

Select the device repository directory on the local system and
the save location currently set.

Edit locations

Click to edit repository locations. The default location is Sys-
tem Repository.

Vendor Select the manufacturers to see available devices.
Install Click to install the device description file.

Uninstall Click to remove the selected device.

Export Click to export the device description file.

Details Click to show detailed information of the selected device.

8.2.1 Install Device Description File

Use the following steps to install device description file.

To install the device description file
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1. Select Tools > Device Repository.

Tools | Window  Help
) Package Manager...

ﬁ] Library Repository...
|ﬂj Device Repository... |I
@ Yisualization Style Repository...
H License Repository...

H License Manager...
Scripting b
Firmware Update

Customize...

Options...

Import and Export Options...

2. Inthe Device Repository dialog, select System Repository as the location,
and then click Install.

=
Location  |System Repository ~ Edit Locations...
(C:\ProgramData\Delta Industrial Automation\DIAStudio\DIADesigner-AX\Devices)
Installed Device Descriptions
String for a full text search Vendor | <All vendors> ~ Install... e
Name Vendor Version Description

* |j Miscellaneous

+ [ peita cone

* Ij Delta Localbus Master
+ - [0 Fieldbuses

® |'_'j Function Cards

+ G /O Modules

+- (@ pics B
+ I_‘_"] Power Supply Modules

+ 9 SoftMotion drives

Close

3. Inthe Install Device Description dialog, select the file type (recommend
selecting Automatic detection), and then select the file to be installed and

click Open.
After installation, you can find the new device description file under the device

component it belongs to, and it is available when you add this type of device to

the project.
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8.3 Library Manager

How do | open the Library Manager pane?

* On the Devices pane, under Application, double-click Library Manager.

Library Manager provides an overview of the libraries used in the application. You
can add the pre-installed libraries from the library repository to your application,
delete them, or edit their properties. In addition to the pre-installed libraries, you can

also create and install more libraries.

Devices. v 32X (f vibrary Manager x
=0 Untitled! ~ ||(E3 Add Library < Delete Library |~ Properties = Details | 5] Placeholders | Library Repository @ Icon Legend... [2 Summary...
= [ Controller_1 (AX-308EAOMA1T)

Libraries used in application Controller_1.Application'

@ Hardware Configuration
=- A Network Configuration

Name Namespace Effective Version
A, EtherCAT Topology ®-|8 3su e

A, EtherNetIP Topology =0 ere: tions GmbH
A ModbusTCP Topology =0
=@ pLC Logic 8] ~
=&} Application %0 co bH) ;
1.0.6..

) Library Manager 15 oL =L Electronics Inc)

[£] Motion_PRG (PRG)

5 mic.pr6 #RO) Contents of selected library 'SysTypes2 Interfaces, 3.5.17.0 (System)" Details about selected library element CWCHAR'
# () Task Configuration =2 gys?’ypeszln(eﬂ%ces, 3.5.17.0 (System) v| =0 mputsjoutputs [Z] Documentation
'$ CWCHAR

= Builtin_IO (Buitn_I0)
(@ o0 ©O10)
() Delta_LocalBus_Master_1 (Delta Localus Ma
(7 EtherCAT_1 (AX Series EtherCAT Master Sof{
= Ethernet_1 (Ethernet)
= Delta_Modbus_TCP_Master_1 (Delta Mo
() Delta_Modbus_TCP_Slave_1 (Delta
= EtherNet_IP_Scanner_1 (EtherNet/IP S
Bl As218px_1 (as218PX)
() coDESYS_PROFINET_Device_1 (CODES
‘3 SoftMotion General Axis Pool

¢ RTS_IEC_CWCHAR ALIAS CWCHAR : RTS_IEC_CWCHAR

¢ RTS_IEC_HANDLE
¢ RTS_IEC_RESULT
¢ RTS_IEC_SIZE
¢ XWORD

@ HandeConstants

For more information about Library Manager, see Object: Library Manager.

8.3.1 Install and Uninstall a Library

Library Repository defines which libraries have been installed on the local system
and can be used in the application. Use Library Repository to install more libraries.

To install a library

1. On the menu bar, click Tools > Library Repository.

2. Inthe Library Repository dialog, click Install.

3. Inthe Select Library dialog, select a library and then click Open.
To uninstall a library

1. On the menu bar, click Tools > Library Repository.

2. Inthe Library Repository dialog, select the library you want to uninstall and
then click Uninstall.
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8.3.2 Add a Library

After a library is installed, you can add it to the application.

To add a library
1. On the Devices pane, under Application, double-click Library Manager.
2. On the Library Manager pane, click Add Library.

3. Inthe Add Library dialog, select a library, and then click OK.

8.3.3 Export Library Files

You can edit the library properties in the Properties dialog. This function is
recommended for library developers or users with library development knowledge.

To edit the library properties

1. On the Library Manager pane, right-click the library and then select
Properties.

2. In the Properties dialog, edit the properties of the library.

8.3.4 Change the Placeholder Library Version

A library placeholder is a placeholder that references a particular library. The
placeholder shows the current library resolution of the application. Use the
Placeholder dialog to change the version of the library placeholder when the library
placeholder cannot be resolved.

To change library placeholder version
1. On the Library Manager pane, click Placeholders.

2. In the Placeholders dialog, double-click the field in the Library column of the
placeholder whose resolution version you want to change.

3. Inthe dropdown list, select a version.
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4. Click OK.
51 placeholders X
: £ Set all unresolved unbound placeholders to the newest available versions
Name Library Info Q
DL_BuiltInIO_IMP | DL_BuitInIO_IMP_AX3, 1.0.7.4 (Delta Electronics Inc) Resolved by device
DL_COM | DL_COM, 1.0.6.0 (Delta Electronics Inc) Unbound placeholder
DL_EtherCAT _Diag | DL_EtherCAT_Diag, 1.3.1.2 (Delta Electronics Inc) Unbound placeholder
DL_EtherCATOP | DL_EtherCATOP, 1.0.0.6 (Delta Electronics Inc) Unbound placeholder
DL_Ethernetlib | DL_EthernetLib, 1.0.6.1 (Delta Electronics Inc) Unbound placeholder
DL_Kinematics L DL_Kinematics, 1.3.2.0 (Delta Electronics Inc) Unbound placeholder
DL_ModbusComMaster [ DL_ModbusComMaster, 1.0.6.0 (Delta Electronics Inc) Unbound placeholder
DL_ModbusTCPMaster [ DL_ModbusTCPMaster, 1.0.6.0 (Delta Electronics Inc) Unbound placeholder
DL_MotionControl L DL_MotionControl, 1.4.0.0 (Delta Electronics Inc) Unbound placeholder
DL_MotionControl_Error [ DL_MotionControl_Error, 1.4.0.0 (Delta Electronics Inc) Unbound placeholder
DL_OnlineConfigMode | DL_OnlineConfigMode, 1.0.5.1 (Delta Electronics Inc) Unbound placeholder
DL_SlaveParaBackupRestore L I DL_SlaveParaBackupRestore, 1.0.6.2 (Delta Electronics Inc) I Unbound placeholder
ElementCollections Other versions of DL SlaveParaBackupRestore ions GmbH)  Unbound placeholder
EtherCATStackLibrary ’ 1.06.0 [\ | Resolved by subdevice
EtherNetIP Services 1054 Wy ) Resolved by subdevice
FloatingPointUtils Resolved by device
IoDriver Utilitv =0 Resolved bv device 4
< 1020 Y
Other library... Cancel

8.4 Firmware Update

With the update of the host and module versions, different controllers may have
different available functions and parameters. DIADesigner-AX provides a device
description file (DDF) that defines functions and parameters. When DIADesigner-
AX is installed, the latest version of the DDF will be installed. The DDF includes
the firmware information of all versions. When there is a need for new functions
or parameters, the firmware version of the controller needs to be updated. The
AX-8xxEPO Windows Series controller does not support the firmware update.

8.4.1 Update the Firmware
Use the following steps to update the firmware of the controller.
Prerequisites

* The controller is connected.

To update the firmware
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1. On the menu bar, click Tools > Firmware Update.

2. In the Firmware Package Updater dialog, do one of the following:

° In Path, click B to browse the firmware package that will be used for
firmware update.

o Click | £/ to download the firmware package from the server, and then

click ) to select the package.

Note: You can customize the firmware package download path in
the menu bar > Tools > Options > Online Download. The default
path is C:\Users\XXX\Documents.

3. In Online Device, select the controller to be updated.

4. Ensure that Device Type and Device ID of the firmware package match that of
the online device selected.

5. Click Update.

8.4.2 Firmware Package Updater Dialog

The following table lists the settings and descriptions of the Firmware Package
Updater dialog.

Setting Description

Firmware Package

Path Select the firmware package saved on the computer.
Vendor Shows the firmware package manufacturer.

Device Type Shows the firmware package device type number.
Device ID Shows the firmware package device ID.

Device Version Shows the firmware package device version number.

Mini FW Version The firmware package is compatible with the minimum

firmware version that can be updated.
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Setting

Description

Protected Package

If selected, the package is encrypted. Not editable.

¥

Click to download the firmware package online. Users in Chi-
na are recommended to select China as the download server.
The download speed is faster.

Integrity Details

Signature Check

Automatically verify the firmware signature file after selecting
the firmware package.

Hash Value Check

Automatically verify the hash value after selecting the
firmware package.

Online Device

Online Device

Select the controller to be updated.

Device Name

Shows the controller name.

Device Address

Shows the device address.

Device Type

Shows the controller device type number.

Device ID

Shows the controller device ID.

Device Version

Shows the controller device version number.

Update Progress

Progress

Shows the update progress after clicking Update.

8.5 Package Manager

How do | open the Package Manager dialog?

* On the menu bar, select Tools > Package Manager.

Package Manager extends the standard installation with additional configuration

settings. You can install, uninstall, and manage packages. The package is a

compressed file with a *.package file extension.
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P Package Manager

Currently Installed Packages

Refresh Sortby | Name w Install...
MName Version Installation date Update info License info Uninstall...
CODESYS SoftMotion 4510 1112023 Livense i vald Details

=: | Delta_DXMC_2000_Package 1.0.0.3 11/1/2023 License info not available
Updates

Search Updates

[] pisplay versions Search updates in background

1 pending installation(s) Close

The package components include the following:

Plug-in

Library

Device descriptions

Supplier’s description

Profiles

Information profiles

Profile changes

Files

Extensions for configuration of the menu, toolbar, keyboard shortcuts, and

views

Help modules
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* Complete menu configurations for special profiles

* Complete toolbar configurations for special profiles

* Complete keyboard configurations for special profiles
* Options

* Library profiles

Package Manager provides the following settings.

Setting Description
Refresh Click to refresh the installed package list.
Install Click to install the package.

Browse the packages and select the package to install. The
installation steps include:

* Check package signatures: Select Allow unsigned
and self-signed packages to install an unsigned or
self-signed package.

* [Installation - License Agreement: It only shows if the
package contains a license agreement.

* Installation - Choose Setup Type

o Complete setup: install all components.

° Typical setup: install the standard set of compo-
nents defined in the package.

o Customized setup: install the selected components.
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Setting Description

* Installation - Target Versions: Select the versions that
the package should upgrade.

* Installation - Directories: Select the target installation
path.

Uninstall Click to uninstall the package.

* When Display versions is not selected, all versions of
the selected package will be uninstalled.

* When Display versions is selected and you do not se-
lect a node or select the root node, all versions of the se-
lected package will be uninstalled.

* When Display versions is selected and you select a
package version under the root node, only the selected
version will be uninstalled.

Details Click to view the detailed information of the package.
Updates

Search Updates Click to search for updates.

Download Click to open the Download Package dialog to download and

install the update packages.

Display versions Select to show all versions of installed packages.

Search updates in | Select to search for updates for the selected package every
background hour automatically.

The update package is listed in the Update Info column.

8.5.1 Install and Uninstall a Package
Use the following steps to install a package.

To install a package
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1. On the menu bar, select Tools > Package Manager.
2. In the Package Manager dialog, click Install.
3. Inthe Open dialog, select a package file and then click Open.

4. In the Installation dialog, follow the package installation guidance to install
the package. For more information about the installation options, see Package
Manager.

5. After the installation completes, click Finish.

Note: If you want to use the function blocks in the library OSCAT
BASIC, you must install the OSCAT BASIC. The location of the
package is C:\Program Files\Delta Industrial Automation\DIAStudio
\DIADesigner-AX 1.xX\CODESYS\Packages.

To uninstall a package
1. On the menu bar, select Tools > Package Manager.
2. In the Package Manager dialog, select the package and then click Uninstall.
3. In the Uninstallation dialog, follow the guidance to uninstall the package.

4. After the uninstallation completes, click Finish.

8.6 Startup Command

How do | open Startup Command?

* On the Devices pane, right-click the controller and then select Startup

Command.

* Select Tools > Startup Command.

Startup Command supports configuring and generating different commands to
a .PLCCmd.ini.scmd file and saving it to a portable device. Once the portable device
is attached to the controller, the command will be run after a restart of the controller.

Note: An SD card of 64G or less is recommended.
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Supported device:

* AX-3 series controllers

AX-5 series controllers

AX-8 series controllers (Except for the AX-8 Windows series)

* AX-C series controllers

Note: AX-8 series and AX-332 controllers only suggest using SD memory

card as the portable device. For the AX-332 controller, you need to open

pull [~

the cover to find the hidden Micro SD slot. For more information about

inserting a memory card, see AX-3 Series Operation Manual .

Use the following table to configure the Startup Command dialog.

Setting

Description

Click to open the Command dialog to add or insert com-
mands.

Click to open the Template dialog to select the command

template.
B Click to export the command configuration file.
) Click to import the command configuration file.

Append Command

Select to add commands.

Insert Command

Select to insert commands before the selected command.

Restore Application
from Selected De-
vice

Select to restore the application file from the current applica-
tion to the controller.

Restore Application
from Portable De-
vice

Select to restore the application file from the portable device
to the controller.
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Setting

Description

Restore Source
from Current
Project

Select to restore the source file from the current project to the
controller.

Restore Source
from Portable De-
vice

Select to restore the source file from the portable device to
the controller.

Reset to Factory
Settings

Select to reset the controller to the factory settings.

Backup Application

Select to back up the application file from the controller to the
portable device.

Backup Source

Select to back up the source file from the controller to the
portable device.

Firmware Update

Update the controller firmware from the portable device.

Keep

Select to always run this command.

Execution Time

Clear Keep and enter Execution Times (1-65536). After run-
ning the number of times you defined, the command will be
deleted.

Exit

Select to stop and exit after running this command.

8.6.1 Add and Generate Commands

Use backup and restore commands to save and recover the file in case of an

unexpected data loss, or to transfer files from one controller to another. Use the

firmware update command to update the controller firmware via the file in the

portable device. Use the reset to factory settings command to delete all the data and

settings in the controller.

8.6.1.1 Back up Application or Source

Use the following steps to backup the application or the source.

Prerequisites
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* The portable device is attached.

To back up the application or the source

1. Open the Startup Command dialog.

2. Click .2

3. In the Command dialog, select Append Command, and then select Back up
Application or Back up Source.

4. Click OK.

5. In the Startup Command dialog, set up the execution of the command via
Keep, Execution Times, or Exit.

6. (optional) Click ? to precompile commands to check the required space, and
verify errors if any.

7. Click Generate. The command file is generated in the portable device.

Note: Only the FAT32 format portable device is supported. A message
will ask you to format your portable device to FAT32 if it is not. You can
follow the steps to format it.

8.6.1.2 Restore Application or Source
Use the following steps to backup the application or the source.
To restore the application or the source from the portable device

1. Open the Startup Command dialog.

2. Click | 2

3. Inthe Command dialog, select Append Command, and then select Restore
Application from Portable Device or Restore Source from Portable Device.

4. Click OK.

5. In the Startup Command dialog, set up the execution of the command via
Keep, Execution Times, or Exit.
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6.

(optional) Click ? to precompile commands to check the required space, and
verify errors if any.

Click Generate.
Attach the portable device to the target controller. The command will be run

after a restart of the controller.

Note: Make sure the restore file exists before running the command to
restore the application or source file from the portable device.

To restore the application or the source from the the current project

1.

2.

8.

Connect to the controller.

Open the Startup Command dialog.

Click .

In the Command dialog, select Append Command, and then select Restore
Application from Selected Device or Restore Source from Current Project.

Click OK.

In the Startup Command dialog, set up the execution of the command via
Keep, Execution Times, or Exit.

(optional) Click ? to precompile commands to check the required space, and
verify errors if any.

Click Generate.

8.6.1.3 Add Additional Files

When you select Restore Source from Current Project, you can also add the

additional files.

To add additional files

1.

2.

Open the Startup Command dialog.

Click .2
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3.

In the Command dialog, select Append Command > Restore Source from
Current Project, and then click OK.

In the Startup Command dialog, in the Settings column, click Additional
Files.

In the Additional Files dialog, select the files and then click OK. These settings

are synchronized with Project > Project Settings > Source Download >
Additional Files, and can be saved with the project.

8.6.1.4 Update Firmware

Use the following steps to update firmware.

To update firmware

1.

Open the Startup Command dialog.

Click .

In the Command dialog, select Append Command > Firmware Update, and
click OK.

In the Startup Command dialog, in the Settings column, click El select the
firmware package file, and then click Open.

In the Startup Command dialog, set up the execution of the command via
Keep, Execution Times, or Exit.

(optional) Click ? to precompile commands to check the required space, and
verify errors if any.

Click Generate. The command file is generated in the portable device.
Note: Only FAT32 format portable device is supported. A message will

ask you to format your portable device to FAT32 if it is not. You can
follow the steps to format it.

Attach the portable device to the target controller. The command will be run
after a restart of the controller.

After the firmware update completed, restart the controller again.
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8.6.1.5 Reset to Factory Settings

Use the following steps to reset to the factory settings

To reset to the factory settings

1.

Open the Startup Command dialog.

Click .

In the Command dialog, select Append Command > Reset to Factory
Setting, and click OK.

All the data and settings in the controller will be deleted after running this
command.

In the Startup Command dialog, set up the execution of the command via
Keep, Execution Times, or Exit.

(optional) Click ? to precompile commands to check the required space, and
verify errors if any.

Click Generate. The command file is generated in the portable device.
Note: only FAT32 format portable device is supported. A message will

ask you to format your portable device to FAT32 if it is not. You can
follow the steps to format it.

Attach the portable device to the target controller. The command will be run
after a restart of the controller.

After running the command, restart the controller again.

8.6.2 Add and Generate Template Commands

The template command provides you with two command combinations that are

convenient for widely used situations. Select one of the following options if you want

to apply the application or source file to another controller.

Backup & Restore Application

Backup & Restore Source
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Prerequisites

The portable device is attached.

To add and generate template commands

1.

o

Open the Startup Command dialog.

Click

Select one of the templates, and then click OK.
Click Generate. The command file is generated in the portable device.

Note: Only FAT32 format portable device is supported. A message will
ask you to format your portable device to FAT32 if it is not. You can
follow the steps to format it.

Attach the portable device to the controller to back up the file.

Attach the portable device to the other controller to restore the file.

8.6.3 Import and Export Commands

You can export and import the command configuration to an XML file.

To export commands

1.

2.

5.

Open the Startup Command dialog.

Add the command.

Click .2

Enter File Name, and then select a path to save the command configuration
file.

Click Save.

To import commands
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1. Open the Startup Command dialog.

0

2. Click , and select the command configuration file to be imported.

3. Click Open. The commands will be listed in the Startup Command dialog.

8.7 Resource Monitor

How do | open Resource Monitor?

* Select Tools > Resource Monitor.

Resource Monitor is only available when there is a project with AX series
controllers.

Use Resource Monitor to monitor the controller CPU usage in real time and the
variable usage, such as the size of variables assigned to different storage areas.

/[ Ax_308EAMATT " Resource Monitor X
~Select device and applications 4 CPU Usage
AX_308EAOMAIT v
= PLC load average:  19% Raise alarm when any of the PLC Core load exceeds: |80 | % (1~99)
Selectall  [] Unselectall CorelD: 0
Application PLCCoreload:  19%
4 Compile Inf
Compile
(] Hide chart 100% — — — — — —
Unit: BYTE
80%
60%
1506194
8189 8191 1524288 1262120} 131048
40%
20%
—
% 1715274 3 1 0 0 0
o
Data & Code %I %Q %M Retain Persistent
Available B Used
Display by area | Al v Display by status | All v (] Only show user-defined variables
Address Range Scope Name Data Type Status  Size (BYTE)
%QB1-%QB8191 Application [o st A
%QB0 Application.JOCONFIG_GLOBALS_MAPPING map_818f6875_02ec_4¢ BYTE [B 1
%MBO-%MB524287 [\0 524288
%1B83-%188191 Application [\0 8189
%182 Application.JOCONFIG_GLOBALS_MAPPING map_818f6875_02ec_4¢ BYTE I:B 1
%IB1 Application.JOCONFIG_GLOBALS_MAPPING map_818f6875_02ec_4¢ BYTE I:B 1
%180 Application.JOCONFIG_GLOBALS_MAPPING map_818f6875_02ec_4¢ BYTE I:B 1
Application.IMPLICIT_FUNCTION_POINTERS SIGNATURE__994__FP_POINTER TO DWORD I:B 4
Annlication.JMPLICTT FUNCTION POINTFRS  SIGNATURF 1000 FFPOINTFR TO DWORD. O 4
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8.7.1 Monitor Variable Usage

Use the following steps to view the variable usage.

To monitor variable usage

1. On the Select device and application(s) pane, select the device and

applications that you want to monitor.

If you edit devices or applications on the Devices pane, it will be updated in

real-time on the Select device and application(s) pane.

2. On the Compile Information pane, click Compile.

All user-defined variables and system variables are monitored.

The following table lists the variable compilation information.

Item Description
Address Range Shows the address range of 1%, M%, or Q%.
Scope Shows the location of the variable.
The scope format: Application name + Signature name.
Name Shows the variable name.
Data Type Shows the variable data type.
Status Shows the usage condition of the address.
. L : Used: There are variables assigned to the address.
. Lo : Available: No variables assigned to the address
within this range.
o £ Conflict: Different variables are assigned to the
same address.
Size (BYTE) Show the variable size or the size of the address section.

On the Compile Information pane, you can:
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Double-click the variable in the table to see where it is being used.

Filter the variables by area or status.

Search the variable by the variable name, address range, or scope.

Select Only show user-defined variable to filter out the system variables.

Select Hide Chart to hide the bar chart to expand the variable table.

8.7.2 Monitor the Online Controller CPU Usage

Use the following steps to monitor the controller CPU usage when the controller is

online.

To monitor the online controller CPU usage

1.

2.

3.

4.

On the Devices pane, double-click the device.

On the Device editor, select Communication Settings > Scan Network, and
then select the device.

Click System Settings > Read from PLC.

Log in to the controller.

The CPU Usage at the lower-right corner will show. You can also double-click it to

launch Resource Monitor.

Resource Monitor monitors the CPU usage of the corresponding online controller.

The following table lists the items monitored online.

Item Description

PLC load average |Shows the average PLC load.

%

Core load exceeds

Raise alarm when | The CPU Usage at the lower-right corner turns red when any
any of the PLC of the PLC Core load exceeds the specified value.

CorelD Shows the Core ID.
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Item Description

PLC Core load Shows the PLC Core load in real time.

Note: If you log in under simulation mode, CPU usage monitoring will not be
available.

8.8 Trace Variables

Trace is used to monitor variables and show the variables’ value change in amplitude
charts.

To trace variables
1. On the Devices pane, right-click Application and select Add Object > Trace.
2. In the Add Trace dialog, enter a name, select a task, and click Add.

3. On the trace tab, click Add Variable.

4. In the Trace Configuration dialog, click El next to Variable.

5. In the Input Assistant dialog, select a trace variable or traceable parameter
and click OK.

6. Log in to the controller.

7. Right-click the Trace field and select Download Trace to start monitoring.
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8.

aﬁ Trace X
15 4

7 Add Variable

Download Trace

Start Trace
Stop Trace

Reset trigger

Autoscroll
Cursor

Mouse Zooming
Reset View

AutoFit

Compress

Stretch

N a1 = v

Muve all variables te first diagram

Move all variables te individual diagrams
Online List ...

Upload Trace

b Configuration

Load Trace...
4 Save Trace...

Export symbolic trace config

Statistics

nc

(optional) You can select Move all variables to individual diagrams to show

the trace separately for multiple variables.

8.8.1 Automatically Save Traces

DIADesigner-AX supports automatically saving the trace data to a local .csv file after

the trace starts. Saving samplings will only stop when the free disc space reaches

the lower limit you set up.

To automatically save traces

1.

2.

On the trace tab, click Configuration.
In the Trace Configuration dialog, click Advanced.

In the Advanced Trace Settings dialog, select Save to local disc after
running trace to turn on more options.

Select a local path to save the file.

Do one of the following:
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o Select Samplings per file, and then enter the number of samplings saved

to one .csv file.
o Select Size per file, and then enter the size limit of the .csv file.

6. Enter the minimum disc space and select an option when reaching this limit.

Measure in every n-th cycle 1

Recommended runtime buffer size (samples)

100

|| Trace editor buffer size per variable (samples) 10001

Save to local after running trace

C:\Users\katie.ma\Documents

@ Samplings per file: 500000 (100,000 ~ 5,000,000}
() Size per file: 400 MB (10 ~ 800)
When free space is less than |1 GB:

(Mo lass than 1 GB. The current free space is 134.32 GB.)

@ Stop saving files
() Owerwrite old files

8.8.1.1 Add Time Value to the Trace File

The .csv file which automatically saves the trace data does not contain the time
value for each traced item. Use the following steps to add the time value to the .csv

file.
To add time value to the trace file
1. On the Devices pane, double-click Library Manager.

2. In the Library Manager editor, click Add Library, and then search and add
SysTimeRtc and SysTypes Interfaces libraries.

3. Open POU and add the following code to get the time value from the controller.

DIADesigner-AX Version 1.8.0

336



A hELTA Chapter 8: Tools and Configurations

udi UtcTime : = SysTi meRt cCGet (udi Resul t);

| F udi Result <> 0 THEN

RETURN;

END_|I F

(*converts the utc time (seconds) to a SYSTI MEDATE with year,
month , day, and tinme etc. *)

udi Result : = SysTi neRt cConvert Ut cToDat e(udi Ut cTi me, strTineDate);
| F udi Result <> 0 THEN

RETURN;

END_|I F

(*converts the utc time to the local tine, regarding ti mezone and
sumrer tine in seconds *)

udi Result : = SysTi meRt cConvert Ut cToLocal (udi Ut cTi ne,

udi Ut cTi meLocal ) ;

| F udi Result <> 0 THEN

RETURN;

END I F

/1 Convert the UTC seconds to a DATE AND TI ME vari abl e

dt #yyyy- mm dd- hh: nm ss :

Date_and_time_format := UDI NT_TO DT(udi Ut cTi neLocal);

4. Click the following variables in the code to open the Auto Declare dialog to
declare variables.

Date _and_time fornmat: DATE_AND TI M
strTi neDat e: SysTi neRt c. SYSTI MEDATE;
udi Ut cTi me: DWORD;

udi Ut cTi neLocal : DWORD;

udi Resul t: RTS_| EC_RESULT;

5. On the toolbar, click 1o generate code.
6. Log in to the controller.

7. Add a trace and add the Date _and _time format variable, and then download
the trace. For more information about how to add and download trace, see
Trace Variables.

8. Open the automatically saved.csv file and find the Date_and_time_format
column to check the time values for each traced item.

8.9 Product Rating

You can provide feedback on DIADesigner-AX or its individual features by rating
in the star system and entering your comments. Your feedback will guide future
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software updates and ensure that the software evolves in line with user preferences
and needs.

To rate the product

R

1. On the upper-right corner of DIADesigner-AX, click

2. Inthe Sign In/Sign Up dialog, enter your DIAStudio account information and
click Sign in. If you do not have an account, sign up for a new one.

3. On the menu bar, select Help > Product Rating.

4. Inthe Product Rating dialog, rate the item on a scale of 0.5 points to 5 points,
and enter your comments if there are any.

5. Click Send.

8.10 Software Diagnosis

Software Diagnosis is a tool to diagnose the running environment for DIADesigner-
AX and collect the system and software information. The tool shows all the
compatible and incompatible items.

The tool is installed automatically when installing DIADesigner-AX.

The tool supports diagnosing two versions of DIADesigner-AX (version 1.3.1 and
another) installed on the computer at the same time.

To diagnose the environment
1. Go to C:\Program Files\Delta Industrial Automation\DIAStudio\Diagnosis Tool.
2. Double-click SoftwareDiagnosis.

3. Click Collect to start the diagnosis. If you want to stop diagnosing, click
Cancel.

4. Look for the red items that indicate incompatible issues.
5. Select the red item.
6. On the Prompt Information pane, check the solution.

You can click Save as to export the diagnosis information as an XML file or a zip file.

DIADesigner-AX Version 1.8.0

and then select Sign In.

338



A AELTA Chapter 8: Tools and Configurations

You can click Open File to open the generated XML file.

You can search for related information in the search box.

Select the Only show incompatible items checkbox to filter and show the items

that are not compatible with the operating system.
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Chapter 9: Protection Mechanism Overview

DIADesigner-AX provides protection mechanisms for user-developed projects to

ensure the projects are fully protected.

The following is the password protection structure provided by DIADesigner-AX. You
can set passwords and adopt different data protection mechanisms according to your

needs.

Password Type

Description

Project

Designer-AX Engineering ID

(Project ID)

PLC

PLC identification
code

(PLC ID)

The ID is the authentication information
used as the first check. Before down-
loading a project, the Project ID set in
the project and the PLC ID set in the
host must be the same. Therefore, the
protection mechanism can restrict cer-
tain projects to download only to certain
hosts.
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9.1 Set Project ID

Use the following steps to set Project ID.

To set Project ID

1. On the Devices pane, double-click the device and then select System
Settings > Set Project ID.

Devices v o X

8 Hardware Configuration
= & Network Configuration
A EtherCAT Topology
A, EtherNetlP Topology
A, ModbusTCP Topology
=810 pLC Logic
= ’@r Application
m Library Manager
[£] Motion_PRG (PRG)
[£] pLc_pr (RG)
+ @’g Task Configuration
() Builtin_IO (Builtin_I0)
[ or0 (010)
@ Delta_LocalBus_Master_1 (Delta LocalBus Ma|
ﬂ"j EtherCAT_1 (AX Series EtherCAT Master Sof{
= @ Ethernet_1 (Ethernet)

@ Delta_Modbus_TCP_Slave_1 (Delta

[ As218px_1 (aS218PX)
[ cODESYS_PROFINET_Device_1 (CODES
‘3 SoftMotion General Axis Pool

[ Controller_1 x

=) Untitled1 |v
=) Controller_1 (AX-308EAOMA1T) o

Communication Settings

Applications

Backup and Restore

Files

Log

PLC Settings
PLC Shell

Licensed Software Metrics

System Settings Q

= @ Delta_Modbus_TCP_Master_1 (Delta Moq | |

= @ EtherNet_IP_Scanner_1 (EtherNet/IP Sc{ | |

Right Settings

System Parameters

Task Deployment

Status

Information

Runtime Clock
PLC Time: | Read PLC Time
Date: l\"lednesday, August 21, 2024 D‘I Write PLC Time |
Time: l10:29:20AM ::Iv Sync with Local Time
Time Zone
PLC Timezone: | Read Timezone
Timezone: | (UTC-+08:00) Asia/Shanghai V|| Write Timezone
Network
[ Apply IP settings vihile dovinload
cpswl
IP Address Mode: vsgaﬁc v
IP address: 192.168. 1 .5 |
Subnet mask: [255 . 255 . 255 . 0 |
Default gateway: ‘0 .0 .0 .0
Obtain DNSserver address automatically
(® Usethefolloving DNSserver addresses:
Preferred DNS server: [0.0.0.0
Alternate DNSserver: | 0 . 0 . 0 . 0 |
Read from PLC
‘ Project ID
Project ID status: Inactive Set Project me
Persistent Retain Settings
Mode: O Original mode (® %M mode
Start Memory Address (%M8) |0
End Memory Address (%MB) 524287
Clearall %M addresses Clear

2. Inthe Project ID Settings dialog, enter New Project ID and Confirm Project

ID.

The length of the password should be 4-16 characters.

You can select the Sync same ID with Online Device checkbox to set PLC

ID at the same time as the Project ID. For more information, see Set Project ID

and PLC ID simultaneously.
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&l Project ID Settings —

Praject ID
Mew Project ID sane
Confirm Project ID |uu|

Sync same D with Cnline Device

OK

x

Cancel

3. Click OK. Once the password is set successfully, the Project ID status will be

Active.
Project ID

Project ID status: Active

9.2 Modify Project ID

Use the following steps to modify Project ID.

To modify Project ID

Set Project ID
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On the Devices pane, double-click the device and then select System

Settings > Set Project

ID.

Devices v 3 X

=-[) Untitled?
=) Controller_1 (AX-308EAOMA1T)
8 Hardware Configuration
= & Network Configuration
A EtherCAT Topology
A, EtherNetP Topology
A ModbusTCP Topology
= &0 PLC Logic
= i,} Application
m Library Manager
[£] Motion_PRG (PRG)
[£] PLc_pra (RG)
+ @3 Task Configuration
= Builtin_IO (Builtin_10)
[ o10 (O10)
Eﬁ Delta_LocalBus_Master_1 (Delta LocalBus Ma
fﬂ EtherCAT_1 (AX Series EtherCAT Master Sof{
= m Ethernet_1 (Ethernet)
= ]I'] Delta_Modbus_TCP_Master_1 (Delta Mo
LT‘] Delta_Modbus_TCP_Slave_1 (Delta
= ]ﬂ EtherNet_IP_Scanner_1 (EtherNet/IP Scd
Bl As218px_1 (as218P%)
[ copESYS_PROFINET Device_1 (CODES
a3 SoftiMotion General Axis Pool

0 '

| /[ Controller_1 x

Communication Settings
Applications
Backup and Restore
Files
Log
PLC Settings

‘ PLC Shell

Licensed Software Metrics

System Settings Q

Right Settings

System Parameters
‘ Task Deployment
: Status

Information

Runtime Clock
PLC Time:

Date: l\"lednesday, August 21, 2024 B |

Time:

Time Zone

PLC Timezone:
Timezone:

Network
Apply IP settings while download

cpswl

IP Address Mode: 'staﬁc v

1P address: 192.168 . 1 .5 |
Subnet mask: 255 . 255 . 255 . 0 |
Default gateway: 0.0 .0 .0

Obtain DNSserver address automatically
(® Usethefollowing DNSserver addresses:
Preferred DNSserver: [ 0 . 0 . 0 . 0 |

Alternate DNSserver: | 0 . 0 . 0 . 0 |

Project ID

Project ID status: Inactive

Persistent Retain Settings
Mode: (O Original mode
Start Memory Address (%M8B) |0

End Memory Address (%MB) 524287

Clearall %M addresses

[10:28:20 Am & |

[ UTC+08:00) Asia/shanghai o[

Read PLC Time
[ Write PLC Time

Sync with Local Time

Read Timezone

Write Timezone

Read from PLC

Set Project IDQ

® %M mode

Clear

In the Project ID Settings dialog, enter Current Project ID (old password),

New Project ID (new password), and Confirm Project ID (confirm the new

password).
=
Praoject ID
Current Project 1D sans
Mew Project ID sans
Confirm Project ID sans

Sync same |D with Online

Device

OK

Cancel

Click OK.
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9.3 Clear Project ID

Use the following steps to clear Project ID.

To clear Project ID

1.

2.

On the Devices pane, double-click the device and then select System
Settings > Set Project ID.

Devices v o X

=) Untitled! |v
=) Controller_1 (AX-308EAOMA1T) o

8 Hardware Configuration
= & Network Configuration
A EtherCAT Topology
A, EtherNetlP Topology
A, ModbusTCP Topology
=810 pLC Logic
= ’Q‘; Application
m Library Manager
[£] Motion_PRG (PRG)
[£] pLc_pr (RG)
+ @Z Task Configuration
=+ Builtin_IO (Builtin_10)
[ or0 (010)
@ Delta_LocalBus_Master_1 (Delta LocalBus Ma|
@ EtherCAT_1 (AX Series EtherCAT Master Sof{
= @ Ethernet_1 (Ethernet)
= @ Delta_Modbus_TCP_Master_1 (Delta Mot
@ Delta_Modbus_TCP_Slave_1 (Delta

[ As218px_1 (aS218PX)
[ cODESYS_PROFINET_Device_1 (CODES
‘3 SoftMotion General Axis Pool

[ Controller_1 x

Communication Settings

Applications

Backup and Restore

Files

Log

PLC Settings
PLC Shell

Licensed Software Metrics

System Settings Q

Right Settings

System Parameters
= @ EtherNet_IP_Scanner_1 (EtherNet/IP Sc{ | |

Task Deployment

Status

Information

Runtime Clock
PLC Time:

Date: l\"lednesday, August 21, 2024

Time: [10:23:20 am

Time Zone

PLC Timezone:
Timezone: v(IJTC+08:00) AsiafShanghai

Network
[ Apply IP settings vihile dovinload

cpswl

IP Address Mode: vsgaﬁc v

IP address: 192 . 168 . 1
Subnet mask: [255 . 255 . 255 .
Default gateway: ‘0 .0 .0

Obtain DNSserver address automatically
(® Usethefolloving DNSserver addresses:

Preferred DNSserver: | 0 . 0 . 0

Alternate DNSserver: | 0 . 0 . 0

| Project ID

Project ID status: Inactive

Persistent Retain Settings
Mode: (O Original mode
Start Memory Address (%M8) [0
End Memory Address (%MB) 524287

Clearall %M addresses

|
B |

Read PLC Time
Write PLC Time

Sync with Local Time |

Read Timezone

Write Timezone

Read from PLC

Set Project IDQ

® %M mode

Clear

In the Project ID Settings dialog, enter Current Project ID. Leave New

Project ID and Confirm Project ID blank.
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&

Praject ID
Current Project 1D sane
Mew Project ID

Confirm Project 1D
Sync same D with Cnline Device

OK Cancel

3. Click OK.

9.4 Set PLC ID

Use the following steps to set PLC ID. PLC ID setup and modification only supports
AX-3 series controllers with firmware version 1.0.3.0 or later.

Prerequisites

* The controller is connected.
To set PLC ID
1. On the menu bar, select Tools > PLC ID.

2. Inthe PLC ID Setting dialog, click the Online Device dropdown menu and
then click Browse.
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E1 PLC ID Setting — X

Online Device
Gateway-1/0301.300F v
Browse...
Gateway-1/0301.300F

Device Type: 4102

Device ID: 16F7 0314

Device Version: 1.0.5.8

PLCID

New PLC ID ssnsee
Confirm PLC ID sscnse
Please also set the Project ID

s different from Project ID

the application will be removed at the next power-on.

0K Cancel

3. Inthe Select Device dialog, select the device and click OK.
4. Inthe PLC ID Setting dialog, enter New PLC ID and Confirm PLC ID.

5. Click OK.

9.5 Modify PLC Identification Code

Use the following steps to modify PLC ID.

Prerequisites

* The controller is connected.
To modify PLC ID
1. On the menu bar, select Tools > PLC ID.

2. Inthe PLC ID Setting dialog, click the Online Device dropdown menu and
select Browse.
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21 PLC ID Setting — X

Online Device
Gateway-1/0301.300F s
Browse...
Gateway-1/0301.300F

Device Type: 4102

Device ID: 16F7 0314

Device Version: 1.0.5

PLCID

Current PLC ID ssnsee

New PLC ID ssssese

Confirm PLC ID esnene

Please also set the Project ID

If the PLC ID is different from Project ID

the application will be removed at the next power-on.

0K Cancel

3. Inthe Select Device dialog, select the device and click OK.

4. Inthe PLC ID Setting dialog, enter Current PLC ID (original password), New
PLC ID (new password), and Confirm PLC ID (confirm the new password).

5. Click OK.

9.6 Clear PLC ID

Use the following steps to clear PLC ID.

Prerequistes

* The controller is connected.
To clear PLC ID
1. On the menu bar, select Tools > PLC ID.

2. Inthe PLC ID Setting dialog, click the Online Device dropdown menu and
select Browse.
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21 PLC ID Setting - X

Online Device
Gateway-1/0301.300F i
Browse...
Gateway-1/0301.300F

Device Type: 4102

Device ID: 16F7 0314

Device Version: 1.0.5.8

PLC ID

Current PLC ID ssssss

New PLC ID

Confirm PLC ID

Please also set the Project ID

If the PLC ID is different from Project ID

the application will be removed at the next power-on.

OK Cancel

3. Inthe Select Device dialog, select the device and click OK.

4. Inthe PLC ID Setting dialog, enter Current PLC ID (original password) and
leave New PLC ID and Confirm PLC ID blank.

5. Click OK.

9.7 Set Project ID and PLC ID Simultaneously

Use the following steps to set Project ID and PLC ID at the same time. PLC ID setup
and modification only supports AX-3 series controllers with firmware version 1.0.3.0
or later.

Prerequisites

* The controller is connected.

To set Project ID and PLC ID simultaneously
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1. On the Devices pane, double-click the device and then select System
Settings > Set Project ID.

Devices v 3 Xx [ Controller_1 x
=) nsteds =i Communication Settings Runtime Clock
= @ Ct?ntroller_l (AX-308EAOMA1T) I PLC Time: Read PLC Time
&8 Hardware Configuration | - .
= & Network Configuration Applications Date: l\"lednesday, August 21, 2024 B | | Write PLCTime
A, EtherCAT Topology IR Time: [10:29:20 a i | Syncuith Local Time
A EtherNetIP Topology i
A, ModbusTCP Topology Files Time Zone r
= &0 PLC Logic J PLC Timezone: Read Timezone
= o} W . .
3 Application Log Timezone: (UTC+08:00) Asia/Shanghai v Write Timezone
m Library Manager 4 : r
[£] Motion_PRG (PRG) PLC Settings Network
[E) pLc_prG (RO I Apply IP settings wihile download
+-(# Task Configuration PLC Shell .
= Builtin_IO (Builtin_10) | . ) s
@ DI0 (OI0) Licensed Software Metrics

IP Address Mode: [stati |
@ Delta_LocalBus_Master_1 (Delta LocalBus Ma . |Static e
System Settings . )
(i) EtherCAT_1 (AX Series EtherCAT Master Soff IP address: 92 .18 . 1 . 5

= m Ethernet_1 (Ethernet)

Right Settings

= @ Delta_Modbus_TCP_Master_1 (Delta Moq | | Subnet mask: L 25 . 255 .25 . 0 |
(i) Delta_Modbus_TCP_Slave_1 (DeltaN | | system Parameters Default gateway: 0.0 .0 .0
= @ EtherNet_IP_Scanner_1 (EtherNet/IP Scd | |
. AS218PX_1 (AS218PX) Task Deployment Obtain DNSserver address automatically
(i) copesYs_PROFINET Device_1 (CODESY | | (@ Usethefollowing DNSserver addresses:
3 SoftMotion General Axis Pool Status r )
i Preferred DNSserver: | 0 . 0 . 0 . 0
Information Alternate DNSserver: | 0 . 0 . 0 . 0 |
Read from PLC
| Project ID
Project ID status: Inactive | Set Project 109
‘ Persistent Retain Settings
Mode: O Original mode ® %M mode
Start Memory Address (%M8) |0
End Memory Address (%MB) 524287
Clearall %M addresses Clear
< > I

2. In the Project ID Settings dialog, enter New Project ID and Confirm Project
ID, and then select Sync same ID with Online Device.

2! Project ID Settings — X
Project ID

New Project ID ssssse

Confirm Project ID sssses

/| Sync same ID with Online Device

Online Device
Gateway-1/0301.300F v
Browse... %
Gateway-1/0301.300F

Device Type: 4102

Device ID: 16F7 0314

Device Version: 1.0.5.8

oK Cancel
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3. Browse to select the controller.
4. (optional) If the controller already has a PLC ID, enter Current PLC ID.

5. Click OK. PLC ID and Project ID are set to the same.

9.8 Modify Project ID and PLC ID Simultaneously

Use the following steps to modify Project ID and PLC ID at the same time.

Prerequisites

* The controller is connected.

To modify Project ID and PLC ID simultaneously

1. On the Devices pane, double-click the device and then select System
Settings > Set Project ID.

Devices v 3 X Eﬂ Controller_1 x
=8 hatkal = Communication Settings Runtime Clock
= controller_t (ax-308€A0MAIT) I PLC Time: Read PLC Time
o8 Hardware Configuration | h
= & Network Configuration Applications Date: l\"lednesday, August 21, 2024 D*I Write PLC Time
A, EtherCAT Topology | e erReter Time: [10:23:20 am 2] [ syncuith Local Time |
A, EtherNetlP Topology
A, ModbusTCP Topology Files Time Zone
=810 pLC Logic PLC Timezone: Read Timezone
=1 icati s
G Application Log Timezone: (UTC+08:00) Asia/Shanghai v Write Timezone
m Library Manager 1 : o
[£] Motion_PRG (PRG) PLC Settings Network
[2) pic_pre (PR) I [ Apply IP settings wihile dowinload
+- (&4 Task Configuration PLC Shell 0
"
= @ suitin_10 (Buitin_10) | ) s
@ oio 10) Licensed Software Metrics - f— -
@ Delta_LocalBus_Master_1 (Delta LocalBus Ma| . ressHoce: »Stahc M|
System Settings §
@ EtherCAT_1 (AX Series EtherCAT Master Sof{ 1P address: 192 .168. 1 . 5
= () Ethernet_1 (Ethernet) Ri : )
- ght Settings .
= @ Delta_Modbus_TCP_Master_1 (Delta Moq | | Subnet mask: .255 255 .25 . 0 |
@ Delta_Modbus_TCP_Slave_1 (Delta System Parameters Default gateway: 0.0 .0 .0
= ﬂ’i EtherNet_IP_Scanner_1 (EtherNet/IP Sc{ | |
. AS218PX_1 (AS218PX) Task Deployment Obtain DNSserver address automatically
[ copesYs_PROFINET_Device_1 (CODES (® Usethefolloving DNSserver addresses:
a SoftMotion General Axis Pool Status )
i Preferred DNSserver: | 0 . 0 . 0 . 0
Information Alternate DNSserver: | 0 . 0 . 0 . 0 |
Read from PLC
Project ID
Project ID status: Inactive Set Project 109
Persistent Retain Settings
Mode: O Original mode (® %M mode
Start Memory Address (%M8) |0
End Memory Address (%MB) 524287
Clearall %M addresses Clear
< >

2. Inthe Project ID Settings dialog, select Sync same ID with Online Device.
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1 Project 1D Settings — X
Project ID

Current Project ID sssese

New Project ID ssssse

Confirm Project ID ssssse

V| Sync same ID with Online Device
Online Device

Gateway-1/0301.300F -]

Browse... %

Gateway-1/0301.300F
Device Type: 4102
Device ID: 16F7 0314
Device Version: 1.0.5.8

PLCID

Current PLC ID sssnse

OK Cancel

3. Browse to select the controller.

4. Enter Current Project ID, New Project ID, Confirm Project ID, and Current
PLC ID.

5. Click OK. PLC ID and Project ID are set to the same.

9.9 Clear Project ID and PLC ID Simultaneously
Use the following steps to clear Project ID and PLC ID at the same time.

Prerequisites

* The controller is connected.

To clear Project ID and PLC ID simultaneously
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On the Devices pane, double-click the device and then select System
Settings > Set Project ID.

Devices v 3 X

=3 Untitied v
=) Controller_1 (AX-308EAOMA1T) o

8 Hardware Configuration
= & Network Configuration
A EtherCAT Topology
A EtherNetIP Topology
A, ModbusTCP Topology
= &0 PLC Logic
= @ Application
m Library Manager
[£] Motion_PRG (PRG)
[£] PLc_pra (RG)
+ @ Task Configuration
= Builtin_IO (Builtin_10)
[ o10 (O10)
@ Delta_LocalBus_Master_1 (Delta LocalBus Ma
Eﬁ EtherCAT_1 (AX Series EtherCAT Master Sof{
= m Ethernet_1 (Ethernet)
= @ Delta_Modbus_TCP_Master_1 (Delta Mo
@ Delta_Modbus_TCP_Slave_1 (Delta
= @ EtherNet_IP_Scanner_1 (EtherNet/IP Scd
Bl As218px_1 (as218P%)
[ copESYS_PROFINET Device_1 (CODES
3 SoftMotion General Axis Pool

[ Controller_1 x

Log

Communication Settings

Applications

Backup and Restore

Files

PLC Settings
PLC Shell

Licensed Software Metrics

System Settings Q

Right Settings
: System Parameters
‘ Task Deployment
: Status

Information

Runtime Clock
PLC Time: |
Date: l\"lednesday, August 21, 2024 D'|:
Time: [10:29:20 am B |
Time Zone
PLC Timezone:
Timezone: i(UTC-(»OB:UO) Asia/Shanghai v:
Network
Apply IP settings while download
cpswl
IP Address Mode: .Stab’c |
1P address: [192.163. 1 .5 |
Subnet mask: [255 . 255 . 255 . 0 |
Default gateway: :0 .0 .0 .0

Obtain DNSserver address automatically
(® Usethefollowing DNSserver addresses:
Preferred DNSserver: [ 0 . 0 . 0 . 0 |

Alternate DNSserver: | 0 . 0 . 0 . 0 |

| Project ID

Project ID status: Inactive

Persistent Retain Settings
Mode: (O Original mode
Start Memory Address (%M8B) |0
End Memory Address (%MB) 524287

Clearall %M addresses

Read PLC Time
Write PLC Time

Sync with Local Time

Read Timezone

Write Timezone

Read from PLC

Set Project 109

® %M mode

Clear

In the Project ID Settings dialog, select Sync same ID with Online Device.
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21 Project ID Settings -

Project ID

Current Project ID ssssse
New Project ID

Confirm Project ID

v/| Sync same ID with Online Device

Online Device

<

Gateway-1/0301.300F

Browse...

Gateway-1/0301.300F
Device Type: 4102
Device ID: 16F7
Device Version: 1.0.°
PLCID

Current PLC ID sesnse

oK Cancel

3. Browse to select the controller.

4. Enter Current Project ID and Current PLC ID. Leave New Project ID and

Confirm Project ID blank.

5. Click OK.

9.10 Set Rights

You cannot undo or redo settings on this pane. Starting from version 1.4.0, if you
select the AX-3 series controller and its version is 1.0.5.0 or later, and select Users

and Groups on the Right Settings pane, an encryption function is available for

importing and exporting management files.

To set rights

1. Create a New Project or open an existing one.

2. Connect to the network first.

te

3. Select Right Settings, and then click

to synchronize with the controller.
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m Device X
Communication Settings
Applications

Backup and Restare

Files

Log

PLC Settings

PLC Shell

Licensed Software Metrics
System Settings

Right Settings

System Parameters

| -
+ |Users and Groups * = %] [E | Device user: Anonymous

| Offline modeis not supported by the device, switchto synchronized mode to edit

4. The account password is “Administrator” by default. When logging in for the

first time, you need to change the password from the default “Administrator” to

another. If the password is lost, it can only be restored to the factory value.

9.10.1 Import Management Files

You can import users and user groups and access configurations from the local

computer.

To import management files

1.

2.

5.

On the Devices pane, double-click the controller.

On the Device editor, select Right Settings.

Click |2

Select the *.rsu2 or *.dum2 file.

The *.dumz2 file is the configuration file for all settings on the User and Groups

pane.

The *.rsu2 file is the configuration file for all settings on the Right Settings

pane.

In the synchronization mode, DIADesigner-AX only supports importing the

* . dum? file.

(optional) In the Enter Password dialog, enter Password, and then click OK.
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The password was assigned when the user management file was exported.
This encryption function is only available when you select:

o The AX-3 series controller and its version is 1.0.5.0 or later.

o Select the User and Groups pane.

Note: The import of a device user management by means of a
*.dum2 file completely overwrites the existing user management
on the device. To log in to the device again afterward, you need
authentication data from the recently imported user management.

6. Inthe Device User Logon dialog, enter Username and Password and click
OK.

7. Click < and log in again.

9.10.2 Export Management Files

You can only export users and user groups and access configurations in the
synchronization mode.

To export user management files
1. On the Devices pane, double-click the controller.

2. On the Device editor, select Right Settings.

™
3. Click L

4. Click =] to only export the configurations in the Users and Groups pane or

the Access Rights pane or click =] to export all configurations on the Right
Settings pane.

5. Enter File name, and click OK.

6. (optional) In the Enter Password dialog, enter Password.
This encryption function is only available when you select:
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o Select the User and Groups pane.

Note: You need to enter this password when importing the *.dum2 file.

7. Click OK.

9.10.3 Set up Users and Groups

You can adjust user management for the first time in a project and adjust the
definitions of users and groups to which they belong.

Prerequisites

* Turn on and synchronize the device where user management will be
established and ensure that the configuration has not been adjusted.

To add a user
1. On the Devices pane, double-click the controller.
2. On the Device editor, select Right Settings > Users and Groups.

3. Click Add next to the Users pane.

@ Controller 1 x B

Devices
=3 untited1

v 2 X

= [ controller_1 [connected] (AX-308EAOMAY
8 Hardware Configuration
= A Network Configuration
A, EtherCAT Topology
A, EtherNetIP Topology
A ModbusTCP Topology
=81 pLc Logic
= ) Application
(i Library Manager
|E] Motion_PRG (PRG)
|E] PLC_PRG (PRG)
* (& Task Configuration
=@ suilttn_Io (Buiitin_IO)
@ oro ro)
( Delta_LocalBus_Master_1 (Delta LocalBus Ma|
(i EtherCAT_1 (AX Series EtherCAT Master Sof{
= (i Ethernet_1 Ethernet)
= (i Delta_Modbus_TCP_Master_1 (Delta Mo
([ Delta_Modbus_TCP_Slave_t (Delta

Communication Settings

Applications

Backup and Restore

Files

Log

PLC Settings

PLC Shell

Licensed Software Metrics

System Settings

System Parameters

Users and Groups Q- 23 [5) [ | Device us =
othe de
Users.

mode: All changes

# 8 Usert

4. Inthe Add User dialog, enter Name, select the default group for the user being

added, and then enter Password, and Confirm password.

5. Click OK.

To add a user group
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4.

5.

On the Devices pane, double-click the controller.

On the Device editor, select Right Settings > Users and Groups.
Click Add next to the Groups pane.

Enter Name, and then select group members.

Click OK.

To modify the user password

1.

2.

On the Users pane, select the user that you want to change the password for.
Click Edit.
In the Edit User dialog, enter Password and Confirm password.

Click OK.

Users and Groups =R Device user: 123

Synchronized mode: All changes areimmediately downloaded to the device. This mode does not support undoing actions.

Users B
+-8 123 o & A

£ Import...

Name 123 4 Fdt..

&  Delete

Password

ol

Confirm password

Password strength

[] Keep password

Password can be changed by user o Add.

[[] Password must be changed at firstlogin
3 Import...
Cancel

& Edit.

9.10.4 Set up Access Rights

You can configure whether group members have the right to view, edit, or delete

objects, and add or delete sub-objects in objects.

To configure the access rights

1.

2.

On the Devices pane, double-click the controller.

On the Device editor, select Access Rights.
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>

Devices vi
=4 Untted v
= {1 Conroler_t [connected] (AX-S0BEAONALT)
o8 Hardare Configuraton
= & Nebuork Configraton
A EerCAT Topoogy
A EtherNeti Topoogy
A ModbusTCP Topdlogy
3 @J] PLC Logic
2 @ Application
m Library Manager
[ votion P86 Re)
B e o prg)
® @ Task Configuration
=) uitin 10 Buitn J0)
(f oo oro)
fﬂ Delta LocalBus_Master_1 (Delta LocalBus Mg
(1) etherCAT_1 (A SeriesEtherCAT Mastr Sof
= ﬂiEhemet_l(Eﬂwemet)
= {1 Dell Hodous TCP Mester_1 Deaog
(1) Dela_Mocbus TP Save_1 Dela

([ Controller 1 x|

Communicaton Settngs Access Rights £ [ B Deviceuser Usert
Synchronized mode: All changes are immediately downloaded to the device,
Applications Ot Rehs
Backup and Restore = L1 Rontie cbjcts ® Add/Remove Modiy View
etk At % ¢ ¢
Fls ! Logger Develper $ = &
79 Myt Senvice $ = $
Log < _COMMAND_READ_CLOCK Watch = = ¢
< _COMMAND_READ_IP
PL Setings 9 _COMMAND_SET_CLOK
ot < _GET RTS_VERSION
. 9 Fdoge
59 hoplat
Licensed Software Metrics m@ "
9 _CModulelntegration_
System Settngs 7 SachpiRestore
) Pleshel
Right Settings =+ %) RemoteComections
< OPCUAServer
System Parameters 9 Settings

3. On the Objects pane, select the object that you want to configure the access

right for.

4. On the Rights pane, double-click the access.
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